• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required. There are many reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

E1DA Cosmos ADC

trl

Major Contributor
King of Mods
Joined
Feb 28, 2018
Messages
1,980
Likes
2,544
Location
Iasi, RO
Never mind, it worked after a computer restart. I get "Verifying Success" now. Thank you all!

FW_success.png
 

dominikz

Addicted to Fun and Learning
Forum Donor
Joined
Oct 10, 2020
Messages
803
Likes
2,630
I'm astonished nobody mentioned that the ES9822Pro includes SPDIF Out. I miss syncing capabilities too. If that output would be available I could at least let the Cosmos be clock master for computer and DAC. And it would even be possible to use the Cosmos stand-alone, via SPDIF out only. According to the data sheet a simple TOSLINK transmitter would be enough to get that, no further data conversion or buffer circuits are needed.
Addition of an SPDIF/Toslink out would make me even more interested in this ADC :D, especially if stand-alone mode was supported.
It would make for a much more convenient setup if one already owns a good audio interface with SPDIF in and out.
 

trl

Major Contributor
King of Mods
Joined
Feb 28, 2018
Messages
1,980
Likes
2,544
Location
Iasi, RO
Cosmos_ADC_DC_offset_.png

D90 MQA connected to Cosmos ADC in Mono-mode (about 3.5V RMS)

Is this -95 dBFS the DC offset people was telling about? Soryy I haven't got a screenshot before performing the update provided by Ivan on the other page, so I can't compere before vs. after FW update.
 

trl

Major Contributor
King of Mods
Joined
Feb 28, 2018
Messages
1,980
Likes
2,544
Location
Iasi, RO
Pretty close to mine which is -92 dB @ 1.5 Hz. Thanks for posting back!

Below is what @pkane measured prior to FW upgrade: about -74 dB, while after the FW upgrade is -95 dB, so at least 20 dB of DC reduction.

index.php
 

pkane

Master Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
5,694
Likes
10,348
Location
North-East
Pretty close to mine which is -92 dB @ 1.5 Hz. Thanks for posting back!

Below is what @pkane measured prior to FW upgrade: about -74 dB, while after the FW upgrade is -95 dB, so at least 20 dB of DC reduction.

index.php

Yes, an improvement with new firmware, and indeed, the phase is no longer inverted.

I wonder if the DC compensation can be added as another setting to the Tweak app (@IVX ) so that I could dial it in more precisely for my ADC?
 

HpW

Member
Technical Expert
Joined
May 13, 2018
Messages
40
Likes
9
Location
Guacimara
Yes, an improvement with new firmware, and indeed, the phase is no longer inverted.

I wonder if the DC compensation can be added as another setting to the Tweak app (@IVX ) so that I could dial it in more precisely for my ADC?

ADC input 2x balanced shorted (600E) running latest FW given:

a) after startup as MONO, L -102dBFS, R -95dBFS

b) altered to Stereo, L -117dBFS, R -95dBFS

IMHO, I do not understand why each time I connect the ADC, I have to change to Stereo again, while the filter settings gets stored & remembered
 

staticV3

Master Contributor
Joined
Aug 29, 2019
Messages
7,877
Likes
12,585
ADC input 2x balanced shorted (600E) running latest FW given:

a) after startup as MONO, L -102dBFS, R -95dBFS

b) altered to Stereo, L -117dBFS, R -95dBFS

IMHO, I do not understand why each time I connect the ADC, I have to change to Stereo again, while the filter settings gets stored & remembered
Those values seem oddly low. Could you please share your ADC_INT_SEL numbers for each of the four ADCs?
 
Last edited:

HpW

Member
Technical Expert
Joined
May 13, 2018
Messages
40
Likes
9
Location
Guacimara
Those values seem oddly low. Could you please share your ADC_INT_SEL numbers for each of the four ADCs?

Connect, changing ADC selection and read SEL: >> ADC-1 : 15, ADC2..4 : 11

and each time I Connect it is on MONO again... help :eek:
 

staticV3

Master Contributor
Joined
Aug 29, 2019
Messages
7,877
Likes
12,585
Connect, changing ADC selection and read SEL: >> ADC-1 : 15, ADC2..4 : 11

and each time I Connect it is on MONO again... help :eek:
Those are the THD values, not the ADC_INT_SEL values, which you can find on the left side of the application:
unknown-2.png
 

HpW

Member
Technical Expert
Joined
May 13, 2018
Messages
40
Likes
9
Location
Guacimara
What I did, connected... and MONO
Changed the ADC-x listbox and

ADC_INT_SEL: ADC-1 = 15
ADC_INT_SEL: ADC-2 = 11
ADC_INT_SEL: ADC-3 = 11
ADC_INT_SEL: ADC-4 = 11
 

IVX

Major Contributor
Joined
Mar 3, 2019
Messages
1,421
Likes
2,789
Location
South of China, SHZ area, - Слава Україні
HpW, you did ask me in PM about MONO/STEREO, and I replied: The slider in Cosmos tweak app is only for MONO/STEREO switching. To send the command to switch the mode need to move the slider. At the same time, USB host(I guess Windows) sending UAC2 volume commands as well, so ADC responses for the last volume command received.
The Windows Volume slider position sends every time you plug Cosmos ADC to the USB. Try to change the Windows ADC volume slider to 0% and every time you connect the ADC it will be in the STEREO mode.
 

staticV3

Master Contributor
Joined
Aug 29, 2019
Messages
7,877
Likes
12,585
What I did, connected... and MONO
Changed the ADC-x listbox and

ADC_INT_SEL: ADC-1 = 15
ADC_INT_SEL: ADC-2 = 11
ADC_INT_SEL: ADC-3 = 11
ADC_INT_SEL: ADC-4 = 11
Please try setting the first one to 11 and see if your values improve
 

staticV3

Master Contributor
Joined
Aug 29, 2019
Messages
7,877
Likes
12,585
HpW, you did ask me in PM about MONO/STEREO, and I replied: The slider in Cosmos tweak app is only for MONO/STEREO switching. To send the command to switch the mode need to move the slider. At the same time, USB host(I guess Windows) sending UAC2 volume commands as well, so ADC responses for the last volume command received.
The Windows Volume slider position sends every time you plug Cosmos ADC to the USB. Try to change the Windows ADC volume slider to 0% and every time you connect the ADC it will be in the STEREO mode.
Could it be that HpW isn't using the correct driver, and so Windows is using software volume instead?
 

MC_RME

Addicted to Fun and Learning
Technical Expert
Audio Company
Joined
May 15, 2019
Messages
872
Likes
3,614
> Please try setting the first one to 11 and see if your values improve

They won't. What HpW reports is limited by DC. L -117dBFS, R -95dBFS will sum to -102dBFS in Mono Mode. Noise is lower, of course.
 

HpW

Member
Technical Expert
Joined
May 13, 2018
Messages
40
Likes
9
Location
Guacimara
Could it be that HpW isn't using the correct driver, and so Windows is using software volume instead?
UAC2 using Win 10 Pro ENG, 20H1, so I run WASAPI Exclusive.

@IVX, so far no chance to get on startup as Stereo...
 

Grooved

Addicted to Fun and Learning
Joined
Feb 26, 2021
Messages
679
Likes
441
@IVX not linked to the problem above, but I need a confirmation please : to run it in mono with both XLR inputs, we just need a standard XLR Y cable, right ?
I didn't test it yet but I want to be sure that my Y cable is what I have to use (1 female XLR > 2 male XLR)
 

pkane

Master Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
5,694
Likes
10,348
Location
North-East
Top Bottom