• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required. There are many reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

E1DA Cosmos ADC

Grooved

Addicted to Fun and Learning
Joined
Feb 26, 2021
Messages
683
Likes
446
Pretty close to mine which is -92 dB @ 1.5 Hz. Thanks for posting back!

Below is what @pkane measured prior to FW upgrade: about -74 dB, while after the FW upgrade is -95 dB, so at least 20 dB of DC reduction.

index.php

I didn't update the Cosmos firmware yet, but just tried a fast test with @pkane new tool with what I had near me (Cosmos ADC and Tone2 Pro). Note that I can't see anything lower than 10Hz on the graph (tried to zoom in/out), I don't know how to extend it further.
But it shows a difference in distorsion results if I set the analysis between 20Hz and 20kHz, or between 0Hz and 20kHz, see below :

20Hz-20kHz :
Test 1.PNG


10Hz-20kHz : same result
Test 2.PNG


5Hz-20kHz : same result (except +0.3 on level)
Test 3.PNG


0Hz-20kHz : nothing on the graph is so much different, so the change in TD+N and N+D comes from below 5Hz
Test 4.PNG
 
Last edited:

pkane

Master Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
5,788
Likes
10,562
Location
North-East
I didn't update the Cosmos firmware yet, but just tried a fast test with @pkane new tool with what I had near me (Cosmos ADC and Tone2 Pro). Note that I can't see anything lower than 10Hz on the graph (tried to zoom in/out), I don't know how to extend it further.
But it shows a difference in distorsion results if I set the analysis between 20Hz and 20kHz, or between 0Hz and 20kHz, see below :

20Hz-20kHz :
View attachment 163412

10Hz-20kHz : same result
View attachment 163414

but 0Hz-20kHz : nothing on the graph is really different, so the change in TD+N and N+D comes from below 10Hz
View attachment 163415

To see below 10Hz (default setting) go to settings by clicking on the gear icon, and change minimum frequency to 0, then rerun the test. I suggest you use the largest FFT size (1M) to see details below 1Hz:

1636125946585.png
 

Grooved

Addicted to Fun and Learning
Joined
Feb 26, 2021
Messages
683
Likes
446
To see below 10Hz (default setting) go to settings by clicking on the gear icon, and change minimum frequency to 0, then rerun the test. I suggest you use the largest FFT size (1M) to see details below 1Hz:

View attachment 163416

Thanks for the information! And thanks for this tool, will report anything on its own thread
Got the full graph now (read it too fast so I didn't change the FFT Size value on this one, will change it next)
Stayed on 5-20k, so the results are not affected, but we see the increase in the lowest part

Test 5.PNG
 
Last edited:

pkane

Master Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
5,788
Likes
10,562
Location
North-East
Thanks for the information! And thanks for this tool, will report anything on his own thread
Got the full graph now (read it too fast so I didn't change the FFT Size value on this one, will change it next)
Stayed on 5-20k, so the results are not affected, but we see the increase in the lowest part

View attachment 163420

This is consistent with what I saw in my testing before FW update.
 

trl

Major Contributor
Forum Donor
King of Mods
Joined
Feb 28, 2018
Messages
1,986
Likes
2,575
Location
Iasi, RO
Since Day1 I had troubles measuring non-balanced signals. On Motu M4 and Clarett 2Pre I get very good results, while on Cosmos ADC I get crappy ones, see below:

ODAC_v1_Cosmos_ADC_.png

ODAC v1 measured on Cosmos ADC (1 ch., Stereo mode) - SINAD of 45.5 dB

ODAC_v1_MotuM4_.png

ODAC v1 measured on Motu M4 Input #1 - SINAD of 95 dB
What am I doing wrong? It doesn't matters if I'm using an RCA - XLR cable (V+ connected to hot, V- connected to GND) or the default Cosmos ADC cables with spades, I get the same huge harmonics. It happens on all DACs but Topping D90 MQA (which has a very low output impedance).

Any thoughts, please?
 
OP
mansr

mansr

Major Contributor
Joined
Oct 5, 2018
Messages
4,685
Likes
10,717
Location
Hampshire
What am I doing wrong? It doesn't matters if I'm using an RCA - XLR cable (V+ connected to hot, V- connected to GND) or the default Cosmos ADC cables with spades, I get the same huge harmonics. It happens on all DACs but Topping D90 MQA (which has a very low output impedance).

Any thoughts, please?
What signal level is the Cosmos set for? Its input impedance is quite low, especially at the lower level settings, so you could be overloading the DAC. Try the highest setting (10 V) on the Cosmos and see if that helps.
 

trl

Major Contributor
Forum Donor
King of Mods
Joined
Feb 28, 2018
Messages
1,986
Likes
2,575
Location
Iasi, RO
It doesn't matters Cosmos's input voltage level. However, I need my measurements to be relative to 0 dBFS, so when I feed the ADC with 2V RMS I expect to work perfectly on the 2.7V setting.

However, I'm probably doing something wrong, but what intrigues me is that with D90 on RCA I get perfect results, but when I measure another DAC on RCA I get up-to-the-sky harmonics. On balanced all DACs measure perfectly, only on RCA I get this odd issue.
 
OP
mansr

mansr

Major Contributor
Joined
Oct 5, 2018
Messages
4,685
Likes
10,717
Location
Hampshire
It doesn't matters Cosmos's input voltage level. However, I need my measurements to be relative to 0 dBFS, so when I feed the ADC with 2V RMS I expect to work perfectly on the 2.7V setting.

However, I'm probably doing something wrong, but what intrigues me is that with D90 on RCA I get perfect results, but when I measure another DAC on RCA I get up-to-the-sky harmonics. On balanced all DACs measure perfectly, only on RCA I get this odd issue.
Harmonics of that magnitude are often a sign of the output being overloaded and (close to) clipping. If this is the case, increasing the input impedance should at least reduce the level of the harmonics a bit. Lowering the signal level should have the same effect. Try that too. If neither of those actions has any effect, then something else is causing the problem.
 
OP
mansr

mansr

Major Contributor
Joined
Oct 5, 2018
Messages
4,685
Likes
10,717
Location
Hampshire
Here's the DC offset of my unit with old and new firmware.

1636132110657.png
 

trl

Major Contributor
Forum Donor
King of Mods
Joined
Feb 28, 2018
Messages
1,986
Likes
2,575
Location
Iasi, RO
Harmonics of that magnitude are often a sign of the output being overloaded and (close to) clipping. If this is the case, increasing the input impedance should at least reduce the level of the harmonics a bit. Lowering the signal level should have the same effect. Try that too. If neither of those actions has any effect, then something else is causing the problem.
Signal it's -5.1 dB, so no clipping. Can you test the same DAC with both balanced and non-balanced, please? Thanks in advance!
 
OP
mansr

mansr

Major Contributor
Joined
Oct 5, 2018
Messages
4,685
Likes
10,717
Location
Hampshire
Signal it's -5.1 dB, so no clipping. Can you test the same DAC with both balanced and non-balanced, please? Thanks in advance!
It can still clip if the output driver is overloaded. Balanced or not has nothing to do with it.
 

trl

Major Contributor
Forum Donor
King of Mods
Joined
Feb 28, 2018
Messages
1,986
Likes
2,575
Location
Iasi, RO
I'm not sure I understand, sorry. The ADC can not clip at -5 dB and the DAC is not clipping for sure. I can go to -25 dB, same high harmonics.
 
OP
mansr

mansr

Major Contributor
Joined
Oct 5, 2018
Messages
4,685
Likes
10,717
Location
Hampshire
The output stage of the DAC can't deliver enough current for the load presented by the cosmos so it's clipping.
We can't say for sure that that's what's happening to @trl, but it's something I have seen with a couple of DACs connected to the Cosmos.
 

trl

Major Contributor
Forum Donor
King of Mods
Joined
Feb 28, 2018
Messages
1,986
Likes
2,575
Location
Iasi, RO
All of my DACs but D90 act the same. What load? It's just the DAC connected directly to the Cosmos ADC, without any load interconnected. I'll dive deep into this more during this weekend, but would be more helpful if others will please test this ADC with RCA outputs from different DACs. Thanks!
 
OP
mansr

mansr

Major Contributor
Joined
Oct 5, 2018
Messages
4,685
Likes
10,717
Location
Hampshire
All of my DACs but D90 act the same. What load? It's just the DAC connected directly to the Cosmos ADC, without any load interconnected. I'll dive deep into this more during this weekend, but would be more helpful if others will please test this ADC with RCA outputs from different DACs. Thanks!
The Cosmos input impedance is quite low, about 1 kΩ at the 2.7 V setting. That's a lot less than many DACs are built to drive. Try something with a headphone output.
 

staticV3

Master Contributor
Joined
Aug 29, 2019
Messages
8,717
Likes
14,075
All of my DACs but D90 act the same. What load? It's just the DAC connected directly to the Cosmos ADC, without any load interconnected. I'll dive deep into this more during this weekend, but would be more helpful if others will please test this ADC with RCA outputs from different DACs. Thanks!
The Cosmos ADC is the load. Most DACs expect a load of tens to hundreds of kΩ, so much more than the Cosmos ADC's input impedance.
 
OP
mansr

mansr

Major Contributor
Joined
Oct 5, 2018
Messages
4,685
Likes
10,717
Location
Hampshire
@IVX, sometimes reading the various settings returns bogus values (usually but not always zero). What's with that? It happens with both your tweak application and mine.
 

trl

Major Contributor
Forum Donor
King of Mods
Joined
Feb 28, 2018
Messages
1,986
Likes
2,575
Location
Iasi, RO
The Cosmos ADC is the load. Most DACs expect a load of tens to hundreds of kΩ, so much more than the Cosmos ADC's input impedance.
Then Cosmos is unable to be used with most DACs in unbalanced operation? Anyone here cares to actually test some DACs in on RCA outputs, please?
 
Top Bottom