• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required. There are many reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

Matrix Audio X-SABRE 3 DAC/Streamer Official Thread

OP
enricoclaudio

enricoclaudio

Major Contributor
Audio Company
Joined
Jan 7, 2021
Messages
1,109
Likes
2,193
Location
Houston, TX - USA
I'm testing right now 1.0.4 Build 001, which like I mentioned before, is a Beta firmware that is fixing some network related bugs and introducing new functions.
 

officialsm

Member
Joined
Apr 6, 2021
Messages
99
Likes
14
I'm testing right now 1.0.4 Build 001, which like I mentioned before, is a Beta firmware that is fixing some network related bugs and introducing new functions.
I was testing 1.0.4 and today i had again the freezing issue after days. The same for you or not?
 
OP
enricoclaudio

enricoclaudio

Major Contributor
Audio Company
Joined
Jan 7, 2021
Messages
1,109
Likes
2,193
Location
Houston, TX - USA
I was testing 1.0.4 and today i had again the freezing issue after days. The same for you or not?

Yes, mine froze about 8 hours ago. I sent and email to Wei ( @MatrixAudio ) and he said their Dev team found that B001 was causing the No Network bug as well and they just released B003. I updated mine to Build003 as soon Wei told me to do so. Let's see if this Build fix the No Network issue. Check if your shows B003 available. If not, you have to email @MatrixAudio and ask him to take your unit out of the Beta program and enable it for general public firmware releases then you will be able to update to 1.0.4 Build003.
 

Charlie

Member
Joined
Jan 18, 2022
Messages
21
Likes
4
I also encountered the problem with 1.0.4. The build003 version is loading.
But all updates are very long since the update integrating ma remote.
The remote control supplied with the xsabre is not operational. The battery drains immediately...it is unusable. @MatrixAudio is considering something because the new RM4 remote control is expensive.
 
OP
enricoclaudio

enricoclaudio

Major Contributor
Audio Company
Joined
Jan 7, 2021
Messages
1,109
Likes
2,193
Location
Houston, TX - USA
I also encountered the problem with 1.0.4. The build003 version is loading.
But all updates are very long since the update integrating ma remote.
The remote control supplied with the xsabre is not operational. The battery drains immediately...it is unusable. @MatrixAudio is considering something because the new RM4 remote control is expensive.

Yes, the RM4 remote is a bit expensive but worthy. I got it about 1 month ago and it is most definitely a much better remote than the RM3.
 
OP
enricoclaudio

enricoclaudio

Major Contributor
Audio Company
Joined
Jan 7, 2021
Messages
1,109
Likes
2,193
Location
Houston, TX - USA
I have no bugs since latest firmware update, 1.0.4 Build003.
 

VintageFlanker

Major Contributor
Forum Donor
Joined
Sep 20, 2018
Messages
4,992
Likes
20,076
Location
Paris
@amirm
Review this, man. :)
Are you going to send it to him?

Anyway, I did the job, already:
;)
 
OP
enricoclaudio

enricoclaudio

Major Contributor
Audio Company
Joined
Jan 7, 2021
Messages
1,109
Likes
2,193
Location
Houston, TX - USA

tensor9

Active Member
Forum Donor
Joined
Jun 26, 2018
Messages
149
Likes
90
Are you going to send it to him?

Anyway, I did the job, already:
;)
I noticed some weird distortion patterns and channel imbalance and want to verify it.
 

officialsm

Member
Joined
Apr 6, 2021
Messages
99
Likes
14
Anyone made comparison about streaming throught embebbed UPNP/DNLA client versus externale streamer using X-Sabre 3 as pure dac only?
 
OP
enricoclaudio

enricoclaudio

Major Contributor
Audio Company
Joined
Jan 7, 2021
Messages
1,109
Likes
2,193
Location
Houston, TX - USA
Yep, also my element i2 got an update today.
 

Charlie

Member
Joined
Jan 18, 2022
Messages
21
Likes
4
the update of MA remote application has a bug. It finds my nas but no longer displays the music... do you have this problem?
 
OP
enricoclaudio

enricoclaudio

Major Contributor
Audio Company
Joined
Jan 7, 2021
Messages
1,109
Likes
2,193
Location
Houston, TX - USA
It's working for me when playing from my Synology DS1520 NAS. I updated my SABRE-3 to latest firmware and MA app as well.
 

Charlie

Member
Joined
Jan 18, 2022
Messages
21
Likes
4
My nas is a Synology ds220j. with bubble upnp it works again but not with ma remote.
 
Top Bottom