• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Matrix Audio X-SABRE 3 DAC/Streamer Official Thread

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
Hi guys, today got delivery of the New Matrix Audio X-SABRE 3 DAC/Streamer which is the updated version of the X-SABRE PRO MQA reviewed by @amirm exactly 2 years and 2 days ago.

First let me tell you that I'm a big fan of Matrix Audio products. They are to me the Oppo of streamers. Their products show a level of quality and attention to detail that excels over other companies, including some that charge almost 3 times for products with even less performance. I got a Matrix Audio mini-i Pro 3 at the beginning of the year and I have been using it every single day for about 6 hours every day without a single glitch. I use Roon as my streaming platform with local library stored in a Synology DS1019+ NAS, Qobuz and TIDAL services and everything works like a charm. I also have an ARCAM ST60 and Bluesound NODE. All 4 streamers are Roon Ready and all of them work perfectly fine in my Roon ecosystem.

Here some photos of the unboxing process:


IMG_7930.jpeg


IMG_7931.jpeg


IMG_7932.jpeg


Attention to details:

IMG_7933.jpeg


IMG_7934.jpeg


IMG_7935.jpeg


Here it is:

IMG_7936.jpeg


Top is tempered glass. Did I said that this thing weights a TON?

IMG_7937.jpeg


Rear connections:

IMG_7939.jpeg


IMG_7940.jpeg


IMG_7941.jpeg


Bottom:

IMG_7942.jpeg


X-SABRE 3 next to mini-i Pro 3:

IMG_7943.jpeg


IMG_7944.jpeg


Screen:

IMG_7947.jpeg


IMG_7948.jpeg


Paired with Raspberry Pi 4 and Display with RoPieee to show metadata as the X-SABRE 3 screen is too small to show metadata:

IMG_7949.jpeg


IMG_7950.jpeg


IMG_7956.jpeg


Full desk system:

IMG_7952.jpeg


IMG_7953.jpeg


Want to thanks @MatrixAudio for answering all my questions before making my purchase. Also asking @MatrixAudio officially to send one of these bad boys to @amirm for testing and review ;)

I will post my listening impressions in a few hours after listening to my favorite "Calibration" playlist but as of right now, I have found a couple of minor bugs (not deal breaker but certainly annoying) that pretty sure can be fixed in a future firmware update. Feel free to ask any question regarding the X-SABRE 3 functionality and I will do the proper test.
 
Last edited:
OP
enricoclaudio

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
Reserved.
 
OP
enricoclaudio

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
@MatrixAudio still listening but all I can tell after one hour of critical listening is that this thing sounds AMAZING!!! Such a great DAC/Streamer you got in here!!

Here a few bugs that I found that pretty sure you can fix with a firmware update.

1.- Auto Sleep function from Roon works most of the time but not always. So decided to leave the SABRE-3 to control the Auto Sleep and not Roon but would be great if you fix it. If I turn ON or OFF the X-SABRE 3 from Roon, always work but the Auto Sleep not always.

2.- If the X-SABRE 3 is on Standby and I start playing a song from Roon, I get this message on Roon screen:
IMG_7961.jpeg


Then after the message is gone and the X-SABRE 3 is fully ON, then I can start playing. This does not happens with the mini-i Pro 3. Looks like the mini-i Pro 3 wakes up faster so Roon is able to take control over it again. The X-SABRE 3 most likely is timing out as it takes longer to wake up from Standby. BTW, this happens as well with my ARCAM ST60 Streamer when on Standby so you are not alone but it does not happens with the mini-i Pro 3 so if this can be fixed, would be great.

3.- Here we go with MQA playing. When pausing a MQA song, then replay, the song starts for about 1 sec, then stops then starts again with a fade in. All MQA songs start with a fade in, no matter if there is no change in sampling rate. You can see in the X-SABRE 3 screen that the sampling rate goes from PCM to nothing then to MQA and during the transition is when the stop and resume happens. This does not happens with the mini-i Pro 3. This issue only happens with MQA songs. PCM has no issues and no fade in. I remember a few similar bugs were fixed in the mini-i Pro 3 with the latest firmware update. What I call fade in is what Roon calls Crossfade which I have set at 0 secs. I checked with the X-SABRE 3 connected directly via USB to my iMac and when playing with TIDAL app, all the issues reported are present as well and only with MQA songs.

4.- I'm already in the latest firmware as I checked the firmware and a new one was available. Mine is on SW:V1.01 Build043.

@MatrixAudio let me know if I need to do something in the settings or in Roon to fix these issues or if only can be fixed with a firmware update.
 
Last edited:

MatrixAudio

Active Member
Manufacturer
Joined
Jun 5, 2019
Messages
176
Likes
368
Location
Xi'an China
Congratulations, this might be the first open box thread and bug report of X-SABRE 3 in the world. lol :facepalm:
We have received your feedback and forwarded to our dev team, they will get into it as soon as possible. Once there is progress of fixing the bugs, we'll let you know.
Thanks for purchasing Matrix Audio products! :D
 
OP
enricoclaudio

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
Congratulations, this might be the first open box thread and bug report of X-SABRE 3 in the world. lol :facepalm:
We have received your feedback and forwarded to our dev team, they will get into it as soon as possible. Once there is progress of fixing the bugs, we'll let you know.
Thanks for purchasing Matrix Audio products! :D

Thanks for taking care of this ;)
 
OP
enricoclaudio

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
I don't want to come across as being too critical, but I see a bit of free space on that desk where you could fit more devices

LOL, and you haven’t see my other rooms :) I guess this is the advantage of working and making a living of your hobby. I’m full time Technologies Manager and Sound Engineer at a big church and also work since 2010 for Rythmik Audio Subwoofers !!!
 

vollertam

New Member
Joined
Nov 18, 2019
Messages
1
Likes
0
I am interested in this dac. Is that possible to open up and take a look inside the component. Thanks
 
OP
enricoclaudio

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
While I would love to see the internals I for sure not going to open mine but at least take a look at this blurry picture!!!

3923ADC4-77E3-4633-81B4-E5839B345819.png
 
Last edited:
OP
enricoclaudio

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
There is bug with TIDAL Connect. There is gap between songs of 4 secs. Also, it takes 4 secs to start a song after you press play when streaming via TIDAL Connect. However, Spotify Connect works perfectly, same for Airplay.
 

Mansinthe86

Active Member
Joined
Jul 19, 2021
Messages
182
Likes
72
How about qobuz? I don't get why people still use tidal, after MQA turned out to be a lossy scam.
 
OP
enricoclaudio

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
I have both services and Qobuz with Roon works just fine. That’s the service I’m currently using until MQA playback bugs are fixed. However, there is no Qobuz native integration in the X-SABRE3. You have to use a third party app to stream Qobuz, like mConnect app.

018A5193-B187-4A9C-896B-C2AF1DE74F63.png
 

Docmoggy

Member
Joined
Mar 13, 2021
Messages
31
Likes
8
Hi

Is there a facility like V-Tuner to stream internet radio stations. Doesn’t work with mconnect.
 
OP
enricoclaudio

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
Hi

Is there a facility like V-Tuner to stream internet radio stations. Doesn’t work with mconnect.

I use the X-SABRE 3 and all my streamers with Roon as I have a Lifetime Roon subscription and Roon offers hundreds of radio stations.
 
OP
enricoclaudio

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
BTW, I have been listening to to my favorite music with the X-SABRE 3 for the last 3 days. If I need to pick a single word to describe its sound signature, I would pick "Sublime". Started listening to music this morning at 10 am and 5 hours later still sitting here and can't leave my desk. It's addictive. As soon @MatrixAudio gets the bugs fixed, this could be one of the best streamers currently in the market. Even with the current MQA and TIDAL Connect bugs, which do not affect sound quality, I can surely recommend it.
 
OP
enricoclaudio

enricoclaudio

Senior Member
Manufacturer
Joined
Jan 7, 2021
Messages
327
Likes
436
Here is an updated list of the X-SABRE 3 Bugs discovered and reported as of today:

1. Auto Sleep function from Roon works most of the time but not always.

2. TIDAL Connect have a gap between songs of 4 secs when skipping tracks. It takes 4 secs for any song to start playing. Meaning there is no gapless playback

3. When playing Tidal Connect, once pause then play again there will be a short fade in occur.

4. Playing MQA, when pausing a MQA song, then replay, the song starts for about 1 sec, then stops then starts again with a fade in. All MQA songs start with a fade in, no matter if there is no change in sampling rate.

5. If X-SABRE 3 is on Standby and start playing a song from Roon, will get “Failed to open the Audio Device” error message on Roon. Pressing play twice makes the error message go away.

6. When playing with Roon DSD files at 2.8 or 11.2, no matter the sampling rate, if pause the song, as soon I press play again, there is a loud POP coming out of the speakers.

7.- PCM (FLAC) songs get cut by about 100ms to 250ms at the beginning of the song. This only happens with some songs, not all of them and mostly with songs from Qobuz.

None of the bugs reported happens with the Matrix Audio mini-i Pro 3 which I also own and it’s next to the X-SABRE 3 so it’s easy for me to discover new bugs.

@MatrixAudio was able to replicate all the bugs reported above and they are already working to fix all of them. I also provided Matrix Audio with videos showing these bugs and songs playlist so they can easily replicate all the bugs discovered. @MatrixAudio response to all my bug reports have been spot on. We are in constant communication over email and chat. The only issue is time zone so all responses get delayed by 13 hours LOL.

A new bug that happened this morning while listening to some music:

The X-SABRE 3 screen got frozen. The X-SABRE 3 was playing but the screen remained with the same album cover for more than 10 songs. Skipping tracks had no change on the screen but the new track was playing. Tried to put it on standby with Roon, with the remote and with the standby X-SABRE 3 front panel power/standby button but after 1 sec on standby came back ON with the same album cover. Changing inputs did not solve the issue. I had to take the power cord out and after fully reboot the X-SABRE 3 screen cleared up. I know this could happen as it’s literally a computer and computers froze from time to time but it’s worthy to check if this is due to a firmware bug or just normal computer stuff.
 
Top Bottom