• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Review and Measurements of Matrix Audio Element X DAC/Streamer/Amp

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
Thanks for letting me know.
By the way, did you try to control the element M by some other 3rd party app?
Hi, missed your post. No I only use MA Remote on my iPhone to control the device. I haven’t managed to reproduce the skip problem, but almost every time when I play a playlist in tidal, it stops in the middle for no reason, and I had to press play again to continue. Sometimes it reload all songs in the playlist so I had to play from the top again.
Just to add, if you have Tidal license why not ask Tidal to put your products under supported devices page?
 

aigo

Member
Joined
Oct 14, 2020
Messages
85
Likes
33
Understand your frustration, but why you waiting so much until Matrix resolve these issues? Matrix devices work almost perfectly with Roon, so you can setup Roon server on chip PC, plug your external hard drive and connect NAS. DSD will also work flawlessly. I never trust to any audio manufacturer in software development. So I use Roon for several years without any major issues.
Eh, plug external hard drive and connect NAS, DSD will also work flawlessly - if saying so only made it so. :)
 
Joined
Feb 15, 2021
Messages
13
Likes
0
Just speak of myself, I bought element M because I want streamer that supports Tidal MQA without the need of Roon. Whether Roon worth the cost I can’t comment, but if I had Roon I will probably go for a cheaper endpoint like rpi4 plus a decent DAC for half of the price. For the premium I paid for element M I suppose to get much smoother experience.
I'm in the same boat... some of the nagging MA Player issues (random skipping to next track, occasional MA Player shutdown when adding tracks, some of the UI wierdness (cut off track list in a search), etc are really annoying for a premium priced product.
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
Thanks for the detailed information.
For the partnership, if you need, I can send a copy of the license agreement between Matrix and Tidal.

When the issue happens, if your local music (in USB storage devices) could playback continiously?
Hi just want to flag the problem is still unresolved. The device only play about for 30 mins for any playlist or album from Tidal, then it stops. It DOES still make random skips when play queue in consume mode (I turned it off so the info from my previous post wasn’t correct) I don’t have local usb storage so can’t test that unfortunately.
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
I'm in the same boat... some of the nagging MA Player issues (random skipping to next track, occasional MA Player shutdown when adding tracks, some of the UI wierdness (cut off track list in a search), etc are really annoying for a premium priced product.
I can only use it as DAC due to the Tidal playback issue, but I can get a DAC with better quality for half of the price :-(
Very unhappy about the issues, who cares about sound quality if the device isn’t even able to play a complete album from start to end?
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
Thanks for letting me know.
By the way, did you try to control the element M by some other 3rd party app?
In which case would the device skip a song from Tidal playlist? Could it be some buffer issue so when the buffer is full it doesn’t try to load songs? Although I don’t think there is any network issue in my setup, but due to the low speed network card and 802.11N WiFi, can the device skip songs when there is a high latency? Does it ever retry in such scenarios?
And any concrete plan to support Tidal connect for element series?
 
Joined
Feb 15, 2021
Messages
13
Likes
0
In which case would the device skip a song from Tidal playlist? Could it be some buffer issue so when the buffer is full it doesn’t try to load songs? Although I don’t think there is any network issue in my setup, but due to the low speed network card and 802.11N WiFi, can the device skip songs when there is a high latency? Does it ever retry in such scenarios?
And any concrete plan to support Tidal connect for element series?
Just as an FYI, I have similar issues with Qobuz - but seemingly less through Qobuz over Roon.
 

Archsam

Active Member
Joined
Apr 8, 2020
Messages
296
Likes
439
Location
London, UK
Just noticed this morning version 2.2.8 of the MA Remote app is now available. Has anyone tried it?
 

Archsam

Active Member
Joined
Apr 8, 2020
Messages
296
Likes
439
Location
London, UK
Very slow. I mean, really slow. But it does scan the NAS entirely, although takes ages. Overall same rubbish as before.
All I want is a stable app - 2.2.7 for some reason freezes when I try to play songs from my NAS, I can see all the files fine, but if I select 'add to end of queue', or just select to play an individual song, it was completely unresponsive.

This did not happened right away, but it occurred once after I was using the internet radio feature, and a second time in the middle of music playback. Both times I had to uninstall and reinstall the app.

I am also being put on the beta firmware testing team by MA, currently running FW C02001, and one thing I noticed is it will not allow me to rescan my wifi network (i.e. hold down the big knob for 5 seconds to get into set up mode). Luckily I don't have the need yet but if I do, I'll be buggered because I have no idea how to 'undo' firmware.
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
Tried the new iOS version, same problem. Playback stops randomly after a few songs. It makes random skips and eventually gives up.
@MatrixAudio: any update on the issue?
 
Joined
Feb 15, 2021
Messages
13
Likes
0
I'm going wireless through Asus RT-AC88U. There's definitely something about the MA Player/streamer handling of sub-optimal wifi conditions that's causing the odd behavior. for me, it's more likely to occur (I'm using Qobuz) when streaming HiRes 96k streams. Which Roon handles fine because it buffers on the Roon Core first. But even Roon has the track skipping issues when taxed (eg. when I make Roon do upsampling to 368k or 768k streams :)). The wireless N bandwidth is just not adequate as my Roon Core is also on WiFi on the same wireless router. So it has to download a 96k stream and then restream it out as 384 or 768k. when it bottlenecks on the wifi, it does the same thing you're describing.
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
I'm going wireless through Asus RT-AC88U. There's definitely something about the MA Player/streamer handling of sub-optimal wifi conditions that's causing the odd behavior. for me, it's more likely to occur (I'm using Qobuz) when streaming HiRes 96k streams. Which Roon handles fine because it buffers on the Roon Core first. But even Roon has the track skipping issues when taxed (eg. when I make Roon do upsampling to 368k or 768k streams :)). The wireless N bandwidth is just not adequate as my Roon Core is also on WiFi on the same wireless router. So it has to download a 96k stream and then restream it out as 384 or 768k. when it bottlenecks on the wifi, it does the same thing you're describing.
I’m just guess it could be something to do with the buffer - maybe some tiny network latency (with or without WiFi) can cause strange issue with the buffer, and there is no retry logic. I thought it was only a problem with tidal. In theory 802.11n is good enough for hires music, but I’ve experienced problems with both WiFi and ethernet.
 

MatrixAudio

Active Member
Manufacturer
Joined
Jun 5, 2019
Messages
166
Likes
344
Location
Xi'an China
Hi, missed your post. No I only use MA Remote on my iPhone to control the device. I haven’t managed to reproduce the skip problem, but almost every time when I play a playlist in tidal, it stops in the middle for no reason, and I had to press play again to continue. Sometimes it reload all songs in the playlist so I had to play from the top again.
Just to add, if you have Tidal license why not ask Tidal to put your products under supported devices page?
Hi Somy,
Tidal have updated their partner page weeks ago. Please check it. https://tidal.com/supported-devices
Thanks for your feedback, we will continue to investigate the issue.
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
Hi Somy,
Tidal have updated their partner page weeks ago. Please check it. https://tidal.com/supported-devices
Thanks for your feedback, we will continue to investigate the issue.
Hi, thanks for coming back - looks like others also experience similar problem with other streaming service provider.
For me this problem happens very randomly:
1) It works fine without issue for some days
2) It stops right after 1st song of any playlist/album from Tidal
3) It stops in the middle of a Tidal playlist
When 2 (not sure about 3 as it's more difficult to test) happens it doesn't help to only restart the streamer. I found that restart streamer, sign off tidal, uninstall app, re-install app, sign in Tidal, and it solves the problem (not always though).
Are you able to reproduce the issues? Could it some local cache of Tidal playlist URL which is invalidated by Tidal due to change to the playlist?
 
Top Bottom