• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Review and Measurements of Matrix Audio Element X DAC/Streamer/Amp

Joined
Oct 14, 2020
Messages
85
Likes
33
I got the MA Remote 2.2.7 update plus the B91901 FW a few days ago. I am overjoyed to see the internet radio function added under streaming, I will be using this feature a lot.

However the NAS connection now has 2 issues:
  1. my NAS drive is now permanently displayed as 'Disconnected' when in fact it is connected.
  2. The 'rescan' function has been removed - this is annoying because when I add new music to my NAS I cannot rescan to incorporate the new files. I can see the app is now scanning in the background, but I really appreciate the ability to rescan myself. How often does the app update the database? If I add new music to the NAS how do I add it to the library and how soon?
@MatrixAudio can you please advise on the NSA library issue?

Edit: one more thing - ALL my album art don't show up when playing songs from my NAS library - they used to work (mostly) in the older versions of MA remote?
I think we all have to agree at some point, that what is brought to you by the garbage makers will always remain as such. I have MA Element X, it was advertised as the most universal, the best streamer/player there is. And what do I get? - 4tb external hard drive can not be scanned in one go. In fact it may take a week to finally see all the titles. Same goes for the NAS; it either does not show all the titles there are; stops on rescan, or drops it altogether. Playing DSD files is out of question, there is always this loud click between the titles. I asked them, they said it would be addressed in the next update, and that never came. I am not holding my breath. Playing hi-res files from NAS is also problematic, oftentimes the stream will come as if it is from a very dirty LP. Unlistenable. The remote must have been written by who knows who - it is an absolute, horrible junk! And on and on and on .. I mean, seriously, is not there something about made in China? So there you have it, enjoy! As for me, never again!
 
Joined
Aug 20, 2020
Messages
18
Likes
6
Understand your frustration, but why you waiting so much until Matrix resolve these issues? Matrix devices work almost perfectly with Roon, so you can setup Roon server on chip PC, plug your external hard drive and connect NAS. DSD will also work flawlessly. I never trust to any audio manufacturer in software development. So I use Roon for several years without any major issues.
 
Last edited:
Joined
Jan 30, 2020
Messages
18
Likes
3
I think we all have to agree at some point, that what is brought to you by the garbage makers will always remain as such. I have MA Element X, it was advertised as the most universal, the best streamer/player there is. And what do I get? - 4tb external hard drive can not be scanned in one go. In fact it may take a week to finally see all the titles. Same goes for the NAS; it either does not show all the titles there are; stops on rescan, or drops it altogether. Playing DSD files is out of question, there is always this loud click between the titles. I asked them, they said it would be addressed in the next update, and that never came. I am not holding my breath. Playing hi-res files from NAS is also problematic, oftentimes the stream will come as if it is from a very dirty LP. Unlistenable. The remote must have been written by who knows who - it is an absolute, horrible junk! And on and on and on .. I mean, seriously, is not there something about made in China? So there you have it, enjoy! As for me, never again!
To me, on the other hand, everything works very well. 4tb HD is displayed in less than a minute, with all files and directories. The remote app with new update work with no iusses. Very strange
 
Joined
Feb 15, 2021
Messages
13
Likes
0
Hi Element X users and @MatrixAudio ....
After reading 37 pages, I still have a couple of questions that I hope some of you can help with:

1) is there a measured sound quality difference between the Element X and the Element M (or even the Element I)? I get the Element X is more future proofed and has balanced headphone out and the better chips/processors etc. But what is the SQ difference if any?

2) is there resolution for using the Element X connected directly to an Amp (in my case a tube amp)? this would be a deal-breaker for me if it doesn't work with it's full audio quality.

3) are the newer Element X being shipped with the AC WiFi card?

4) how would you connect a subwoofer to this?

thanks!
 
Last edited:
Joined
Jan 30, 2020
Messages
18
Likes
3
Hi Element X users and @MatrixAudio ....
After reading 37 pages, I still have a couple of questions that I hope some of you can help with:

1) is there a measured sound quality difference between the Element X and the Element M (or even the Element I)? I get the Element X is more future proofed and has balanced headphone out and the better chips/processors etc. But what is the SQ difference if any?

2) is there resolution for using the Element X connected directly to an Amp (in my case a tube amp)? this would be a deal-breaker for me if it doesn't work with it's full audio quality.

3) are the newer Element X being shipped with the AC WiFi card?

4) how would you connect a subwoofer to this?

thanks!
For point one:
I tried Element X and M with headphones and I don't remember a clear difference and maybe element M impressed me the most. But I bought Element X to have balanced input for the headphones
 
Joined
Feb 15, 2021
Messages
13
Likes
0
From my experie

For point one:
I tried Element X and M with headphones and I don't remember a clear difference and maybe element M impressed me the most. But I bought Element X to have balanced input for the headphones
Thanks - I'm not sure my pair of Meze Classics will enable me to tell the difference between the balanced feed - but that feature falls into the "future-proofing" benefit for me.
 
Joined
Jun 22, 2019
Messages
36
Likes
3
Does the remote control work beyond 2 meters? I have the RM3 model. The battery is new. If I try to use the remote at 3 meters, the signal does not reach Element X. I have to be very close for it to work. Is it a factory defect or is it normal? Thanks!
 

MatrixAudio

Active Member
Manufacturer
Joined
Jun 5, 2019
Messages
166
Likes
344
Location
Xi'an China
I got the MA Remote 2.2.7 update plus the B91901 FW a few days ago. I am overjoyed to see the internet radio function added under streaming, I will be using this feature a lot.

However the NAS connection now has 2 issues:
  1. my NAS drive is now permanently displayed as 'Disconnected' when in fact it is connected.
  2. The 'rescan' function has been removed - this is annoying because when I add new music to my NAS I cannot rescan to incorporate the new files. I can see the app is now scanning in the background, but I really appreciate the ability to rescan myself. How often does the app update the database? If I add new music to the NAS how do I add it to the library and how soon?
@MatrixAudio can you please advise on the NSA library issue?

Edit: one more thing - ALL my album art don't show up when playing songs from my NAS library - they used to work (mostly) in the older versions of MA remote?
Hi their
This is a known issue, we have solved the issue by a beta firmware version and validated successfully.
We will release the update soon.
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
Hi somy,
This issue is solved by the latest app update, now you can update it from App Store.
The tracks in the playlists created by Tidal have different copyright license in different countries. The quantity of the tracks in the playlist is the total number, due to the listener's location, the quantity of playable tracks is less than the total number. When you add the entire playlist to the play queue, the old version MA app added all the tracks to the play queue, so you saw it skipps many tracks until the track is playable.
In the latest version app, the unplayable tracks will be displayed gray, and cannot be added to the play queue.
This is the changelogs of new firmware and apps.
https://www.matrix-digi.com/en/news/20210204528.html
Sorry I have to report the issue came back yesterday and I had to hard restart the device to fix it. Regarding your explanation of copyright I don’t see any track greyed out and normally I’m allowed to play all of them. If you see in my video it skips most of the tracks, so I don’t think it’s the root cause of the issue. Anyways the issue yesterday is slightly different, it play one song then stops without skipping through the list. I had to manually click next song to continue. What’s the status of Tidal Connect and do you plan to support it on element x/m/I?
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
Does the remote control work beyond 2 meters? I have the RM3 model. The battery is new. If I try to use the remote at 3 meters, the signal does not reach Element X. I have to be very close for it to work. Is it a factory defect or is it normal? Thanks!
If the battery is new you might have an issue. I’m currently using harmony hub to control on/off and it works even the harmony is sitting on another shelf of my av rack.
 

MatrixAudio

Active Member
Manufacturer
Joined
Jun 5, 2019
Messages
166
Likes
344
Location
Xi'an China
Sorry I have to report the issue came back yesterday and I had to hard restart the device to fix it. Regarding your explanation of copyright I don’t see any track greyed out and normally I’m allowed to play all of them. If you see in my video it skips most of the tracks, so I don’t think it’s the root cause of the issue. Anyways the issue yesterday is slightly different, it play one song then stops without skipping through the list. I had to manually click next song to continue. What’s the status of Tidal Connect and do you plan to support it on element x/m/I?
Can you check the Playing page in MA app, did the Single Repeat icon is enabled?
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
Can you check the Playing page in MA app, did the Single Repeat icon is enabled?
It is off - this happened to me again today, start with a playlist, it stops after every single song, it is exactly the same as the video I posted.
Given that your devices are not listed under Tidal supported devices page, I’d like to ask how did you implement tidal integration? Is it through the legal way?

Edit: just add a little more description of the problem:
1) the issue happens randomly, it works fine some days but doesn’t work some other days
2) today I tried a hard restart but it didn’t solve the problem
3) it has no connection to network quality, I’m currently connect the device with ethernet cable, and I have 1000m fiber connection
4) I don’t experience such issue with any other tidal player such as audirvana and mconnect
5) it happens to all tidal playlists and albums, I find no workaround yet so half of the time I can’t use it
6) there is no copy right issue, I can play every song one by one, I can even skip songs, however it always stops after playing the 1st song
7) I have to ask how do you integrate to tidal? Could Tidal block your device for some reason?

I have tried the following without luck:
1) restart the device
2) switch between WiFi and Lan
3) logout/login tidal via ma remote
4) reinstall the app

None of the above work.
 
Last edited:

MatrixAudio

Active Member
Manufacturer
Joined
Jun 5, 2019
Messages
166
Likes
344
Location
Xi'an China
It is off - this happened to me again today, start with a playlist, it stops after every single song, it is exactly the same as the video I posted.
Given that your devices are not listed under Tidal supported devices page, I’d like to ask how did you implement tidal integration? Is it through the legal way?

Edit: just add a little more description of the problem:
1) the issue happens randomly, it works fine some days but doesn’t work some other days
2) today I tried a hard restart but it didn’t solve the problem
3) it has no connection to network quality, I’m currently connect the device with ethernet cable, and I have 1000m fiber connection
4) I don’t experience such issue with any other tidal player such as audirvana and mconnect
5) it happens to all tidal playlists and albums, I find no workaround yet so half of the time I can’t use it
6) there is no copy right issue, I can play every song one by one, I can even skip songs, however it always stops after playing the 1st song
7) I have to ask how do you integrate to tidal? Could Tidal block your device for some reason?

I have tried the following without luck:
1) restart the device
2) switch between WiFi and Lan
3) logout/login tidal via ma remote
4) reinstall the app

None of the above work.
Thanks for the detailed information.
For the partnership, if you need, I can send a copy of the license agreement between Matrix and Tidal.

When the issue happens, if your local music (in USB storage devices) could playback continiously?
 
Joined
Feb 15, 2021
Messages
13
Likes
0
@somy and @MatrixAudio : not sure if this helps but I had a very similar problem when streaming from Deezer App output my laptop to my Sprout100 (as a DAC/PreAmp). I had to switch the laptop's output between the local soundcard and the USB/Sprout100 to make it reset. But the same thing will randomly happen between tracks. Locally caching/buffering the tracks seemed to help some of the time.

When I switched to QuBoz's player, the problem went away.
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
Thanks for the detailed information.
For the partnership, if you need, I can send a copy of the license agreement between Matrix and Tidal.

When the issue happens, if your local music (in USB storage devices) could playback continiously?
I haven’t tried that, today it works fine again and will try local music when this happens next time.
 
Joined
Feb 15, 2021
Messages
13
Likes
0
This is one of my problems:
I had same issue before with the original WiFi card too: Video
I thought the faster card will solve this problem :( I was wrong...

I have now very strong 867Mbps connection between the Asus AC86U Router and the Element X, but there are interruptions (drop off) during playback.
(the distance is no more than 4 meters without any physical barriers)
Other devices with same environment can streams 4K HDR videos easily over WiFi without any problems. (the continuous and stable speed of copy between the NAS and my laptop is around 75MB/s over WiFi (which is 600Mbps))
I think something is wrong with the Wireless part of this unit... Maybe the buffering size of WiFi is wrongly set. :(
Same playback over the Ethernet is OK!
Did you ever resolve the problem? I'm having dropouts occasionally when streaming 192k Quboz content and am using an Asus router as well. Sometimes it works though. Once, rebooting the Element resolved it but not always. My laptop streams the same content fine over wifi.
 

chi2

Member
Forum Donor
Joined
Dec 13, 2018
Messages
92
Likes
90
Location
Switzerland
The last firmware update resolved the Tidal interruption with my wireless network. I've purchased the AC version of the 7260 wifi card to replace the N version in the Element X but didn't install it because the issue was resolved with the new firmware.
 

aigo

Member
Joined
Oct 14, 2020
Messages
85
Likes
33
Wireless N 2x2 (up to 300Mbps) vs. AC 2x2 (up to 867Mbps)

I purchased the MA Element X partly because it's supports the 2x2 AC WiFi radio for the smoothest usage where the Ethernet isn't available.
After few days I've tried the WiFi mode and I realized that the connection is 300Mbps between my router and the Element X. After I contacted the Matrix support, they said that the AC mode and the 867Mbps bandwidth should be available because the Element X has a discrete Intel 7260 NGFF card inside.
As I remember from the past I had a very similar problem with one of my ThinkPad laptop which had the same type of the Intel 7260 card without real AC speed connection. After some investigation I found that there're two different sub-type of Intel 7260:
a: Model: 7260NGW (Dual Band Wireless-AC 7260)
b: Model: 7260NGW BN (Dual Band Wireless-N 7260)

Unfortunately despite the first/original specifications of the Element X which declared the AC speed - the supply chain of the Matrix Audio purchased and equipped BN version cards into the Element X. :(

Of course I know well that the 300Mbps should be enough for playback of all audio files, but I think in case of premium WiFi network (like mine) the real 867Mbps (faster response time and buffering) can effect positively for the quality of the playback.

I purchased an AC version of Intel generic (non Lenovo/HP OEM) WiFi card and already replaced in my unit. (note: don't buy lenovo/HP card because they are modified firmware and won't work in generic applications!)
Now it's working with 867Mbps connection like a charm! ;)

The manufacturer has been revised the specifications on the MA website to N from AC.
How does one open this unit? I mean, which screws should I untie first?
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
371
Likes
86
Understand your frustration, but why you waiting so much until Matrix resolve these issues? Matrix devices work almost perfectly with Roon, so you can setup Roon server on chip PC, plug your external hard drive and connect NAS. DSD will also work flawlessly. I never trust to any audio manufacturer in software development. So I use Roon for several years without any major issues.
Just speak of myself, I bought element M because I want streamer that supports Tidal MQA without the need of Roon. Whether Roon worth the cost I can’t comment, but if I had Roon I will probably go for a cheaper endpoint like rpi4 plus a decent DAC for half of the price. For the premium I paid for element M I suppose to get much smoother experience.
 
Top Bottom