• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Matrix Audio Element M - First impression

Joined
Sep 4, 2020
Messages
42
Likes
6
#21
I kinda figured out the track queue management process in the MA Remote. So far no lag as long as I add them into the queue than force playing a random song.

When adding a song in the queue, I choose add to end of queue. Then when managing the queue, from the song screen you will see those 3 dots.
Screenshot_20200922_162459_com.matrix_digi.ma_remote.jpg


Swipe to the right and you see what is in your queue.
Screenshot_20200922_162508_com.matrix_digi.ma_remote.jpg


You can edit it from there, just like in Spotify. Works good so far without Roon.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
Thread Starter #22
Update 22/09: Matrix Audio has come back and confirmed the noise is normal. When the screen is off (auto dim mode) the noise is also reduced. No big deal for me as I can't hear it 1m away. But I wouldn't use it on my desk for headphones as I will be sitting closer to the device. Maybe I have very good ears :D
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
Thread Starter #23
@somy

If you can get another access point, add another access point to your network just for troubleshooting purposes. It seem that Matrix Audio Element series are a bit picky with what access point they are connected to.
Thanks I connect it to ethernet and haven't experienced any problems with Tidal during music playback so I'd stick with cables.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
Thread Starter #24
I kinda figured out the track queue management process in the MA Remote. So far no lag as long as I add them into the queue than force playing a random song.

When adding a song in the queue, I choose add to end of queue. Then when managing the queue, from the song screen you will see those 3 dots. View attachment 84222

Swipe to the right and you see what is in your queue.
View attachment 84223

You can edit it from there, just like in Spotify. Works good so far without Roon.
Thanks for sharing I wasn't aware there is a way to edit queue actually. Just tried it out and works good! I think in next firmware they'll address issues with playback control.
 

MatrixAudio

Active Member
Manufacturer
Joined
Jun 5, 2019
Messages
128
Likes
322
Location
Xi'an China
#25
Dear @somy ,
Thanks for your detailed feedback. Sorry for my delay, I did not come to Audiosciencereview.com because I was so busy yesterday.
Here is the brief answers for your questions.
1, This is a grayscale OLED display part. It's normal that the pixles are at different brightness. But it seems that the OLED screen is not perfect . Our service personnel will contact you soon for further information.
2, The buzz is due to the characteristic of an OLED diaplay part, all the OLED display have a buzzing sound, but each individual has a different sound level. The only thing we can do is avoid using this display part on future products. Sorry.
3, It's abnormal that the device connect to network again in about 15 minutes. Can you clarify if it costs 15 minutes to connect after you switch the Network Type from LAN to Wi-Fi or from Wi-Fi to LAN mode? Or both switches are all costs so long time? According to our testing, when we switch Wi-Fi to LAN mode, the connecting time is about 30 seconds, when we switch LAN mode to Wi-Fi mode, the re-connecting time is about 15 seconds. What network router or access point are you using? Can you provide the model name? Can you describe the topology of the network enviroment? Is it possible to change a network enviroment (change another network router? or simplify the network topology and reduce routing levels) to test again?
5, currently it's recommended to not cut off power supply to the unit to avoid waste much time in indexing tracks .
6, Your question #6, We will release new firmware to let the unit recognize photos in albums folders. But we still need some more days to release it. For the second paragraph in this section you marked as red, I have no idea the reasons, we will test at our side, but it's better to confirm the network connection is reliable before we talk about this issue.
7, Also need troubleshooting of the network connection as mentioned in answer #3 above, additionally, check the 2 antannas are installed correctly and tightened.
9, Maybe also related to the network connection reliabilities.
10, We will learn how to register Harmony database.

Others:
- Generates heat during standby mode. When the unit goes to standby mode with power cord not be disconnected. Only digital part working during this status, the DAC, the analoge stage and headphone amplifier are not working. According to our measurement, the power consumption of standby mode is less than 6 watt, at sleep mode it's less than 10 watt. We are still trying to reduce the power consumption during standby and sleep mode.
- For the optimization regarding search in Tidal, will be fized in next app release.
- For the track title display, we will try to find solutions.
 

MatrixAudio

Active Member
Manufacturer
Joined
Jun 5, 2019
Messages
128
Likes
322
Location
Xi'an China
#26
I kinda figured out the track queue management process in the MA Remote. So far no lag as long as I add them into the queue than force playing a random song.

When adding a song in the queue, I choose add to end of queue. Then when managing the queue, from the song screen you will see those 3 dots.

Swipe to the right and you see what is in your queue.


You can edit it from there, just like in Spotify. Works good so far without Roon.
Thanks for your information,
We tested according to your method, but adding to play queue makes no sense to reduce the buffering time at our side.
We will keep finding solutions about this issue.
Thank you.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
Thread Starter #27
Dear @somy ,
Thanks for your detailed feedback. Sorry for my delay, I did not come to Audiosciencereview.com because I was so busy yesterday.
Here is the brief answers for your questions.
1, This is a grayscale OLED display part. It's normal that the pixles are at different brightness. But it seems that the OLED screen is not perfect . Our service personnel will contact you soon for further information.
2, The buzz is due to the characteristic of an OLED diaplay part, all the OLED display have a buzzing sound, but each individual has a different sound level. The only thing we can do is avoid using this display part on future products. Sorry.
3, It's abnormal that the device connect to network again in about 15 minutes. Can you clarify if it costs 15 minutes to connect after you switch the Network Type from LAN to Wi-Fi or from Wi-Fi to LAN mode? Or both switches are all costs so long time? According to our testing, when we switch Wi-Fi to LAN mode, the connecting time is about 30 seconds, when we switch LAN mode to Wi-Fi mode, the re-connecting time is about 15 seconds. What network router or access point are you using? Can you provide the model name? Can you describe the topology of the network enviroment? Is it possible to change a network enviroment (change another network router? or simplify the network topology and reduce routing levels) to test again?
5, currently it's recommended to not cut off power supply to the unit to avoid waste much time in indexing tracks .
6, Your question #6, We will release new firmware to let the unit recognize photos in albums folders. But we still need some more days to release it. For the second paragraph in this section you marked as red, I have no idea the reasons, we will test at our side, but it's better to confirm the network connection is reliable before we talk about this issue.
7, Also need troubleshooting of the network connection as mentioned in answer #3 above, additionally, check the 2 antannas are installed correctly and tightened.
9, Maybe also related to the network connection reliabilities.
10, We will learn how to register Harmony database.

Others:
- Generates heat during standby mode. When the unit goes to standby mode with power cord not be disconnected. Only digital part working during this status, the DAC, the analoge stage and headphone amplifier are not working. According to our measurement, the power consumption of standby mode is less than 6 watt, at sleep mode it's less than 10 watt. We are still trying to reduce the power consumption during standby and sleep mode.
- For the optimization regarding search in Tidal, will be fized in next app release.
- For the track title display, we will try to find solutions.
Hi @MatrixAudio
Thank you for your reply, just to say that your good product support is the reason why I chose your product.
1) I'm also in dialogue with your support regarding the display issue.
2) I think the noise is not only from OLED display. When the device is in standby mode, there is absolutely no noise. When the device is waken up it starts to generate noise regardless if the display is on or off. I do notice when the display is off the noise level is reduced. But there must be something else generating noise. The noise is auditable in a quiet room 1 meter away from the device. I have sent your support a video to demonstrate the noise (can't post video here)
3) I did test multiple times and get the same result.
6) I have sent some more screenshots to your support. What I experienced is for DSF albums with multiple album artist, it will create an empty album for each secondary album artist. I attach two photos below to illustrate the problem. Please be aware it is perfectly normal to have multiple album artists especially for classical music. I don't know if the problem affects PCM files.
7) I didn't have a single problem during playback using ethernet, will not switch to WIFI for now. I think you should try to pre-load the music before playback, building up a good buffer to prevent the issue.
8) Great that you start to look into the issue!
9) Doesn't happen very often now, I receive once yesterday and I can live with it
10) It would be good to add the device to Harmony. If you can publish some API for controlling the device maybe I can implement a homebridge plugin to control the device by Siri.

I have have some suggestion for the app:
1) Search in Tidal and return from album goes straight to streaming home page and it forgets about previous search. The return button from the album should return to the search result instead. And for better usability it would be nice to remember searched terms.
2) Tracks with long title is trimmed, would be nice to allow scrolling (or like Tidal app rolling the text from left to right)
3) The streaming section should allow user who only has one streaming service to go to that service directly instead of choosing between Tidal and Quboz

4) Use the folder.jpg or embedded cover art for albums (should be simple)
 

Attachments

Joined
Sep 4, 2020
Messages
42
Likes
6
#28
Thanks for your information,
We tested according to your method, but adding to play queue makes no sense to reduce the buffering time at our side.
We will keep finding solutions about this issue.
Thank you.
That is interesting, but nevertheless, excellent support from your Team! Looking forward for the updates.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
Thread Starter #29
That is interesting, but nevertheless, excellent support from your Team! Looking forward for the updates.
I think the lag could also be added in the app itself, and MA player on the device doesn't necessarily the root cause.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
Thread Starter #30
Just want to update: looks like there is some issue with my OLED display. Matrix is in active dialogue with me on replacing the device.
They've also managed to reproduce the problem with DSF albums with multiple album artists, and will hopefully fix the issue in the next firmware.
 
Joined
Jun 25, 2020
Messages
85
Likes
17
#31
Every DAC I've seen tested here will have 'good' SQ. In a high end system, I doubt any listener(s) could consistently identify any of the top 5 DACs on the SINAD chart vs the Schiit Modius or SMSL M500 in blind listening. I have those two DACs right now and neither buzzes or has any issues. A DAC costing three to six times more with problems is shocking.
 
Joined
Jan 13, 2020
Messages
15
Likes
22
Location
Australia
#32
Every DAC I've seen tested here will have 'good' SQ. In a high end system, I doubt any listener(s) could consistently identify any of the top 5 DACs on the SINAD chart vs the Schiit Modius or SMSL M500 in blind listening. I have those two DACs right now and neither buzzes or has any issues. A DAC costing three to six times more with problems is shocking.
It would be shocking if dozens were shown to be faulty but we are talking about one unit. There’s multiple threads with loads of pages on Matrix gear and they appear to be outstanding in terms of build, reliability and support.
 
Joined
Sep 4, 2020
Messages
42
Likes
6
#33
Every DAC I've seen tested here will have 'good' SQ. In a high end system, I doubt any listener(s) could consistently identify any of the top 5 DACs on the SINAD chart vs the Schiit Modius or SMSL M500 in blind listening. I have those two DACs right now and neither buzzes or has any issues. A DAC costing three to six times more with problems is shocking.
The only issue I got is with the laggy streaming app. I also experience similar issues with BluOS and HEOS. Only Roon got it perfect. But that is an unfair comparison because Roon uses a music server/core while these streamers are all-in-one devices.
 
Joined
Jun 25, 2020
Messages
85
Likes
17
#34
It would be shocking if dozens were shown to be faulty but we are talking about one unit. There’s multiple threads with loads of pages on Matrix gear and they appear to be outstanding in terms of build, reliability and support.
Good point. I do recall a defense secretary years ago stating we have to be right every time, they only have to be right once. You just read the goofiest analogy this week. I think the Matrix DACs are super cool
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
Thread Starter #35
Update 29/9: Long story short: I have been in contact with my dealer and Matrix Audio, now they suggested to repair the device. I guess being a "as new" demo device which I bought complicates things. I have denied the offer to repair and ask for returning the product.
 
Joined
Sep 4, 2020
Messages
42
Likes
6
#36
My element M stopped working. It can’t be detected by my network(says it is offline) even when I switch to Wifi or LAN. Airplay can’t detect it too. Any way to reset this?

Edit: This only seem to affect my iPhone. It works with my Huawei phone. App on iOS keeps stating something to update firmware.
 
Last edited:
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
Thread Starter #37
My element M stopped working. It can’t be detected by my network(says it is offline) even when I switch to Wifi or LAN. Airplay can’t detect it too. Any way to reset this?

Edit: This only seem to affect my iPhone. It works with my Huawei phone. App on iOS keeps stating something to update firmware.
I was stocked yesterday as well. I think it’s due to the upgrade. After close open the app multiple times, eventually it asked to upgrade firmware, after that it works again. Again a software issue IMO.
 
Joined
Sep 4, 2020
Messages
42
Likes
6
#38
I was stocked yesterday as well. I think it’s due to the upgrade. After close open the app multiple times, eventually it asked to upgrade firmware, after that it works again. Again a software issue IMO.
Are you now on iOS 14? i havent iupgraded yet and all my 4 iOS devices shows the element M as offline.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
Thread Starter #39
Are you now on iOS 14? i havent iupgraded yet and all my 4 iOS devices shows the element M as offline.
Yes I'm on iOS 14 - not sure why does it matter though? Anyways in the beginning I also experienced what you described - it kept saying the device is offline. Restarted the app multiple times, eventually it pops up a dialogue ask to upgrade. After upgrade it works fine without issue. Again as I said, Matrix Audio needs better software developer :)
 
Joined
Sep 4, 2020
Messages
42
Likes
6
#40
Yes I'm on iOS 14 - not sure why does it matter though? Anyways in the beginning I also experienced what you described - it kept saying the device is offline. Restarted the app multiple times, eventually it pops up a dialogue ask to upgrade. After upgrade it works fine without issue. Again as I said, Matrix Audio needs better software developer :)
Definitely! The updated MA app seems to be optimized for iOS 14 as what its description shows. Will update my OS then and see how it goes. I just find it odd that it works perfectly fine in Android.
 
Top Bottom