• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Matrix Audio Element M - First impression

somy

Senior Member
Joined
Aug 20, 2020
Messages
313
Likes
63
#1
Hi,
I have received Matrix Audio Element M today and spent the whole afternoon and evening with it, I think I'd share some of my thought here maybe helpful for someone who are interested in the Element series
It is my first impression of the product, and I will continue to add more while I'm using the product.
Good parts first:
1) Very good build quality, and the remote is also very nice
2) The mobile app is very powerful, not only can you control playback of music but also can you adjust all settings, change input/output, and even wake-up/sleep, so you can use the device without the IR remote
3) I like the auto input selector, which seems to work for me most of the time.

Things can be improved:
1) The LCD display looks in poor quality - you can see the attached photos of how English text are displayed. It's not about sharpless, but some pixels are missing for certain letters. "On" looks like "Dn" for example.
2) The device is not completely silent. To my surprise I can hear some eletrical buzz from the device (not sure if it's the internal transformer), the sound is auditable 1 meter away when the device is waken up. Not a big deal for me as I use it for speakers, but might be annoying for some.
3) WiFi and ethernet cannot be enabled at the same time, and swicthing between them takes the device 15 minutes to connect again. It doesn't bother me much as I probably won't swith network very often, but why on earth does it take 15 minutes to connect?
4) For those who plan to use it with NAS, it only supports SMB 1 and SMB 2 ( my NAS by default support versions above 2.1)
5) When the device is restarted, the network share containing local music is disabled, and I need to manually enable it to rescan the content. For my small library it takes about 10-15mins, and during the period the app doesn't allow me to play music.
6) Looks like the device will download album covers from internet instead of using already embedded cover art. About 30% of my albums (most classical) don't have cover, even though all of them have cover art embedded. I think the better logic would be to download cover art only when local one doesn't exist.
I spend some time to look into the scan result and found that there are multiple albums with the same tracks. In fact I have 217 albums in total but Element M thinks I have 247 (30% albums don't have cover art). I then disabled the library and re-enable it to force rescan of the content, now I got 139 albums! The scanner simply doesn't work properly and I'm kind of surprised nobody mentioned this. All my albums are nicely sorted and tagged properly, with folder.jpg for cover art. I have no problem with other scanners like Music Station, Emby and Kodi.
7) When playing Tidal streaming via WIFI I got many interuptions/pops during playback. The WiFI speed is definately not a problem as I can stream DSF with much bigger bitrate from my NAS without problem (and I have 1Gbps internet connection). Changing to Ethernet solved the issue, so forget about WiFI if you want stream Tidal.
8) Switching Tidal tracks sometimes delays the streaming by 1-5 minutes. I saw others also mentioned this problem, so guess it might be a bug in the software.
9) The mobile app is not very stable. I have received the error saying I'm disconnected from WiFI please retry a few times today. Not sure what caused it but I don't think my phone is disconnected and the signal is always full in the living room. Also experience the app freezes and I had to restart (multiple times today)
Only experienced this once during today and I can live with it.
10) Now my most annoying problem (not solved yet) - I use Logitech Harmony Hub to control all my AV/HIFI devices, it works very well and with HomeBridge you can also use Siri to control them. Element M unfortunately is not in Harmony database, which means I have to teach Harmony Hub all IR commands. For some reason Harmony hub doesn't recognize several commands successfully, so I had to repeat multiple times and so far I got most working but not all. It would be nice to have a profile in Harmony database. In relation to IR control, it is the only device in my AV/HIFI rack that doesn't receive IR signal from my Harmony hub. Looks like I need to really point to the device to make it work. I planned to use Harmony to turn on power AMP together with the player, but I think I have to give up due to the above problems.
Manage to solve this however it would still be a lot easier if Element M is registered in Harmony database.

Will add more when I get to know more about the device. So far I spent most of time to test and configure, I expect to spend more time listing to it so I can write something about its SQ.

Updated 18th Sep: I managed to get Harmony to work. I can live with 3, 5 and 8.
@MatrixAudio: it would be very helpful if you can comment on 1, 2, 6 and 7.

I did some listening sessions today.
My previous setup is:
Laptop/Audirvana -> Cheap HDMI -> Onkyo AVR TXNR906 (more than 10 years old) -> RCA -> Stereo AMP -> B&W 804S
AudioAero Prima CD -> VHD XLR -> Krell Steron AMP -> B&W 804S
The new setup:
Element M -> VHD XLR -> Krell Steron AMP -> B&W 804S
My initial thoughts on SQ:
1) Sound stage is wider, instrument separation is better than Audirvana, same level as my CD player at least, maybe slightly better
2) Mids and highs have auditable better clarity, better than my CD player and PC
3) Darker background, very good dynamics not as good as my CD player though (strange!)
4) I don't enjoy bass as much as mids/highs, the extension is not as good, it feels more boomy and the depth is not impressive.
Overall I'm happy with SQ except for the bass, I don't expect it to beat a CD player that costs twice 15 years old. It's noticeable better than PC/AVR and very close to my CD player.
 

Attachments

Last edited:
Joined
Jul 5, 2019
Messages
45
Likes
21
#4
I don't have any experience with the M but I do own a Matrix Element i and it is proving to be very stable and reliable. No issues with WiFi when streaming from Roon, over Airplay or from Tidal within the MA app. The MA app is stable and I don't recall any dropouts. My unit is also deadly quiet whether on or off. And the display looks fine. Perhaps your unit is faulty?
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
313
Likes
63
Thread Starter #5
I don't have any experience with the M but I do own a Matrix Element i and it is proving to be very stable and reliable. No issues with WiFi when streaming from Roon, over Airplay or from Tidal within the MA app. The MA app is stable and I don't recall any dropouts. My unit is also deadly quiet whether on or off. And the display looks fine. Perhaps your unit is faulty?
Well that I don't know. Maybe @MatrixAudio or somebody who also own Element M can confirm? I'm not sure if the display in Element I is the same of M though.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
313
Likes
63
Thread Starter #6
That's a lot of issues. I get much better functionality from my RPi4 connected to Topping D50s for a fraction of the cost. Are you keeping it?
I think most of the issues are software related and if 1) and 2) are not hardware issue and the SQ is good I'll keep it. The sad thing is, there are not many choices in the market that does Tidal streaming with MQA support. Another option which I used before Element M is Audirvana + external DAC. To be honest Audirvana is way smoother to use. I'm kind of surprised in the HIFI market the technology/software is way behind, any TV box regardless of price can handle all the music files and provides much better user experience. But obviously they're not engineered for SQ.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
313
Likes
63
Thread Starter #7
Thanks for the review! Looks Matrix is great at engineering, software not so much. A 15 minute wait is pretty bad.
Yes I don't understand the 15min re-connect, but in most cases you don't need to switch network connection so maybe not a big deal.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
313
Likes
63
Thread Starter #8
Re 6) I did some more tests and looks like it has something to do with DSF files. For some reason it creates empty albums for each artist. It doesn't affect PCM files.
IMG_3386.PNG
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
313
Likes
63
Thread Starter #9
Just sent an email to Matrix support, will update here is I hear anything back.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
313
Likes
63
Thread Starter #12
Some more experience to share:
1) The mids and highs are very sweet, love the sound! I still think the bass can be a bit tighter.
2) DLNA works very well. It can play DSD directly over network from both Audirvana and Emby
3) There are small glitches with the MA remote app, noticed play/pause can take a few seconds, and sometimes switch album gives no response.

Suggestion for improvement, better user experience:
1) Search in Tidal once return, it forgets about previous search and jump to front page. It would be nice to remember previously searched items
2) Tracks with long title only disable half, would be nice to allow scrolling (or like Tidal app rolling the text from left to right)
3) The streaming section should allow user who only has one streaming service to go to that service directly instead of choosing between Tidal and Quboz
4) Use the folder.jpg or embedded cover art for albums (should be simple)
 
Joined
Sep 4, 2020
Messages
42
Likes
6
#13
Thanks for covering the issues found on the Element M. Overall, I am happy with the product. My wife noticed how much better it sounds compared to my other systems. She says it is much clearer and can even understand mumble rap playing lol

Now, with the issues.

Hardware
- Very well built but even when it’s idle or just plugged into the outlet, it generates a certain amount of heat.

Software
- Runs perfectly with Roon but the MA Remote? I will list down my findings:
1. Seems to have trouble playing Tidal MQA files using the MA Remote App. It lags at times and is annoying. This doesn’t happen all the time though. Will try using wired from a Mesh router.
2. If I play a particular playlist in Tidal, it works fine, even when MQA files are in it, but when I want to switch to a different track not part of the playlist, like an MQA track, I will experience 1 to 5 minutes lag.

I think that is it so far, and it seems to be directed to the cache management of the Tidal App integration in the MA Remote. I got a reply from Matrix Audio Facebook, and they said that they are looking into the issue and will probably release a firmware and app update to address these.
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
313
Likes
63
Thread Starter #14
Thanks for covering the issues found on the Element M. Overall, I am happy with the product. My wife noticed how much better it sounds compared to my other systems. She says it is much clearer and can even understand mumble rap playing lol

Now, with the issues.

Hardware
- Very well built but even when it’s idle or just plugged into the outlet, it generates a certain amount of heat.

Software
- Runs perfectly with Roon but the MA Remote? I will list down my findings:
1. Seems to have trouble playing Tidal MQA files using the MA Remote App. It lags at times and is annoying. This doesn’t happen all the time though. Will try using wired from a Mesh router.
2. If I play a particular playlist in Tidal, it works fine, even when MQA files are in it, but when I want to switch to a different track not part of the playlist, like an MQA track, I will experience 1 to 5 minutes lag.

I think that is it so far, and it seems to be directed to the cache management of the Tidal App integration in the MA Remote. I got a reply from Matrix Audio Facebook, and they said that they are looking into the issue and will probably release a firmware and app update to address these.
Hi, I also noticed it generates heat when idle. As I'm able to rescan the music files when it's idle I think standby just means turn off display.
Can you help to confirm my issues 1) and 2). Are the text displayed sharper on your unit? And can you hear any sound from the device when it's running (you need to be quite close to hear it)? Thanks a lot in advance!
 
Joined
Sep 4, 2020
Messages
42
Likes
6
#15
Hi, I also noticed it generates heat when idle. As I'm able to rescan the music files when it's idle I think standby just means turn off display.
Can you help to confirm my issues 1) and 2). Are the text displayed sharper on your unit? And can you hear any sound from the device when it's running (you need to be quite close to hear it)? Thanks a lot in advance!
LCD seems ok, went through most of the options, and I don’t see any dead pixel. For the noise, I am not sure if my AC is just noisy or my hearing isn’t that good, but I can’t hear any noise coming from the chassis even when my ears are an inch away from it. Sorry you had to experience those on your unit. Our local dealer here has a lifetime service warranty on top of a 1 year replacement warranty, maybe you can get it exchanged?
 
OP
S

somy

Senior Member
Joined
Aug 20, 2020
Messages
313
Likes
63
Thread Starter #16
LCD seems ok, went through most of the options, and I don’t see any dead pixel. For the noise, I am not sure if my AC is just noisy or my hearing isn’t that good, but I can’t hear any noise coming from the chassis even when my ears are an inch away from it. Sorry you had to experience those on your unit. Our local dealer here has a lifetime service warranty on top of a 1 year replacement warranty, maybe you can get it exchanged?
Thanks! It could be defected. Just want to be sure before I contact the dealer, can you help to take a photo of how the display looks like when you enter settings? Especially the right part of the display. Thanks a lot in advance!
 
Joined
Sep 4, 2020
Messages
42
Likes
6
#17
Thanks! It could be defected. Just want to be sure before I contact the dealer, can you help to take a photo of how the display looks like when you enter settings? Especially the right part of the display. Thanks a lot in advance!
Just an update, I now hear the noise. It is very faint, like an ant whispering. It is some sort of buzzing noise that I can hear if the room is dead silent, I put my ear next to the chassis and focus on the noise. But the noise isn't really audible even if I am seated 1 feet away from element M.

Still trying to figure out how I can attach pictures, but I should be able to do so later.
 
Joined
Aug 26, 2020
Messages
21
Likes
8
Location
Indonesia
#20
@somy

If you can get another access point, add another access point to your network just for troubleshooting purposes. It seem that Matrix Audio Element series are a bit picky with what access point they are connected to.
 
Top Bottom