• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Hidizs S9 Review (Headphone Adapter)

Matias

Major Contributor
Forum Donor
Joined
Jan 1, 2019
Messages
2,782
Likes
4,703
Location
São Paulo, Brazil
Please someone send an S9 Pro for Amir to test?
 

multicast

Member
Joined
Sep 3, 2021
Messages
6
Likes
3
HIDIZS S9 PRO PROBLEM, after attempting to download the drivers from their website, whenever i plug my s9 pro in a windows notif comes up “USB device not recognized”

Did you follow the instructions thoroughly? First fill in the actual PID then enable "detect device".

Mike
 

multicast

Member
Joined
Sep 3, 2021
Messages
6
Likes
3
you should find SWX768-4493_A1 under

My computer -> settings management -> sound, video and game

after starting SWX_setup_WHQL_XXXXXXXXX.exe.
 

KeithPhantom

Addicted to Fun and Learning
Forum Donor
Joined
May 8, 2020
Messages
558
Likes
529
Please someone send an S9 Pro for Amir to test?
I would send mine, but I use it pretty much everyday and I don't have any other way to use my Blessing 2 without them.
 

ZolaIII

Major Contributor
Joined
Jul 28, 2019
Messages
1,174
Likes
682
HIDIZS S9 PRO PROBLEM, after attempting to download the drivers from their website, whenever i plug my s9 pro in a windows notif comes up “USB device not recognized” and from the Device Manager before listed under Hidizs S9 Pro now becomes under other devices - Comtrue-inc Firmware Update Device. Cant update it or anything. CS said to flash the firmware again. What does that mean? When it's plugged in it's just breathing blue led.View attachment 151226View attachment 151227View attachment 151228

PS. i'm sorry if i'm breaking any rules with this post. i'm very new here
Try: a) removing any driver remains then re initing it (device manager/scan for hardware changes),
b) reflash firmware (re download it and check hash [checksum]).
It either didn't flash correctly (firmware which is internal device operating software) or you have for some reason conflict from leftovers (previous drivers...).

Hope that helps.
 

joshpgst

Member
Joined
Sep 3, 2021
Messages
6
Likes
1
Try: a) removing any driver remains then re initing it (device manager/scan for hardware changes),
b) reflash firmware (re download it and check hash [checksum]).
It either didn't flash correctly (firmware which is internal device operating software) or you have for some reason conflict from leftovers (previous drivers...).

Hope that helps.
sorry what is this step b one how do i reflash firmware. i uninstalled the comtrue-inc firmware update device and scan for hardware changes already, it popped back up, the same. i was told by CS to flash the firmware which i have been trying to figure out how to do.
 

ZolaIII

Major Contributor
Joined
Jul 28, 2019
Messages
1,174
Likes
682
@joshpgst see Felippe post on page 12. You have to write to Hidizs suport, they will give you a link for firmware, it comes in self execution exe file. First ensure that you really need to do that. Check if it works with other computer (preferably with same OS). If it does then it's a driver's leftovers problem.
 

joshpgst

Member
Joined
Sep 3, 2021
Messages
6
Likes
1
@joshpgst see Felippe post on page 12. You have to write to Hidizs suport, they will give you a link for firmware, it comes in self execution exe file. First ensure that you really need to do that. Check if it works with other computer (preferably with same OS). If it does then it's a driver's leftovers problem.
thank you for that but still seems to have issues with it, when i plug the s9 pro to the 3.0 usb, comtrue-inc firmware update pops up but cannot update anything. and then if i try out the 2.0 usb, the device is not found, Device Descriptor Request Failed. Now on day 2 trying to talk with Hidizs and not getting much luck. i've told them all my issues as detailed as possible but they keep asking me generic questions and replies half a day later or the next day even.
 

ZolaIII

Major Contributor
Joined
Jul 28, 2019
Messages
1,174
Likes
682
thank you for that but still seems to have issues with it, when i plug the s9 pro to the 3.0 usb, comtrue-inc firmware update pops up but cannot update anything. and then if i try out the 2.0 usb, the device is not found, Device Descriptor Request Failed. Now on day 2 trying to talk with Hidizs and not getting much luck. i've told them all my issues as detailed as possible but they keep asking me generic questions and replies half a day later or the next day even.
Well try another Windows PC, avoid hubs whenever you can.
Remote assistance ain't easy thing and you warent exactly thirl with a description. You got a "bimbo" first support from they stuff. They want a same thing (detaild description), so that they can ship request to someone more elaborate to try to delt with it (which takes time). I am trying to simplify it as much as possible. You need to isolate cause (is it stick, your PC, is it software and accessible and can be fixed or its a tost). That is about as much as it can be delt with ad hock (and probably even if you are an expert as it's single PCB [eventually change USB port and that's about it]).
Best regards.
 

joshpgst

Member
Joined
Sep 3, 2021
Messages
6
Likes
1
Well try another Windows PC, avoid hubs whenever you can.
Remote assistance ain't easy thing and you warent exactly thirl with a description. You got a "bimbo" first support from they stuff. They want a same thing (detaild description), so that they can ship request to someone more elaborate to try to delt with it (which takes time). I am trying to simplify it as much as possible. You need to isolate cause (is it stick, your PC, is it software and accessible and can be fixed or its a tost). That is about as much as it can be delt with ad hock (and probably even if you are an expert as it's single PCB [eventually change USB port and that's about it]).
Best regards.
yeaah i agree, i messaged them from starting point a to z tho. screenshots and videos of what happened. lets see what happens hopefully things can get cleared up and fixed asap.
 

kevmitch

New Member
Joined
Sep 6, 2021
Messages
2
Likes
0
I'm comparing the measurements at the top of this thread for the s9 with those for the s8. It looks to me like the s8 has slightly better SINAD of 114 dB (vs 108 dB for the s9). The s8 has a dynamic range of 121 dB. I don't really understand why there are two dynamic range measurements for the s9 (118 dB and 79 dB) both labeled "balanced out", but that second one is considerably worse than the s8. The s8 also looks to have better jitter performance. Multi-tone performance looks about equal.

About the only thing that looks better for the s9 is the power, which on the flipside, likely has a negative impact on battery life.

Since I'm really only planning on driving IEMs (Etymotic ER4SR) that don't need a lot of power, I'm not seeing any reason I should get the s9 even if it were the same price. Is there anything I'm missing?
 

meccup

Member
Joined
Sep 15, 2021
Messages
5
Likes
1
Hello guys, I'm fairly noob-ish at hifi stuff. I hope a pro could explain something for me.

I'm getting lots of distortion when using Hifiman Deva with Hidizs s9 pro via balanced TRRS cable at 50% and higher volume levels. What I hear is a lot of cracks and hum when music is played (no distortion without music).

I'm also getting some, but not that much distortion (for some reason only on the right channel) when using stock unbalanced cable at 65% and higher volume level. Under 65% level, it is clear and crisp.

I'm not getting any distortion when using just normal audio output (from macbook) whatsoever at any volume level with my Deva.

I'm also not getting any distortion when using my old m50x and Hidizs s9 pro at any volume levels.

Dunno what is that... Deva has lower impedance rating than m50x (18 ohms vs 38 ohms). Could that be that s9 just overloads Deva?

Cheers
 

Jimbob54

Master Contributor
Forum Donor
Joined
Oct 25, 2019
Messages
7,337
Likes
8,718
Hello guys, I'm fairly noob-ish at hifi stuff. I hope a pro could explain something for me.

I'm getting lots of distortion when using Hifiman Deva with Hidizs s9 pro via balanced TRRS cable at 50% and higher volume levels. What I hear is a lot of cracks and hum when music is played (no distortion without music).

I'm also getting some, but not that much distortion (for some reason only on the right channel) when using stock unbalanced cable at 65% and higher volume level. Under 65% level, it is clear and crisp.

I'm not getting any distortion when using just normal audio output (from macbook) whatsoever at any volume level with my Deva.

I'm also not getting any distortion when using my old m50x and Hidizs s9 pro at any volume levels.

Dunno what is that... Deva has lower impedance rating than m50x (18 ohms vs 38 ohms). Could that be that s9 just overloads Deva?

Cheers

Now, I get lost with the Deva. Is this the one that has some kind of active amp built in/ attached? If so, then yes, possibly clipping the inputs .

If the Deva is passive I wouldnt have thought a dongle at 50% should cause the driver to physically clip.

Possibly faulty headphone.
 

meccup

Member
Joined
Sep 15, 2021
Messages
5
Likes
1
Now, I get lost with the Deva. Is this the one that has some kind of active amp built in/ attached? If so, then yes, possibly clipping the inputs .

If the Deva is passive I wouldnt have thought a dongle at 50% should cause the driver to physically clip.

Possibly faulty headphone.

Thanks for the reply.

Hifiman Deva is a planar drivers headphones, no preamps, just only s9 dongle.

It does not seem that Deva is the cause/faulty, when I plug them in standard audio output of my macbook, they play well on 100% volume level, no distortion or noise. Subjectively it even plays louder (100% level internal audio vs 50% level via s9).
 

BARDUKE

Member
Joined
Oct 20, 2020
Messages
38
Likes
12
Now, I get lost with the Deva. Is this the one that has some kind of active amp built in/ attached?
That was my first thought too. If the little "bluemini" or whatever its called is attached, it could be double amping the signal causing distortion and clipping.
 

Kevbaz

Member
Forum Donor
Joined
Sep 22, 2021
Messages
78
Likes
92
Location
UK - West Yorkshire
I recently bought the Hidizs S8 on Amazon and I’m really impressed.
I was tempted by the S9 Pro but wanted to wait till a review comes out 1st so do hope Anirm test it :)
 
Top Bottom