• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Topping Quality Issues?

Joined
Jan 8, 2019
Messages
40
Likes
22
#42
Following up on my own post..I purchased a D50 in May 2019

My D50 has developed a channel imbalance (left channel louder than right) when using USB.

The problem does not exist using TOSLINK from the same motherboard. I tried my old JDS O2 DAC via USB with no issue.

So the problem appears to be with the D50

I'm talking to Topping about the issue...
 

gvl

Major Contributor
Joined
Mar 16, 2018
Messages
1,639
Likes
1,310
Location
SoCal
#43
Following up on my own post..I purchased a D50 in May 2019

My D50 has developed a channel imbalance (left channel louder than right) when using USB.

The problem does not exist using TOSLINK from the same motherboard. I tried my old JDS O2 DAC via USB with no issue.

So the problem appears to be with the D50

I'm talking to Topping about the issue...
Odd this is USB only. Are you sure the balance in the Topping sound device settings isn't off?
 
Joined
Jan 8, 2019
Messages
40
Likes
22
#44
Yes, USB only.

There is no balance adjustment on the D50. The issue seems to be in the difference in signal paths, USB vs TOSLINK internal to the device.
 

gvl

Major Contributor
Joined
Mar 16, 2018
Messages
1,639
Likes
1,310
Location
SoCal
#45
Yes, USB only.

There is no balance adjustment on the D50. The issue seems to be in the difference in signal paths, USB vs TOSLINK internal to the device.
I thought balance adjustment is available on all devices in the OS. However if you use exclusive mode or ASIO on Windows it may not have any effect - not sure.

1578176913056.png
 
Joined
Jan 8, 2019
Messages
40
Likes
22
#46
I'm running Linux and made no changes to my config when changing USB DACs, so I don't believe it is the audio chain on the PC
 
Joined
Jan 8, 2019
Messages
40
Likes
22
#49
I need to retract my post above regarding a balance issue with the D50...Embarrassingly, the problem was entirely on my end.

There is no issue with the D50
 

L5730

Senior Member
Joined
Oct 6, 2018
Messages
314
Likes
160
Location
East of England
#50
I need to retract my post above regarding a balance issue with the D50...Embarrassingly, the problem was entirely on my end.

There is no issue with the D50
So what did you do wrong that caused you to think there was an issue. No embarrassment need be felt, we're all human, we make mistakes. Admitting error and learning from it, and even helping to prevent others making those same errors, that's nothing to be embarrassed about. :)
 
Joined
Jan 8, 2019
Messages
40
Likes
22
#51
I switch to Mint recently from OpenSUSE. When I had the balance issue I popped open the Sound Control Panel and got what is shown below...no balance slider?? I figured it was somewhere else, so I looked a amixer, alsamixer, pusle_effects...nothing?...I had no reason to play with it and figured if I couldn't find it, it must be OK...The issue I was having only happened with the D50 in USB mode, TOSLINK worked fine, analog worked fine, a separate USB DAC worked fine?...I was stumped...

Digging around on the net I noticed a Mint screen shot showing the balance slider in the Sound Control Panel...huh?...It ends up that when the Panel is re-sized, it doesn't scale the contents, it crops....so the controls were there just out of view....dumb-ass....I still can't explain how the balance got changed....

I'd like to mention I had a email chain with Topping during this and they were awesome...great company!

1578526959973.png
 

Similar threads

Top Bottom