• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Shield TV passes strange formats to Denon X2700h

Galz

Member
Joined
Aug 8, 2021
Messages
40
Likes
14
Hi,

I've noticed my Sony X950H Android TV on Netflix passes DD+ for atmos content, but the shield TV passes just DD atmos. I checked with friends and they get DD+ on both TV app and the Shield TV.
Also, when playing in remux files in Kodi I get DD Atmos, shouldn't I be getting TrueHD indication? For remux with DTS I get DTSHD+NeuX (not sure what I'm supposed to be getting?). Can't compare to TV here because it doesn't support playing lossless audio anyway.
Finally, youtube on TV shows DD+ on the receiver, but from the Shield TV it shows DDSur and upmixes the stereo signal from youtube to use the surround speakers, which sounds pretty bad.

I didn't enable any upmixing options that I'm aware of, set Shield TV to auto-detect supported formats and set Kodi to passthrough. If there is some bad option somewhere that I need to change - I can't find it.


After some more searching I found the answer: Use the "direct" button on the receiver's remote several times until it displays "auto". Don't use the other buttons (movie/music/game) to pick a format (seems like that was what started the whole problem in the first place). I'm not sure if there is any way to set this from the configuration menus or if it's only accessible via this "direct" button.

I'm leaving this thread in case someone else encounters the same problem, because it took me a while for my searches to find this solution.
 
Last edited:

Drengur

Member
Forum Donor
Joined
Aug 17, 2021
Messages
31
Likes
36
I have a Shield as well and I have really stopped bothering with it in regards to audio. But if you check about>Status>Audio mode, what does it show?
 
OP
G

Galz

Member
Joined
Aug 8, 2021
Messages
40
Likes
14
I have a Shield as well and I have really stopped bothering with it in regards to audio. But if you check about>Status>Audio mode, what does it show?
I already mentioned I found the issue - Need to use the "direct" button on the Denon remote to change the mode to "auto".
This isn't a shield issue, it was just happening with the shield as that setting on the Denon is input-specific, and apparently was set up incorrectly for the shield input when I tried to check what the other modes do.

This was difficult to find as it doesn't appear in any of the menus (at least not that I could find).

Didn't change anything in the shield settings, only the Denon settings were the issue.
 
Top Bottom