• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Review and Measurements of WesionTEK Khadas Tone Board DAC

milw50717

Active Member
Joined
Jan 25, 2019
Messages
124
Likes
108
Joined
Feb 5, 2019
Messages
25
Likes
32
You may be right about their size... I didn't notice that the amazon one was the smaller in size. Similar but different. However if you search for them on aliexpress I can pretty much guarantee that you'll find the same exact ones.
 
Joined
Sep 6, 2019
Messages
7
Likes
8
20190907_013557.jpg

Didn't think it would be able to drive my diy F5 amp, but it's loud already at 50% through Volumio. Would you still recommend a preamp?
(and if there is a better place to ask this, I'll move this question there)
 
Joined
Jan 18, 2019
Messages
88
Likes
77
Anyone else having trouble with the Khadas Tone Board after Windows update 1903? I tried windows drivers and the Theyscon (very old V2 ones) but no luck.

DPC Latency checker gives me red spikes. But also without the spikes when start playing audio everytime it will pop first before playing. Settings the sample rate to 384K smoothens this out. But TBH I never had these issues before and I had to go back to my DX3 Pro (running with the latest Theyscon V4.67 drivers picked from their D50s that install and work flawlessly.

https://www.techpowerup.com/258611/...io-stutter-bug-microsoft-hasnt-managed-to-fix

This is the bug I'm talking about. It seems different per device.

Anyone else?
 
Joined
Feb 5, 2019
Messages
25
Likes
32
Anyone else having trouble with the Khadas Tone Board after Windows update 1903? I tried windows drivers and the Theyscon (very old V2 ones) but no luck.

DPC Latency checker gives me red spikes. But also without the spikes when start playing audio everytime it will pop first before playing. Settings the sample rate to 384K smoothens this out. But TBH I never had these issues before and I had to go back to my DX3 Pro (running with the latest Theyscon V4.67 drivers picked from their D50s that install and work flawlessly.

https://www.techpowerup.com/258611/...io-stutter-bug-microsoft-hasnt-managed-to-fix

This is the bug I'm talking about. It seems different per device.

Anyone else?
Hmm... thanks for info. I actually thought that it was my old DDR3 RAM that was just dying on me causing all of the stuttering...
 

g29

Addicted to Fun and Learning
Joined
May 1, 2019
Messages
520
Likes
298
Anyone else having trouble with the Khadas Tone Board after Windows update 1903? I tried windows drivers and the Theyscon (very old V2 ones) but no luck.

DPC Latency checker gives me red spikes. But also without the spikes when start playing audio everytime it will pop first before playing. Settings the sample rate to 384K smoothens this out. But TBH I never had these issues before and I had to go back to my DX3 Pro (running with the latest Theyscon V4.67 drivers picked from their D50s that install and work flawlessly.

https://www.techpowerup.com/258611/...io-stutter-bug-microsoft-hasnt-managed-to-fix

This is the bug I'm talking about. It seems different per device.

Anyone else?
And Microsoft wants to kill Windoze7 ???
 
Joined
Jan 18, 2019
Messages
88
Likes
77
Not the RAM, I went through practically every trick on the internet to get rid of it. It doesn't matter all stutters... The driver needs to be update for Windows 1903 and up. I emailed Theyscon with the info but not sure what will happen maybe we should contact Khadas also. As of now it's a shitshow. My Khadas is unusable on Windows. I'm back at the DX3 Pro for desktop use. Which is not a punishment but it's missing that bass oompf and clarity for gaming. It's more suitable for music.

Hope they can get it sorted soon.

My DX3 Pro works flawless with SPDIF and USB it seems.
 

g29

Addicted to Fun and Learning
Joined
May 1, 2019
Messages
520
Likes
298
Not the RAM, I went through practically every trick on the internet to get rid of it. It doesn't matter all stutters... The driver needs to be update for Windows 1903 and up. I emailed Theyscon with the info but not sure what will happen maybe we should contact Khadas also. As of now it's a shitshow. My Khadas is unusable on Windows. I'm back at the DX3 Pro for desktop use. Which is not a punishment but it's missing that bass oompf and clarity for gaming. It's more suitable for music.

Hope they can get it sorted soon.

My DX3 Pro works flawless with SPDIF and USB it seems.
You might want to post your Windows 10 drivers issues on the Khadas forums. Maybe someone has a workaround (or you may have to rollback the 1903 patch).

Khadas Tech Support Forum
Khadas Tone Board Forum
 
Joined
Jan 18, 2019
Messages
88
Likes
77
You might want to post your Windows 10 drivers issues on the Khadas forums. Maybe someone has a workaround (or you may have to rollback the 1903 patch).

Khadas Tech Support Forum
Khadas Tone Board Forum
I did post there already but thanks for the tip and rolling back from 1903 is not really an option since I'm running a new Ryzen 3000 cpu which is reliant on the updates for the scheduler in 1903 for it to perform optimal.

I'm on 1909 Insider preview to see if that changed anything but it didn't.

I've fiddled around between all my DACs and currently only the Khadas seems affected just like some discrete soundcards. I still have to hook it up to another machine with an older version of windows these days to make sure it's not the Khadas that went faulty (which I find hard to believe but better check it out to be sure.)
 
Joined
Jan 18, 2019
Messages
88
Likes
77
Yes that's the driver. My DX3 Pro uses the EXACT same driver by default and it works without pops and crackles.

I think the Khadas needs a firmware update to be compatible with Windows 1903 and up again.
 

Silou

Active Member
Joined
Oct 5, 2018
Messages
245
Likes
109
I have no problems with the KTB (2.24.0) and Windows 10 1903. I have got an older driver version though (10.0.18362.1)
 
Top Bottom