• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required. There are many reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

Dirac Live standalone for PC running Roon server

Joined
Dec 3, 2019
Messages
10
Likes
0
I have roon and the dirac live processor on the same PC.
Roon is working, but it sounds like the voices has some kind of echo and there is not much bass.

If I select the DAC as a device in roon. The sound is normal.
I can only use the Holo Audio Sound device when I have shut down the Dirac Processor. Because it's running in exclusive mode.

The DAC is attached to the USB port on the PC. And Roon server is also running on the PC.
I have tried different sample rates and buffer sizes but all with the same result.

In the sound panel I can see that Dirac are using 24 bits and my DAC 32 bits. I can’t change the dac’s bitrate it's fixed to 32 bits.
Hope someone can shine some light on the problem.

image01.png

image02.png

image03.png
 

leonidg

New Member
Joined
Mar 14, 2023
Messages
2
Likes
1
I have exactly the same issue with my system.
1. Dirac Live works perfectly fine with any other player, but Roon acts weirdly (garbled sound).
2. No issues when playing from Roon directly to the DAC either when I quit Dirac Live.

(!) One issue that I have definitely verified is that Dirac Live simply does NOT work properly with ANY Sample Rates above 48KHz. (No, it is not related to the PC speed limitations; I've tried it with the best and fastest...) Try lowering the Sample Rate to 48000; otherwise, you get a much worse frequency response in highs... Regrettably, while it improves frequency response, this does NOT rectify the Roon issues.
 

leonidg

New Member
Joined
Mar 14, 2023
Messages
2
Likes
1
Miraculously, I have found a cure: Looks like the Dirac Live Audio device in Windows does NOT allow any other process to use it in EXCLUSIVE mode. I have experimented with Qobuz and noticed that Qobuz plays fine via Dirca Live using WASAPI (Shared) mode, but in WASAPI (Exclusive) mode the sound gets garbled...

I have changed the settings of the Dirac Live Device Setup in Roon by simply removing the Exclusive mode checkbox. After that everything plays perfectly!

Let me know if this works for you. Also, lower the Sample Rate in Dirac Live Processor Audio Settings to 48000 (see above).
 

Attachments

  • Screenshot 2024-05-20 203422 - NON-Exclusive Dirac Live Device use.png
    Screenshot 2024-05-20 203422 - NON-Exclusive Dirac Live Device use.png
    698.3 KB · Views: 23
Top Bottom