• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). There are daily reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

Hidizs s9 Pro Interference Sound issue

dojihi9831

New Member
Joined
Feb 6, 2022
Messages
1
Likes
0
Hi All,

I have recently purchased Hidizs S9 Pro, have been interference sounds while using iPhone and Andriod device, the same does not occur when using an desktop PC, the interference sounds does not occur when the cellular network is switched off and Wifi is on in both the devices, can anyone help me out with this issue.

Thanks in advance
 

eelpout

Member
Joined
Nov 9, 2021
Messages
8
Likes
0
something is going on with mine recently too. when using the 3.5mm jack, it has tinges of sounding underwater and there is always a music track blended in. very odd. it happens for me no matter what it's attached to, laptop or phone. what's also strange is it doesn't happen on the 2.5mm jack. I wonder if it was damaged somehow.

I've tried re-flashing the firmware a couple times to no affect. :(

Oh I forgot to add the weirdest part though. This interference or whatever it is, only happens when using system wide shared audio. If using Exclusive Mode, and this goes for Windows or Mac, it's fine.
 
Last edited:

Vik

Member
Joined
Feb 21, 2022
Messages
39
Likes
1
it has tinges of sounding underwater and there is always a music track blended in.
If I understand this right – doesn't that make the unit totally unusable?

Have you guys been in contact with Hidizs about it?
 

eelpout

Member
Joined
Nov 9, 2021
Messages
8
Likes
0
If I understand this right – doesn't that make the unit totally unusable?

Have you guys been in contact with Hidizs about it?

sort of, but it works fine over the 2.5mm balanced jack and as long as I listen in exclusive mode on the 3.5mm, it's fine. it's just shared system audio that's the issue. I now think there is a short somewhere on the 3.5mm jack or traces.

Hidzs wants me to make a video of the problem before they'll do anything about it. I have yet to do that as I was a bit annoyed as apparently a written description isn't enough. :)
 

Vik

Member
Joined
Feb 21, 2022
Messages
39
Likes
1
Since I want to use also when I watch YouTube etc, maybe the need for exclusive mode will be a problem?
 

eelpout

Member
Joined
Nov 9, 2021
Messages
8
Likes
0
Since I want to use also when I watch YouTube etc, maybe the need for exclusive mode will be a problem?
yes, it would be, on the unbalanced jack. for me it happens regardless of OS/platform so it's definitely something in the DAC. Firmware flashes haven't fixed it.

It's possible I damaged it somehow. I think this is different than the interference issue.
 

Jinjuku

Major Contributor
Forum Donor
Joined
Feb 28, 2016
Messages
1,259
Likes
1,115
something is going on with mine recently too. when using the 3.5mm jack, it has tinges of sounding underwater and there is always a music track blended in. very odd. it happens for me no matter what it's attached to, laptop or phone. what's also strange is it doesn't happen on the 2.5mm jack. I wonder if it was damaged somehow.

I've tried re-flashing the firmware a couple times to no affect. :(

Oh I forgot to add the weirdest part though. This interference or whatever it is, only happens when using system wide shared audio. If using Exclusive Mode, and this goes for Windows or Mac, it's fine.

I've had mine for ~ 1 year and it's lost a channel already.
 
Top Bottom