• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required. There are daily reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

exarva1

Member
Joined
Jun 21, 2022
Messages
8
Likes
1
Hi everyone, as per thread title i have problems with SONCOZ SGD1

Long story short :
May 2022 - I Buy SGD1 form china directly via alibaba (no Soncoz distributor in my country)
June 2022 - My SGD1 suddenly turn off (some parts over heated i guess), they have very supportive CS and said just sent it under warranty for repair
October 2022 - My SGD1 return from service, BUT has issue with the driver (The thesycon usb driver don't recognize the device, thus i cannot use the via ASIO for DAW and Foobar)

I tried to live with only WASAPI (amazingly WASAPI and CoreAudio has no problem), but as we all know WASAPI is not that great, and major DAW work better using ASIO.

Things i have check :
- Power fuses (they turn on, so there no problem there)
- Power Cable (3 different cable : the one in the box, the OFC cable, and Hospital grade copper cable)
- USB Cable (3 different cable : the one in the box, silver plated cable, gold plated cable)
- USB Port (tried USB 2.0, USB 3.0, USB 3.1)
- Powercyle the unit
- Reset (the 6 sec button hold)
- fresh install of windows (both 10 and 11)
- 2nd, 3rd, and 4th laptop/pc
- already tried upgrading the firmware (both hotspot & ESPtouch method)

Things i have noticed :
1. The WASAPI driver works IF ONLY the driver on hardware manager is the generic audio driver from windows (when i change them to the one that said SONCOZ, it won't work)
2. While upgrading (through the Hotspot thingy and ESPtouch method), after get connected to the internet, the SGD1 freeze (trust me i have enough patience to say it's has freeze)
3. The filter selection return to APOD everytime the unit started (indicating older firmware per Ben said on this post)

Already tried contact the soncoz via email ([email protected], and [email protected]), and all we have is a circling discussion around the language barrier (have you tried this, have you read the manual, have you download our driver, etc).

Haven't heard from them again for 2 weeks, when i follow up the email, i got reply from mailing system that the address ([email protected] and [email protected]) is not exist

Thinking about selling the unit, but who the hell gonna buy "broken" thing.
And i cannot afford to sent back the unit back to china for repair (the delivery fee and tax are expensive for me and the guys on china)

Anyone having experience or have tried to upgrade the firmware via USB DFU (my guess are the ESP driver outdated, and while trying to upgrade, it didn't found the new firmware)
or any other suggestion
 

Snoopy

Major Contributor
Joined
Jul 19, 2021
Messages
1,614
Likes
1,188
Does ALSA work? So you could at least use it with Linux or a raspberry pi streamer.


If I learned anything at all in this forum it's that these china based manufacturers have great performance for the price and plenty of units work obviously perfect fine but when a problem occurs you are on your own, because for the Chinese distributor the sale is final. Customer support is only there while they still need good reviews for the unit, after that they are gone. Software support for older hardware is non existent .

Returning something to China and paying tax both ways for a broken unit is a bad joke. Better buy something from a local retailer if you want warranty.

I have 3 Chinese device's that have SOTA performance but I'm aware if I want to resell them they are basically as valuable as a paperweight.

(I would just order a new unit from china and return the broken one for a refund with the new order)
 
Last edited:
Top Bottom