• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Review and Measurements of Matrix Audio Element X DAC/Streamer/Amp

Joined
Jun 5, 2019
Messages
43
Likes
15
Joined
Jul 21, 2019
Messages
9
Likes
6
Could just be dpll bandwidth that is set to low, I have the same problem with my matrix sabre pro when connected to my console.
Tried changing DPLL with no luck, same problem. Frankly, for the price that they ask, I would expect flawless execution of the basic functionality. At the very list, good QA should be done.
 

gvl

Major Contributor
Joined
Mar 16, 2018
Messages
1,241
Likes
795
Location
SoCal
If your TV is out of spec no amount of QA is going to help. Sure, some DACs may be more tolerant to that, but you can't really blame the device in such a case.
 
Joined
Jul 20, 2019
Messages
15
Likes
11
Try looking into SMBv1 https://support.microsoft.com/en-nz/help/4034314/smbv1-is-not-installed-by-default-in-windows

As for the TV link, I tried all digital inputs, same result. In my case I had to bypass Element X completely, since it does not work with TV data. Yes, I did set PCM and had all of the fancy Dolby configs off.
Your suggestion regarding SMBv1 did the trick so that's solved. Thanks for the heads up. I tried to modify ntlm through the registry and group policy manager, but this is home edition and not windows 10 pro.

I'd really be pissed if I connected my TV via Toslink and it not work with any DAC, especially a $3k DAC of this caliber, I hope these quirks will get resolved in future firmware updates.
 
Last edited:
Joined
Jul 21, 2019
Messages
9
Likes
6
I'd really be pissed if I connected my TV via Toslink and it not work with any DAC, especially a $3k DAC of this caliber, I hope these quirks will get resolved in future firmware updates.
So far the cheap DAC does a fabulous job at that, seems like Samsung TVs are hard for somebody DACs to handle via TOSLINK.

Glad that you have you SMB share working!
 

somebodyelse

Active Member
Joined
Dec 5, 2018
Messages
221
Likes
154
Your suggestion regarding SMBv1 did the trick so that's solved. Thanks for the heads up. I tried to modify ntlm through the registry and group policy manager, but this is home edition and not windows 10 pro.
I hope you read Microsoft's Stop Using SMB1! link in the references to the first article before deciding to enable it. They deprecated it 5 years ago because it has fundamental, unfixable security issues that have been actively attacked.
 
Joined
Jul 20, 2019
Messages
15
Likes
11
I hope you read Microsoft's Stop Using SMB1! link in the references to the first article before deciding to enable it. They deprecated it 5 years ago because it has fundamental, unfixable security issues that have been actively attacked.
I've made contact with Matrix and explained all this to them and I agree with you completely. I realize it's gaping security risk, but I am glad to at least know how to resolve the issue now on Windows 10 machine with a clean install vs an upgraded version of Windows 10 installed where both SMBv1.0 and 2.0 coexist still for legacy support I assume.
 

somebodyelse

Active Member
Joined
Dec 5, 2018
Messages
221
Likes
154
I've made contact with Matrix and explained all this to them and I agree with you completely. I realize it's gaping security risk, but I am glad to at least know how to resolve the issue now on Windows 10 machine with a clean install vs an upgraded version of Windows 10 installed where both SMBv1.0 and 2.0 coexist still for legacy support I assume.
I'm glad to hear it was an informed decision. Please let us know how Matrix respond - it'll give some indication of whether they can be trusted to manage a network port.
 
Joined
Jul 20, 2019
Messages
15
Likes
11
I'm glad to hear it was an informed decision. Please let us know how Matrix respond - it'll give some indication of whether they can be trusted to manage a network port.
Will do. Thanks for bringing this important point up. The person who responded from Matrix seemed eager to assist with resolving all of my issues, but because of the 12hr time difference it may take longer to get a response as it's 10pm there now.

I think their ticketing system isn't working because I submitted the original request via their website last Wednesday and got no confirmation feedback they received it. I then used their MA Player App to submit another support request a couple of days later. Hopefully the member here representing Matrix will respond in this thread to these issues as he has posted before in this thread.
 
Joined
Jul 20, 2019
Messages
15
Likes
11
Update: Roon is aware the MQA issues and replicated them in their testing of the DAC. So it would seem I'll just be waiting for a firmware update to resolve these minor issues in the future. Hopefully my work arounds will help anyone using Roon with the Element X until that time. Otherwise, I'm really happy camper with this piece. I highly recommend it.
 
Joined
Jul 20, 2019
Messages
15
Likes
11
I am in communication with Matrix through a Facebook post which has been very responsive towards the minor issues with the Element X. The latest firmware added SMBv2.0 window share support and support for Tidal natively. They are doing a great job being responsive and getting the bugs worked out and the features added. Good job Matrix!
 
Joined
Jul 21, 2019
Messages
9
Likes
6
I am in communication with Matrix through a Facebook post which has been very responsive towards the minor issues with the Element X. The latest firmware added SMBv2.0 window share support and support for Tidal natively. They are doing a great job being responsive and getting the bugs worked out and the features added. Good job Matrix!
I was communicating with them via email and was given fresher version of FW to try and solve the sync issues. It did get better but on completely solved yet.

Do you know when the new firmware will be available, interested in SMB update and Tidal.

EDIT: Just got the new version of the app and it updated it to a new firmware. Tried Tidal, but streaming does not seem to work in my case, stuck on a first second of the track and loops there indefinitely. Maybe my combination of the OS and firmware on the Element X that is not playing well. Let me know if you are able to stream anything from Tidal.
 
Last edited:

sonycman

New Member
Joined
Jul 31, 2019
Messages
3
Likes
2
Tried Tidal, but streaming does not seem to work in my case, stuck on a first second of the track and loops there indefinitely. Maybe my combination of the OS and firmware on the Element X that is not playing well. Let me know if you are able to stream anything from Tidal.
Hello!
Another owner here :)

Had updated the app and the firmware today as well, and it seems that Tidal works just fine for me.
Strange the Element is not automatically switched to MA Player mode (it was in USB DAC mode before I start streaming Tidal), and displays wrong sample frequency of currently playing track, but eventually it switches to player mode and all end up fine.

Sorry for bad english :(
 
Last edited:
Joined
Jul 20, 2019
Messages
15
Likes
11
I was communicating with them via email and was given fresher version of FW to try and solve the sync issues. It did get better but on completely solved yet.

Do you know when the new firmware will be available, interested in SMB update and Tidal.

EDIT: Just got the new version of the app and it updated it to a new firmware. Tried Tidal, but streaming does not seem to work in my case, stuck on a first second of the track and loops there indefinitely. Maybe my combination of the OS and firmware on the Element X that is not playing well. Let me know if you are able to stream anything from Tidal.
I am able to stream from Tidal and even MASTER MQA tracks, which displays as 352hz, but the MQA indicator didn't come on for whatever reason. I didn't try it for long this way as I use Roon for Tidal normally, but I played a few tracks.
 

sonycman

New Member
Joined
Jul 31, 2019
Messages
3
Likes
2
I am able to stream from Tidal and even MASTER MQA tracks, which displays as 352hz, but the MQA indicator didn't come on for whatever reason. I didn't try it for long this way as I use Roon for Tidal normally, but I played a few tracks.
You need to switch to MA player mode for the app to correctly display MQA track info, as I posted before.
 
Joined
Jul 26, 2019
Messages
22
Likes
22
The element P is interesting as well. I know its a different product, with a built in amp, but I'd love to know if the streamer section is the same as the M.

Also, your site rates it as 110 watts into 8Ω with 1% THD. Do you have the wattage rating at .1% THD?
Now this is interesting!

I just stumbled upon the Element P and I’m intrigued. It’s a much larger unit than what I was hoping to acquire BUT if it’s effectively an integrated amplifier with both a USB DAC *and* amplification then I might be willing to sacrifice space for it!

According to Matrix Audio amplification for the Element P comes from a single ICEpower 250ASX2 module.

Datasheet here: https://icepower.dk/download/1649/

You can find your THD+N vs Power graphs there. Doesn’t look too brilliant to be honest (I do prefer much more than 100W 4Ω @ <0.1% THD) so I’m going to have to think about this a little more. But the overall package does look really awesome! Has anyone got any experience with the Element P? It seems to be a much more niche product than the Element X and Element M. I wonder how the DAC segment compares!

Edit: Oops! I Was looking at the wrong datasheet (haha sorry too many tabs open on an iPad gets confusing) when I typed this post. We do actually get >200W 4Ω @ <0.1% THD from the 250ASX2! I might have to buy this now.
 
Last edited:
Joined
Jul 21, 2019
Messages
9
Likes
6
Edit: Oops! I Was looking at the wrong datasheet (haha sorry too many tabs open on an iPad gets confusing) when I typed this post. We do actually get >200W 4Ω @ <0.1% THD from the 250ASX2! I might have to buy this now.
I thought about that unit too, but so note that it uses ESS9028 not ESS9038. And, frankly, I prefer external amp (using Emotiva for now) so I can swap easily in the future. But again, if space is of the concern, it is an awesome unit to be had.
 
Joined
Jul 26, 2019
Messages
22
Likes
22
I thought about that unit too, but so note that it uses ESS9028 not ESS9038. And, frankly, I prefer external amp (using Emotiva for now) so I can swap easily in the future. But again, if space is of the concern, it is an awesome unit to be had.
Yep! Noticed that it's on the ESS9028 instead, though I honestly doubt that the difference will bother me too much and I have no reason to believe that the implementation of the DAC in its entirety will be anything short of excellent. I'm also fine with the entire solution being all-in-one, since I'm not the type to frequently upgrade my audio equipment. I really do like to get my money's worth, and my last system (with a PCM1792 in its DAC and two ICEpower 125ASX2 modules for amplification) almost lasted me a decade!

@MatrixAudio I'd like to ask a quick question if you don't mind :D

Will I be fine with placing a load of approximately 7KG on top of this DAC? I intend on purchasing this DAC for my PC and I would likely want to sit my monitor on top of it in order to reduce the amount of space that it'll occupy on my desk.

The Element P definitely looks like it's built like a tank, but I'd just like to seek for an opinion from you on this matter for peace of mind.

Thank you!
 
Top Bottom