• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Qobuz

GoMrPickles

Active Member
Forum Donor
Joined
Nov 6, 2018
Messages
103
Likes
85
#1
I'm trying out Qobuz, to see if it can unseat Spotify. Qobuz has "better audio quality," or might, if it worked. I didn't see a thread via search that this was appropriate for, but if it should be moved, NP.

Linux - Linux subsystem can't handle variable bitrate streams? OS limitation, not app, but limits the value vs Spotify.
iPhone/Airplay - limited to 44.1 KHz / Marantz AV8802A noise? Again, not Qobuz's fault, but limits value due to existing hardware.
Windows - App won't open most times, and when it does, it won't play most times. When it *does* play, using the computer (Core i7 with 16 GB RAM) interferes with the steam, which gets staticky or goes into half-time. This *is* Qobuz's issue.

When it doesn't open, I get this:
1600737581417.png


When it does open, I get this when trying to go to WASAPI mode:
1600737636900.png


I've filed support tickets with Qobuz, but I figured I'd post this here in case anyone was considering.

For more money per month than Spotify, it offers a substantially worse experience, with (IMO) inexcusable software issues across platforms. The audio quality is better than Spotify, but the library is smaller, there are no custom playlists based on artists I <3, etc.

If there's an approach to take with Qobuz that a longtime Spotify user wouldn't know about, I'm all ears... also happy to know of any solutions to the problems posted here. Said problems also occur immediately after a restart with no other program open, so it isn't a (non-startup) application conflict.

Cheers / TIA.
 

ahofer

Addicted to Fun and Learning
Forum Donor
Joined
Jun 3, 2019
Messages
683
Likes
1,037
Location
New York City
#2
I’ve found Qobuz had a much better classical library when I switched from Spotify two years ago. I’ve used it through Roon and BubbleUPnP without any issues like yours. I use the iPhone app occasionally - no problem. I almost never use the web app.
 
OP
G

GoMrPickles

Active Member
Forum Donor
Joined
Nov 6, 2018
Messages
103
Likes
85
Thread Starter #3
I’ve found Qobuz had a much better classical library when I switched from Spotify two years ago. I’ve used it through Roon and BubbleUPnP without any issues like yours. I use the iPhone app occasionally - no problem. I almost never use the web app.
I tried Roon a few years ago but opted against it because I didn't have a Roon "access point" or media server or whatever it needed.

Uninstalling and reinstalling Qobuz fixed this issue, although I don't know RC.
 

ahofer

Addicted to Fun and Learning
Forum Donor
Joined
Jun 3, 2019
Messages
683
Likes
1,037
Location
New York City
#4
I tried Roon a few years ago but opted against it because I didn't have a Roon "access point" or media server or whatever it needed.

Uninstalling and reinstalling Qobuz fixed this issue, although I don't know RC.
I'm still on a Roon trial license, but I have to say, it really does enrich the experience. The endpoints are stable compared to UPnP, and the integration of Qobuz and Tidal with my own library (federated search!) is incredible. I'm running it on an old laptop.
 

somebodyelse

Major Contributor
Joined
Dec 5, 2018
Messages
1,087
Likes
694
#5
What linux are you using that has problems with variable rate streams? I'm thinking of giving qobuz a try with LMS/piCorePlayer/squeezelite which doesn't have any problem with variable rate streams from other plugins.
 
OP
G

GoMrPickles

Active Member
Forum Donor
Joined
Nov 6, 2018
Messages
103
Likes
85
Thread Starter #6
What linux are you using that has problems with variable rate streams? I'm thinking of giving qobuz a try with LMS/piCorePlayer/squeezelite which doesn't have any problem with variable rate streams from other plugins.
I had Ubuntu 16; I upgraded to 18 to try Qobuz. Based on the DAC display, my options are 44.1 and 48 KHz, regardless of source.
 

ahofer

Addicted to Fun and Learning
Forum Donor
Joined
Jun 3, 2019
Messages
683
Likes
1,037
Location
New York City
#7
I'm using the app with windows 10 right now, streaming at the source resolution - 24/96
 
OP
G

GoMrPickles

Active Member
Forum Donor
Joined
Nov 6, 2018
Messages
103
Likes
85
Thread Starter #8
I'm using the app with windows 10 right now, streaming at the source resolution - 24/96
I have a raft of other issues on Windows. I have 2 open support tickets with Qobuz and I'm have a direct conversation with a PM. My complaints on another forum were evidently enough to warrant some attention.

My DAC does not go above 48 KHz with Ubuntu 16 or 18. Is there a way to fix this?
Probably; it's Linux.

Do I want to spend many days of my life working to improve my streaming audio quality from 44.1 to 96 KHz?
Probably not.
 

somebodyelse

Major Contributor
Joined
Dec 5, 2018
Messages
1,087
Likes
694
#9
My DAC does not go above 48 KHz with Ubuntu 16 or 18. Is there a way to fix this?
Probably; it's Linux.

Do I want to spend many days of my life working to improve my streaming audio quality from 44.1 to 96 KHz?
Probably not.
That's fair enough. I'm not sure if this will be quick enough for you to try, but it might help...

That'll be the PulseAudio default settings, resampling for mixing the sound from multiple apps. In version 11 they introduced a config option 'avoid-resampling=yes' so you can set it to happen only when necessary - see the pulse-daemon.conf man page for details. You'll be able to do this in Ubuntu 18 but not 16. Alternatively you may be able to use pasuspender to temporarily halt PulseAudio while your player app runs with a direct connection to the ALSA audio device - so long as the app doesn't require PulseAudio.
 
OP
G

GoMrPickles

Active Member
Forum Donor
Joined
Nov 6, 2018
Messages
103
Likes
85
Thread Starter #10
That's fair enough. I'm not sure if this will be quick enough for you to try, but it might help...

That'll be the PulseAudio default settings, resampling for mixing the sound from multiple apps. In version 11 they introduced a config option 'avoid-resampling=yes' so you can set it to happen only when necessary - see the pulse-daemon.conf man page for details. You'll be able to do this in Ubuntu 18 but not 16. Alternatively you may be able to use pasuspender to temporarily halt PulseAudio while your player app runs with a direct connection to the ALSA audio device - so long as the app doesn't require PulseAudio.
Thanks; tried this and it had no effect. 96 KHz track was downsampled to 48 Khz and sounds like it's being played on first gen earpods. Underwater. Good thought tho.

Tried with Foobar, instead of Audacious, and now it downsamples to 44.1 and sounds worse.
 
OP
G

GoMrPickles

Active Member
Forum Donor
Joined
Nov 6, 2018
Messages
103
Likes
85
Thread Starter #11
in PulseAudio world, are Booleans `false` and `true` or `false` and `yes`? Or some Schrodingerian combination?
 

somebodyelse

Major Contributor
Joined
Dec 5, 2018
Messages
1,087
Likes
694
#12
in PulseAudio world, are Booleans `false` and `true` or `false` and `yes`? Or some Schrodingerian combination?
From the man page:
For the settings that take a boolean argument the values true, yes, on and 1 are equivalent, resp. false, no, off, 0.
I should probably mention I try to avoid PulseAudio wherever possible, and use ALSA devices directly. Unfortunately for desktop use this is getting difficult.
 
Last edited:
OP
G

GoMrPickles

Active Member
Forum Donor
Joined
Nov 6, 2018
Messages
103
Likes
85
Thread Starter #14
What linux are you using that has problems with variable rate streams? I'm thinking of giving qobuz a try with LMS/piCorePlayer/squeezelite which doesn't have any problem with variable rate streams from other plugins.
I do not know what those things are, but LMK how it goes!
 

Bamyasi

Active Member
Joined
Feb 19, 2019
Messages
180
Likes
124
#15
My DAC does not go above 48 KHz with Ubuntu 16 or 18. Is there a way to fix this? Probably; it's Linux.
Simplest way to achieve variable sampling rate would be upgrading to Ubuntu 20.04 LTS. Pulsaudio in this Ubuntu release is configured to support automatic sample rate switching out of the box. I found it working pretty well here.

Note that Qobuz only streams in lossy MP3 format to all Linux web browsers (same is true for pretty much all other streaming services as well) and they do not have a Linux desktop app. This may explain why your DAC display always shows 16/44 regardless of the original track sampling rate. Qobuz web interface does not reflect the fact that they stick to MP3 in browsers. This is rather misleading and I have filed bug reports several times before with them but nothing seems to have changed so far.

But you can install UPnP renderer (e.g., Gmediarender) and then use a control app like BubbleUPnP or mConnect. This should work with Hi-Res streams. Oh, and it looks like VLC version 2.0 also has support for UPnP/DLNA. Never tried it myself though.
 
OP
G

GoMrPickles

Active Member
Forum Donor
Joined
Nov 6, 2018
Messages
103
Likes
85
Thread Starter #16
Simplest way to achieve variable sampling rate would be upgrading to Ubuntu 20.04 LTS. Pulsaudio in this Ubuntu release is configured to support automatic sample rate switching out of the box. I found it working pretty well here.

Note that Qobuz only streams in lossy MP3 format to all Linux web browsers (same is true for pretty much all other streaming services as well) and they do not have a Linux desktop app. This may explain why your DAC display always shows 16/44 regardless of the original track sampling rate. Qobuz web interface does not reflect the fact that they stick to MP3 in browsers. This is rather misleading and I have filed bug reports several times before with them but nothing seems to have changed so far.

But you can install UPnP renderer (e.g., Gmediarender) and then use a control app like BubbleUPnP or mConnect. This should work with Hi-Res streams.
Thanks for the info. In Ubuntu 18, Qobuz runs in Nuvola Runtime. Is that just a fancy web browser?
 

somebodyelse

Major Contributor
Joined
Dec 5, 2018
Messages
1,087
Likes
694
#17
I do not know what those things are, but LMK how it goes!
LMS is shorthand for Logitech Media Server which was the squeezebox server before that. I run it (among other things) on a headless linux pc, but you can run it on a variety of hardware including some NAS drives. It has a Qubuz plugin among others, but I haven't tried it yet, hence the interest. The plugin for the BBC radio streaming works with one of the adaptive bitrate streaming protocols (DASH?) which is what I initially thought you were talking about being a problem.
Squeezelite is a software implementation of the squeezebox player endpoint.
PiCorePlayer is an easy-to-use bundle of a minimal linux to run squeezelite and/or LMS on a raspberry pi. I only use it for the player part.
PiCorePlayer and the squeezelite running on my media player PC use the alsa device directly, and only resample if the device doesn't support the stream sample rate and/or bit depth - this is visible on DACs that indicate the bitrate and in the stream details under /proc/asound/cardX/. On Ubuntu desktop and laptop it's hard to avoid PulseAudio as too many common things now require it, and I put up with the resampling as it's not where I listen seriously.

The last blocker bug for the 18.04 to 20.04.1 LTS upgrade path was recently fixed, so it should soon pop up as an option.
 
OP
G

GoMrPickles

Active Member
Forum Donor
Joined
Nov 6, 2018
Messages
103
Likes
85
Thread Starter #19
Simplest way to achieve variable sampling rate would be upgrading to Ubuntu 20.04 LTS. Pulsaudio in this Ubuntu release is configured to support automatic sample rate switching out of the box. I found it working pretty well here.

Note that Qobuz only streams in lossy MP3 format to all Linux web browsers (same is true for pretty much all other streaming services as well) and they do not have a Linux desktop app. This may explain why your DAC display always shows 16/44 regardless of the original track sampling rate. Qobuz web interface does not reflect the fact that they stick to MP3 in browsers. This is rather misleading and I have filed bug reports several times before with them but nothing seems to have changed so far.

But you can install UPnP renderer (e.g., Gmediarender) and then use a control app like BubbleUPnP or mConnect. This should work with Hi-Res streams. Oh, and it looks like VLC version 2.0 also has support for UPnP/DLNA. Never tried it myself though.
Hi,
I upgraded to Ubuntu 20.04. Playing a 96 KHz FLAC file still leaves the DAC at 48 KHz. This is independent of Qobuz etc. Using Audacious.

ETA: Foobar2000 plays all files back at 44.1 KHz.
 
OP
G

GoMrPickles

Active Member
Forum Donor
Joined
Nov 6, 2018
Messages
103
Likes
85
Thread Starter #20
Okay, got my test file playing at 96 KHz in Audacious. I now sit in audio bliss, two OS upgrades and many config files later. JK, it sounds the same.

sudo /etc/pulse/daemon.conf

resample-method = speex-float-5
avoid-resampling = true

default-sample-format = s24le
default-sample-rate = 44100
alternate-sample-rate = 48000

I'm not sure which of these actually did the trick; it wasn't going to 96 KHz with just the first two lines enabled / uncommented.

I also installed PulseAudio Volume Control but did not use it to make any changes.
 
Top Bottom