• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). There are daily reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

Chromecast Audio is clipping at +80 % volume

Holdt

Member
Joined
Jun 10, 2022
Messages
76
Likes
51
Hi there

I have an annoying issue. -When I cast music from Spotify to my Chromecast Audio, I can't turn the volume on the Chromecast above ~80 %. If I do, the sound clips and distorts when e.g. a drum and a vocal is present at the same time.

The setup is very simple:
-Chromecast Audio
-Yamaha P3200 power amplifier (Input impedance = 30 kohm balanced, 15 kohm unbalanced)
-Connected via. analogue output from the Chromecast to the terminal strip on the Yamaha.

It isn't as such a huge issue, other than I haven't got the full volume band available. The solution is that I simply don't turn the Chromecast volume up all the way.
The amp itself isn't clipping. I can play loud by dialing up the gain controls on the Yamaha and keep the Chromecast volume < 80 %.

Chromecast has a toggle "full dynamic range". It doesn't matter if I toggle this switch in the setup.

My theory is that the Chromecast can't supply a high enough voltage or current at high volume and I wonder if I should buy a DAC with volume control or a line level amplifier / gain raiser - whatever it's called.

Any thoughts on the matter?
 
OP
Holdt

Holdt

Member
Joined
Jun 10, 2022
Messages
76
Likes
51
Looks like your amp gets max power at 1.6V already. The CCA gives 2V output, so if the pre-amp has no headroom it may clip.
Ah, of course. That's obvious if true. Haven't considered the other side of the coin as I thought it was lack of power from the CCA.

But how do you come to the conclusion that the amp is 1.6 V in input voltage?
 

voodooless

Master Contributor
Forum Donor
Joined
Jun 16, 2020
Messages
5,056
Likes
8,279
Location
Netherlands
But how do you come to the conclusion that the amp is 1.6 V in input voltage?
By the magic of User Manual:


It says +4.2dB for full power. I assumed they mean dBV..
 
OP
Holdt

Holdt

Member
Joined
Jun 10, 2022
Messages
76
Likes
51
By the magic of User Manual:


It says +4.2dB for full power. I assumed they mean dBV..
Ahh! -Thank you! It checks out.

gain.JPG


So.. Am I wrong in thinking that the only solution is to not use the upper 20 % or so of the CCA volume slider?
 

voodooless

Master Contributor
Forum Donor
Joined
Jun 16, 2020
Messages
5,056
Likes
8,279
Location
Netherlands
So.. Am I wrong in thinking that the only solution is to not use the upper 20 % or so of the CCA volume slider?
It’s not the only solution, just the only one that does not involve some kind of soldering or buying an extra device to attenuate the signal. I’d say: don’t worry about it.
 
OP
Holdt

Holdt

Member
Joined
Jun 10, 2022
Messages
76
Likes
51
It’s not the only solution, just the only one that does not involve some kind of soldering or buying an extra device to attenuate the signal. I’d say: don’t worry about it.
Oh well. Let's assume that I'm OCD enough to care. -Then a DAC with an attenuator / gain / volume control set to not output more than 1.6 V at full CCA volume be a solution? Then I get the full range on the Chromecast volume control.
 

DSJR

Major Contributor
Joined
Jan 27, 2020
Messages
1,824
Likes
2,322
Location
Suffolk Coastal, UK
The power amp has gain controls on it, right?

If you use a digital volume control into the CCA, to confirm the CCA is behaving itself, back the gain controls on the Yamaha down to say, 'one o'clock' (so around a third backed off from max) and try again with the CCA at maximum to see what happens. I use my geriatric Crown amps at around half to two thirds up as back then, it kept 'signal to hum-n-noise' in the interconnects as high as possible and the preamp was also used in it's best 'sinad' position too. Said preamp manages 10V output into the load presented, so it's easy to do.

My wireless network is a bit flaky at the best of times but trying to use two middle aged Android phones to stream music via VLC to my own CCA I find it goes into 'Dalek voice' mode if the phones are set to max output for a few minutes (it's as if a switch has been pressed). backing the phone output by 40 to 50% seems to help after a while, or cycling the casting function (CCA is fully visible and not hidden). I also have a middle age Chromebook and this will stream to the CCA with absolutely no glitches or audible distortion. I don't have my own music attached to this though, so it has to be streaming radio or YouTube here..

Hence my interest in cheap streaming devices like the Octavio if it'll take casting as well... Neat little box too rather than a plastic thing with pi bits hanging off it as some friends use ;)
 

DVDdoug

Major Contributor
Joined
May 27, 2021
Messages
1,240
Likes
1,532
I don't know anything about Chromecast....

My theory is that the Chromecast can't supply a high enough voltage or current at high volume
It can't be current with your high-impedance load.

The voltage shouldn't be an issue either... If the internal DAC is clipping at 80% (about -2dB) it's defective. The built-in power supply (USB) should always provide enough voltage to clip the DAC (at exactly 0dB). It could happen if the DAC has a separate power supply and you're using the wrong one.

An 80% volume control setting doesn't necessarily mean a digital level of -2dBFS. Usually digital audio levels don't go over 0dB and most digital volume controls only attenuate (no actual digital gain).

But it can happen if you boost with digital EQ, and certain applications can boost the digital level to over 0dB. In those cases the digital data is clipped before it hits the DAC.
 

Willem

Major Contributor
Joined
Jan 8, 2019
Messages
2,907
Likes
4,356
The analogue output of the CCA can have two settings: regular, which is something like 1.2V, and High Dynamic Range, which has nothing to do with dynamic range but is simply a 2.0V output level. If you opted for the High Dynamic Range setting you have the answer to your problem.
 
  • Like
Reactions: SMc
OP
Holdt

Holdt

Member
Joined
Jun 10, 2022
Messages
76
Likes
51
The analogue output of the CCA can have two settings: regular, which is something like 1.2V, and High Dynamic Range, which has nothing to do with dynamic range but is simply a 2.0V output level. If you opted for the High Dynamic Range setting you have the answer to your problem.
I'm not sure you are correct. What are your sources for these claims?

In the first post I wrote that I already tried to toggle this switch without it changing anything.
 

Willem

Major Contributor
Joined
Jan 8, 2019
Messages
2,907
Likes
4,356
I would have to look it up, but it is well documented with measurements on, I think, Hydrogen Audio. Sorry, it has been a while.
 
OP
Holdt

Holdt

Member
Joined
Jun 10, 2022
Messages
76
Likes
51
I would have to look it up, but it is well documented with measurements on, I think, Hydrogen Audio. Sorry, it has been a while.
Don't be. I will revisit the toggle. Maybe I was a bit in a hurry when I tried it first.
 
OP
Holdt

Holdt

Member
Joined
Jun 10, 2022
Messages
76
Likes
51
Isn't that just one guys claim? -Can't seem to find measurements in the linked thread.
It seems like he indeed has made measurements and posted the image of the waveforms. The upload has expired ubfortunately.

Thanks for the heads up though! I will revisit the toggle in a couple of days and take my time to investigate properly.
 
OP
Holdt

Holdt

Member
Joined
Jun 10, 2022
Messages
76
Likes
51
Here is one link: https://hydrogenaud.io/index.php/topic,110158.25.html Elsewhere there are even pictures of the waveforms.
Hi there

Being a dad and all, time is always a shortage. but better late than never. -I can confirm that the the sound is NOT clipping when the toggle for "full dynamic range" is set to OFF. So it seems I was too much in a hurry when I tried it out the first time. Thanks for the help. Can't seem to hear any difference in sound quality either, so I guess it's correct that the toggle is just a high / low voltage swap on the output.
 
Top Bottom