• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Topping D10 Setup Help

Joined
Dec 28, 2018
Messages
4
Likes
0
Location
Ottawa, ON
#1
Hey guys. I've been lurking in this forum for a few months now and bought the Topping D10 and JDS Atom based on their reviews. The topping setup guide only talks about setting up Foobar and I'm facing problems there. The option to select "Topping USB Audio Device" when double-clicking on foo_dsd_asio is not present in the drop down menu. What can I do to resolve this? Any help is much appreciated.
 
Last edited:
Joined
Dec 9, 2018
Messages
5
Likes
0
#4
I thought we didn't need drivers for Windows 10? They installed automatically and I'm able to use them.
Yeah, but you are trying to use ASIO.
You need the driver for that. The custom driver supports the ASIO protocol as well as native DSD.
Windows does not.

If all you care about is bit perfect streaming and won't use native DSD, you don't need the driver.
Just use WASAPI exclusive.
 
Last edited:
Joined
Dec 28, 2018
Messages
4
Likes
0
Location
Ottawa, ON
#5
Yeah, but you are trying to use ASIO.
You need the driver for that. The custom driver supports the ASIO protocol as well as native DSD.
Windows does not.

If all you care about is bit perfect streaming and won't use native DSD, you don't need the driver.
Just use WASAPI exclusive.
How do you use the WASAPI?
 

L5730

Active Member
Joined
Oct 6, 2018
Messages
236
Likes
98
Location
East of England
#7
Foobar2000 either has WASAPI support as standard or requires an extra component to enable it.
If it's installed/present, then you just go into Fb2k prefs, Output and find "WASAPI (event): Topping D10 USB" or something like that.
 
Joined
Dec 28, 2018
Messages
4
Likes
0
Location
Ottawa, ON
#8
Foobar2000 either has WASAPI support as standard or requires an extra component to enable it.
If it's installed/present, then you just go into Fb2k prefs, Output and find "WASAPI (event): Topping D10 USB" or something like that.
That worked but D10 display shows 44.1 when playing songs through foobar and 384 otherwise
 

L5730

Active Member
Joined
Oct 6, 2018
Messages
236
Likes
98
Location
East of England
#9
The sample rate will lock to whatever is playing through it.
Check Windows Sound prefs > Advanced and see what sample rate is selected there.
 

bravomail

Senior Member
Joined
Oct 19, 2018
Messages
402
Likes
145
#10
Ye. Do not set default windows sampling freq to highest. Set it to 44.1. Most DACs do not like high freqs (there are exclusions). Set bit depth to highest allowed though - 24 or 32. Use WASAPI in foobar (for music) and VLC (for movies). ASIO is old gimmick for Windows XP.
 

Roen

Addicted to Fun and Learning
Joined
Oct 14, 2018
Messages
587
Likes
205
#11
Ye. Do not set default windows sampling freq to highest. Set it to 44.1. Most DACs do not like high freqs (there are exclusions). Set bit depth to highest allowed though - 24 or 32. Use WASAPI in foobar (for music) and VLC (for movies). ASIO is old gimmick for Windows XP.
Why not 32/48 instead of 32/44.1?

MPC-HC in movies for me.

ASIO allows Native DSD via DSD Transcoder if that means anything to you.
 

daftcombo

Major Contributor
Patreon Donor
Joined
Feb 5, 2019
Messages
1,417
Likes
1,115
#12
Hi,
With a Topping D10 and a PC under Windows 10, would you leave the Windows volume (or JRiver volume) to 100 %, and set the volume on the amplifier, or use another way?
I use convolution and already apply a -6dB alongside speaker EQ/phase correction to the original signal, via the JRiver convolution tool, so even with loud recorded music, peak level is always <100% by a good margin (JRiver analyzer confirms it).
 

L5730

Active Member
Joined
Oct 6, 2018
Messages
236
Likes
98
Location
East of England
#13
For me, I always tell Windows to use some other sound device to output to, and set my playing software to use the DAC to output to. Stops any dumb Windows bings and bongs going to the decent listening rig.

I am using Foobar2000:
What I do is leave the DAC hardware volume (as controlled with the driver) at 100%. I generally leave Foobar2000 at 100% too.
Both of the active nearfield speakers are adjusted for a nice pressure level with -18 LUFS pink noise sent through.
ReplayGain (album mode) handles the adjustment of playback material to be about -18 LUFS on average.

Foobar2000 uses internal 64bit floating point math to do gain adjustments. For both it's volume control, pre-amp settings and ReplayGain.
I think JRiver uses 32bit floating point, or would expect at least that.

So, if you intend to use ReplayGain (or similar volume matching for playback systems) then setting your analogue amplifier for a comfortable listening volume would be fine. Providing your amplifier volume potentiometer is in the reasonable working range (all pots. behave better towards the middle than extremes) this is a good solution. If you think it's too loud and can't turn down the amplifier without thing starting to sound 'funny' (big loss of body, stereo image change etc.) then use software volume control or use the hardware control of the DAC chip via the driver.
 

L5730

Active Member
Joined
Oct 6, 2018
Messages
236
Likes
98
Location
East of England
#15
It just seems logical to do what I have done. I do not notice anything sounding bad because of it.
Try some different scenarios out and see what you think you hear, and then if you think you hear something, try and measure it.

Sorry, maybe someone else can give better advice here.
 

L5730

Active Member
Joined
Oct 6, 2018
Messages
236
Likes
98
Location
East of England
#17
If you are using Windows, be sure to use WASAPI or ASIO. These two will most likely provide the most unadulterated sound. The jury is out on which is better, if even at all measurably so.
Whilst WASAPI will allow Windows volume control, as I mentioned first off, I would set windows to use another audio device. So now, that volume control is out of the equation.
The wiki page you linked seems to indicate that you should either use JRiver internal volume (which is 64bit floating point) or the DAC hardware volume control.
 

daftcombo

Major Contributor
Patreon Donor
Joined
Feb 5, 2019
Messages
1,417
Likes
1,115
#18
I use ASIO both in Jriver and Foobar2000. For Foobar it's because WASAPI crashes. For JRiver, because I can't hear any difference.
I've turned JRiver to "internal volume". I will see if I can hear any difference.

Topping D10 doesn't have any volume co,ntrol, does it?
 

L5730

Active Member
Joined
Oct 6, 2018
Messages
236
Likes
98
Location
East of England
#19
What version of Windows are you running? (in the case of 10, what subversion/build: [win-key] + [r], type "winver" no double quotes, hit [enter]).
Have you updated Foobat2000 lately? You may not need v1.4.x, but the latest v1.3.x shouldn't crash.

The Topping does have a hardware volume control. It's actually inside the DAC chip and is controlled through software.
You'd need to download and install the Topping driver, which auto starts an icon in the system tray. It has a volume control and this will allow manipulation of the PCM gain on the DAC chip. If you feed it DSD you may get low level noise (DoP ?) or a loud static sound (DSD native ?). It seems you are running a pure PCM setup anyway with the other DSP you are employing.
 

daftcombo

Major Contributor
Patreon Donor
Joined
Feb 5, 2019
Messages
1,417
Likes
1,115
#20
I found the Topping software with volume control. It was set to 0. USB is "reliable" and buffer "auto".
I'm gonna control the gain in JRiver through "internal volume" now.

My crarshing Foobar2000 is v1.3.17.
Windows 10 v1809 // 17763.379.
 
Top Bottom