• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

D50s issues: will only play pcm 48kHz

Joined
Jul 10, 2020
Messages
14
Likes
4
Location
West Melbourne, Florida, USA
#1
I just got a d50s it seems that no matter what I play, the display is always set to PCM 48kHz. I have some dsd and hires files to no avail. I have downloaded some test files from http://www.2l.no/hires/ with the same results. Using Windows 10 with the default USB driver, tested grove and foobar.
Tried so far:

1) Powercycle unit several times
2) Install Sony Hi Res Player
3) Install FooBar 2000 1.5.5 (confirms that files higher bit-rate / definition).
4) Change the filter in the D50s


My first standalone advanced DAC so I dont know if I am missing something or I have a bad unit.

Tks in advance.
 

Jimbob54

Major Contributor
Forum Donor
Joined
Oct 25, 2019
Messages
2,214
Likes
1,587
#2
I dont know Foobar etc but I suspect everything is going through the Windows sound controls - which outputs to a designated sample rate - 48khz in your case.

I suspect in the Foobar settings (or most other player software) there is an "enable exclusive mode" setting- this means Windows lets the software send directly to the USB DAC- sending whatever rate Foobar is playing/ sampling to.
 

JohnYang1997

Major Contributor
Joined
Dec 28, 2018
Messages
3,742
Likes
5,102
Location
China
#3
Install proprietary driver from the website or ask support for it. And follow the instructions in the driver package to set up foobar.
 
OP
frabor
Joined
Jul 10, 2020
Messages
14
Likes
4
Location
West Melbourne, Florida, USA
Thread Starter #6
Installed the ASIO driver (comes with the topping package), and proceed with the configuration of the foobar. works now.

a rather convoluted process, really a pain in someting that should be semi automated by the manufacturer. even the docs are not clear and some are years old (asio)

Is this a windows only problem?
Does the raspberry pi require a similar process or its built on the os?
 

JohnYang1997

Major Contributor
Joined
Dec 28, 2018
Messages
3,742
Likes
5,102
Location
China
#7
Installed the ASIO driver (comes with the topping package), and proceed with the configuration of the foobar. works now.

a rather convoluted process, really a pain in someting that should be semi automated by the manufacturer. even the docs are not clear and some are years old (asio)

Is this a windows only problem?
Does the raspberry pi require a similar process or its built on the os?
It's the same for every OS with a mixer. A mixer mixes different sounds from different processes. It resamples them and sums them, then your audio device can use single sampling rate of your operating system, which was 48khz in your case.

Asio bypasses the process. Hence if your audio file is at a different rate than the mixer, you will only be hearing the music you play. You will not be hearing any messages, calls, videos etc.

WASAPI does the thing similar.

A simpler way is just to ignore it and play it as convenience. It won't make much of a difference.
 
OP
frabor
Joined
Jul 10, 2020
Messages
14
Likes
4
Location
West Melbourne, Florida, USA
Thread Starter #8
kind of agree with you with the "just ignore", I cannot hear any difference, and I only have a couple of files available. it makes the process of updating players and/or the operating system an exercise. i wanted to do it just to see if the unit was ok and not faulty. (it was a customer return at 60% of retail). IMHO the installation of advanced audio codecs should not be a dance, and since windows has over 100 million lines of code, it is time for Microsoft to fix such a trivial problem, and stop considering audio as some external esoteric function that requires user interaction for configuring another thing than pcm. windows has a game mode that gives priority 3d video processing, ,why not the same for audio?
1596310596457.png
 

gvl

Major Contributor
Joined
Mar 16, 2018
Messages
1,924
Likes
1,697
Location
SoCal
#9
Installed the ASIO driver (comes with the topping package), and proceed with the configuration of the foobar. works now.

a rather convoluted process, really a pain in someting that should be semi automated by the manufacturer. even the docs are not clear and some are years old (asio)

Is this a windows only problem?
You just had to select WASAPI Exclusive mode in Foobar previously instead of the default audio device, no real need to install the drivers unless your W10 is not up to date or you actually need to use ASIO for some reason - some professional music application only support that for bit-perfect playback, or Amir's analyzer...
 

Jimbob54

Major Contributor
Forum Donor
Joined
Oct 25, 2019
Messages
2,214
Likes
1,587
#10
kind of agree with you with the "just ignore", I cannot hear any difference, and I only have a couple of files available. it makes the process of updating players and/or the operating system an exercise. i wanted to do it just to see if the unit was ok and not faulty. (it was a customer return at 60% of retail). IMHO the installation of advanced audio codecs should not be a dance, and since windows has over 100 million lines of code, it is time for Microsoft to fix such a trivial problem, and stop considering audio as some external esoteric function that requires user interaction for configuring another thing than pcm. windows has a game mode that gives priority 3d video processing, ,why not the same for audio?
View attachment 76176
They kind of have. Exclusive mode, should software wish to request it.
 
OP
frabor
Joined
Jul 10, 2020
Messages
14
Likes
4
Location
West Melbourne, Florida, USA
Thread Starter #11
exclusive mode give the software direct access to the hardware bypassing the windows libraries, but to my understanding there is no kernel priority or affinity tuning that comes bundled with it. In theory, game more is an optimized mode that pushes gaming first.
 
OP
frabor
Joined
Jul 10, 2020
Messages
14
Likes
4
Location
West Melbourne, Florida, USA
Thread Starter #12
jimbob54, tks for the exclusive tip. now all works well (had to disable it). with exclusive mode the pc was refusing to play sound after using foobar and Equalizer APO / Pace was not communicating. now all works great, I can play high bitrate / resolution files while using Equalizer apo. next step, calibrate the room with REW and equalize via Equalizer APO.
 
Top Bottom