• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required. There are many reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

ELAC Unifi 2.0 UB52 high frequency rattling noise in the back of the speaker

srki80

Member
Joined
Jan 5, 2023
Messages
5
Likes
1
Hello everyone,

I've recently purchased the ELAC Unifi 2.0 UB52 speakers. I'm noticing a significant high-frequency rattling noise in the back of the speakers. Both speakers are affected, however, one more than the other. I've linked a video recording where you can hear the rattle/buzzing. I tried tightening the binding post, and binding post cup and tried the cable from the less affected speaker but no improvement. At first, I thought it was coming from the binding post area, but it's really hard to tell. If I lean in and put my ear near the speaker I can also hear it quite a bit near the top at the level of the tweeter. Any idea where this is coming from?

I use these WBC cables and Yamaha A-S801

https://photos.app.goo.gl/U9GNTk2tqmwECDZQ6

Thank you.
 
Darn, that's annoying. I would guess the binding post screw or spacer on the inside of the terminal has rattled itself loose.
Or maybe some clip on the inside has come loose.

You will have to operate, Dr. @srki80!

Also Welcome :D
 
@TheBatsEar Thanks for the suggestion. I've taken out the binding post cup, and it's not the loose binding post inside nuts; it's actually coming from whatever is attached to the back wall of the speaker (I think it's the crossover?). If I get my finger in there and press against something that feels like a cylinder, the rattling is no more. I see no way to get to it and examine it. I will likely have to send this back for servicing :confused:
 
@TheBatsEar Thanks for the suggestion. I've taken out the binding post cup, and it's not the loose binding post inside nuts; it's actually coming from whatever is attached to the back wall of the speaker (I think it's the crossover?). If I get my finger in there and press against something that feels like a cylinder, the rattling is no more. I see no way to get to it and examine it. I will likely have to send this back for servicing :confused:
Maybe.
Or maybe you can pull off the ring in front of the woofer and get access that way? Sending them in would take weeks and is some hassle.

71FJGZKLq2L._AC_SL1500_.jpg
 
Your description suggests loose component/s on the crossover board.

I found this picture of the crossover.

1672885422639.jpeg


Front speaker trim ring/s will come off, remove the drivers and access the crossover. Then locate the offending components.
 
I think it was the yellow cylinder I was pressing against. Although it could be that I was pressing the whole panel over the cylinder. I'll see what I can do tomorrow. Even if I identify offending components, I'm not exactly sure what to do with them at this point. Based on the picture, there are no screws to be tightened.
 
I think it was the yellow cylinder I was pressing against. Although it could be that I was pressing the whole panel over the cylinder. I'll see what I can do tomorrow. Even if I identify offending components, I'm not exactly sure what to do with them at this point. Based on the picture, there are no screws to be tightened.

There should be plenty of adhesive on the board, holding down the components. However, in transit, coils and caps can crack the adhesive and cause really annoying noises like what you are hearing. It's very common and has been forever.

Hopefully, the trim rings covering the mounting flange on the woofer will release easily without damage. If you have any doubts about being able to remove the trim ring/s, leave it alone and claim the whole thing under warranty as trust me, if you damage/crack/scratch the trim, you'll have to look at the carnage and kick yourself. The trim ring looks like it has pins, likely glued in, so be careful and use something like a thin guitar pick near the pins to release. Maybe even heat it a little as it's likely they used hot melt glue to secure the moulding.

Hot melt glue or preferably RTV will be fine for securing the offending component/s.

Looks like there will be 7x screws holding the X/over to the cabinet and likely some wadding under the PCB, which usually puts the PCB under some flexing strain to help with vibrations. Let us know how you go.
 
I decided not to open them up because even if I did, the access to the crossover would be pretty tricky. I'll be sending them back to Elac for servicing.
 
Back
Top Bottom