• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

BEGINNER QUESTION : Getting "BitPerfect" output in Linux ?

PenguinMusic

Active Member
Joined
Dec 20, 2019
Messages
246
Likes
56
#1
Hi guys,

As somewhat that can be considered as more or less a beginner in the computer audio domain, I run the following set-up :
- Computer workstation with Linux (Arch based Manjaro distro) ;
- ASUS Xonar Essence STU DAC/headphone amp ;
- several headphones (Audioquest Nighthawk, Oppo PM-3, Sennheiser HD-700, B&0 H9i...).

The ASUS Xonar Essence STU has a little indicator that should light up when the output is "BitPerfect".

I have read several guides and tried several audio players, but whatever I do, that indocator doesn't light up :-(

Anyone in here skilled with GNU/Linux Manjaro or Arch ?

Regards.
 

q3cpma

Addicted to Fun and Learning
Joined
May 22, 2019
Messages
994
Likes
1,063
Location
France
#3
There's a good chance this LED is controlled by a proprietary Windows driver (which you don't have, obviously). The usual way to get bitperfect on GNU/Linux is to use ALSA without volume control (or volume at 100) and set the output bitdepth/sampling rate to be the same as your source files.
 
OP
P

PenguinMusic

Active Member
Joined
Dec 20, 2019
Messages
246
Likes
56
Thread Starter #4
Hi,
Thanks for your answers.

I can take that expalantion about the "bitPerfect" indicator.
Too bad it is always nice to know what is the output and if indeed I take advantage of the hi-res music I bought :)

Is there no way to tell ALSA to automatically adjust sample rate ?
I have so 16/44 files + 24/44 files + 24/48 files + 24/88 files + 24/96 files...

It would be nice to have it switched in a transparent mode :-(
 

pos

Senior Member
Joined
Feb 13, 2018
Messages
465
Likes
451
#6
@PenguinMusic, you will probably want to get rid of the pulseaudio layer, as it provides resampling for concurrent use of a given audio device.
Altering volume or simply going from one bit depth to another is pretty harmless (if done properly and purposely), but going from one sampling rate to another is not.
 

renaudrenaud

Senior Member
Joined
Apr 20, 2019
Messages
364
Likes
557
Location
Paris
#7
You can also have a try with Daphile. It's very interesting and is working with few ressources. You can recycle an old computer or use something like an Atomic Pi card.

Pulse audio has also good press. I've planned to have a look next year on it, it seems a very very interesting piece of code!
 
Joined
Jan 8, 2019
Messages
45
Likes
26
#9
Is the computer dedicated to audio or mixed use? If dedicated to audio, then there are some "audiophile" linux distros. If mixed use, I'd keep pulseaudio, it just makes life easier. I run Mint+mpd+ncmpcpp, and have no real issues. In the past I have found "speechdispatcher" caused some browser bleed through noise when running music in the background, not sure if it's still an issue.
 
OP
P

PenguinMusic

Active Member
Joined
Dec 20, 2019
Messages
246
Likes
56
Thread Starter #10
Hi,

Thanks to all for your replies.

I always turn computer volume to 100% and control output volume with the headphone amp.

The computer is used for mixed uses.
It's my daily working machine and I would like to be able to listen to music in a decent quality while working.

And as I bought some "hi-res" music in 24/48 or 24/96 format, I'd like to take advantage of it.

It seems it is not trivial to make sure about the format that is played.

Some members of the Manjaro support team said Pulse Audio would convert files to 16/44 automatically...
Which I would like to avoid :-(

It seems getting Linux as an "audiophile" player is all but trivial :-(
 
Joined
Sep 7, 2019
Messages
32
Likes
31
#11
It seems getting Linux as an "audiophile" player is all but trivial :-(
In a desktop setting this might be true although I'm sure it can be done. In the "Audio world" Linux is mostly used as streamer for Raspberry Pi or equivalent distros. Examples are Volumio, moOde and Rune. I use moOde audio player for Raspberry myself.
 

renaudrenaud

Senior Member
Joined
Apr 20, 2019
Messages
364
Likes
557
Location
Paris
#12
Screenshot from Daphile. Using a Sabaj D5 / SMSL SU8.

I can select "BitPerfect" if it is what I need. I cans resample to 768000Hz if it is what I want. Etc...

DaphileSabajD5.png


So it is an "Audiophile" distro for Linux. What I like it the low ressources consumption (Working with Atomic Pi = no fan, very low electric consumption) and the really easy configuration.

It can run from an USB stick in few minutes. So you can waste an hour to prepare your stick, test it with your current computer starting on the USB stick, and validate or no the idea.

Daphile: https://www.daphile.com/
Atomic Pi: https://www.amazon.com/s?k=atomic+pi&ref=nb_sb_noss_1
 
OP
P

PenguinMusic

Active Member
Joined
Dec 20, 2019
Messages
246
Likes
56
Thread Starter #13
Screenshot from Daphile. Using a Sabaj D5 / SMSL SU8.

I can select "BitPerfect" if it is what I need. I cans resample to 768000Hz if it is what I want. Etc...

View attachment 43728

So it is an "Audiophile" distro for Linux. What I like it the low ressources consumption (Working with Atomic Pi = no fan, very low electric consumption) and the really easy configuration.

It can run from an USB stick in few minutes. So you can waste an hour to prepare your stick, test it with your current computer starting on the USB stick, and validate or no the idea.

Daphile: https://www.daphile.com/
Atomic Pi: https://www.amazon.com/s?k=atomic+pi&ref=nb_sb_noss_1
Hi,

The problem is, that I can't use a dedicated distro.
I need this as my own working computer.
And I don't think that I can use Daphile for general purposes :-(

If that can be done on Daphile as a GNU/Linux distro, I am almost sure it can be "ported" to another "regular" distro...

I'll have to dig that out a little.

Thanks a lot.

Regards.
 

graz_lag

Major Contributor
Joined
Oct 13, 2018
Messages
1,296
Likes
1,438
Location
Le Mans, France
#15
Hi guys,

As somewhat that can be considered as more or less a beginner in the computer audio domain, I run the following set-up :
- Computer workstation with Linux (Arch based Manjaro distro) ;
- ASUS Xonar Essence STU DAC/headphone amp ;
- several headphones (Audioquest Nighthawk, Oppo PM-3, Sennheiser HD-700, B&0 H9i...).

The ASUS Xonar Essence STU has a little indicator that should light up when the output is "BitPerfect".

I have read several guides and tried several audio players, but whatever I do, that indocator doesn't light up :-(

Anyone in here skilled with GNU/Linux Manjaro or Arch ?

Regards.
You have to disable PulseAudio and get ALSA instead.

Pls. double check these settings : (make a copy of the original .conf files first naming the copies as confbackup for example)

For ALSA : the file "/etc/modprobe.d/alsa-base.conf" should have the following line added (if not existing) or the index of "snd-usb-audio" should be set to "0":
options snd-usb-audio index=0

For PulseAudio : scroll through the file "/etc/pulse/client.conf" then uncomment (remove the ; character) and edit the following line.
From:
; autospawn = yes
To:
autospawn = no

Save the file, restart/reboot the system, PulseAudio should now be turned off.
ALSA will now be used instead.

Other tips :
alsamixer : you open up a terminal and simply type the command alsamixer
testing for bit-accurate reproduction via USB : you can get the correct bit-accurate reproduction directly using the terminal when playing a song: sudo cat /proc/asound/card0/pcm0p/sub0/hw_params
(note that you should use either card0 or card1 according to your own playback hardware)
listing the connected playback hardware devices/DAC, so card0 or card1 : aplay --list-devices
 

Sal1950

Major Contributor
The Chicago Crusher
Forum Donor
Joined
Mar 1, 2016
Messages
7,243
Likes
5,577
Location
Central Fl
#16
I use Strawberry in PCLinuxOS, very easy to set up for bit-perfect and will work around Pulse, no need to disable (at least in my distro) Handles multichannel files over HDMI in PCM with no issues.
Strawberry1.png


Strawberry.png
 

Sal1950

Major Contributor
The Chicago Crusher
Forum Donor
Joined
Mar 1, 2016
Messages
7,243
Likes
5,577
Location
Central Fl
#18
Indirectly, not strictly the subject, but I am so happy to see some people using Linux!
I've been 99% exclusive on Linux since 1999.
Boot into Windoz a few times a week to update my Quicken financial software and a couple other small things. Yuck. :)
There are others here that do the same.
 
OP
P

PenguinMusic

Active Member
Joined
Dec 20, 2019
Messages
246
Likes
56
Thread Starter #19
Hi Sal,

Thanks for the Strawberry tip...
I know that software and I really never got to understand it's logic.
Or maybe it simply doesn't fit my wantings.
But I will try it again...

I tend to use gmusicbrowser.
I have configured it to use ALSA, but I think it does not as I can still control output volume with the system volume.

I may try to install JACK... Not sure how to do it, but I'll find out :)
 

Phorize

Member
Forum Donor
Joined
Apr 26, 2019
Messages
93
Likes
49
#20
Hi guys,

As somewhat that can be considered as more or less a beginner in the computer audio domain, I run the following set-up :
- Computer workstation with Linux (Arch based Manjaro distro) ;
- ASUS Xonar Essence STU DAC/headphone amp ;
- several headphones (Audioquest Nighthawk, Oppo PM-3, Sennheiser HD-700, B&0 H9i...).

The ASUS Xonar Essence STU has a little indicator that should light up when the output is "BitPerfect".

I have read several guides and tried several audio players, but whatever I do, that indocator doesn't light up :-(

Anyone in here skilled with GNU/Linux Manjaro or Arch ?

Regards.
As per other replies you don’t need to configure the audio sub system further. You can reduce the kernel latency for recording applications with an option at compile time-this doesn’t benefit replay.
 
Top Bottom