• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required. There are many reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

XMOS driver settings for no cutoff/delay

Does nothing if you have only one device that uses the driver.
As far as I know the stream mode keeps the advice "active" at all times feeding it zeros when inactive, but it will not "pop" when changing streams etc then. Connection stays active.
Is the pro audio driver with less latency when using with DAWs. Nothing with impact in terms of sound.
I thought that this was somehow connected with DAW, but I hoped that it affects playback, unfortunately not ok.
This fix works for Windows, but I also get the same issue on MacOS using a SMSL SU-9 Pro. anybody knows how to set the DAC to AlwaysOn on MacOS?
I'm on linux. Is there a way to do this on linux?
I'm on linux. Is there a way to do this on linux?
I figured out that I don't need to do anything. It was either a USB port malfunction, a kernel malfunction, or a user error. I could not reproduce the issue.
You are my lifesaver!!!! Big shout out to you!

Why do the DAC manufacturers set the streaming default option to "on when needed"? What is the benefit of it?
My thanks as well. An easy to follow tutorial that works.
Thank you so so so much. Had been looking for weeks (months?) at how to get rid of those click pops on my SMSL C200. Had tried many things but this little change finally nailed it. You have my gratitude :)
I was contemplating on creating a "tutorial" of sorts for all XMOS drivers on devices that have a cutoff -- latency between the start of a sound and the dac "reacting" and actually playing said sound...
So here it is:

XMOS drivers use a control panel not unlike this:
View attachment 147854

Usually the "Options" menu which is the interesting part for our needs is not present. Please be aware that *some* manufacturers still opt in to lock out that menu completely regardless of what we are about to do and you will still be unable to show and use it.

So, first we need to find where this control panel is located. To find out where yours is, check the process in the task manager:
View attachment 147862

For SSL it is here (for others it will be in the directory where the USB driver was installed):
View attachment 147856

To make this work, please exit/quit the XMOS driver control panel from the tray icon and make sure the xxxxAudioCpl.exe process is not running.

Afterwards open the marked XML file with your favorite text editor and we are greeted with something of this sort:
View attachment 147857

If this section is not present in your xml file, you will need to manually add it. Here is the xml sample for convenience:

<!-- ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ -->
        <!-- Supported values for this page: Hidden (default), Visible  -->

With that XML section in place or it being absent your CPL will look like this (no Options):
View attachment 147858

We need to change from Hidden to Visible to make it so and Save the file:
View attachment 147859

After you save the xml file, please start your control panel from the exe above the xml (see View attachment 147856 ). If everything has gone correctly and your DAC manufacturer has not locked off the use of the Options menu, you will now see:
View attachment 147860

The default is "on when needed", however if you want no latency between start song/video - dac playing said sound - you need to set it to "Always On"

This is by no means maliciousness on behalf of DAC manufacturers (except the ones that hide it despite the above efforts), but complete and utter incompetence or at the very least ignorance.

That's it! You now have a DAC that will not cut off start of songs unless you possibly update the driver and revert the change :)

@amirm if there is no other topic that discusses the matter, could you please pin this as i've seen quite a few complaints about this issue.
Good find.
Yay, found my problem! :D Thank you so much @Noodles . Tested it on Windows and this setting definitely fixes the issue. Only problem is I do not run the DAC via Windows but through RoPieeeXL. I have now asked the author if he can fix it: https://community.roonlabs.com/t/release-ropieee-2023-07-1/249742/31?u=teun_romme
Here is Harry's response, there is no quick fix for Linux.

Wait ... is this issue just for SMSL dacs or any dac using XMOS chips? I have the new SMSL DO400 coming in next week and it uses the 3rd gen XMOS316. Will this stuttering problem also manifest with this new device?
Top Bottom