• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). There are daily reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

Topping MX5, A new device?

terryforsythe

Member
Joined
May 4, 2022
Messages
52
Likes
15
I received my MX5 today and had some issues and managed to fix it, which might perhaps point somebody into hopefully the right direction.

There was no speaker output, just occasional 'pops', not loud, of some medium frequency. This occurred with analog and digital input. Headphone output was fine.
I upgraded the firmware, which was 1.02, to 1.04 and the problem remained, but the frequency of the pops grew to about 1 per second.
These pops seem to be in line with some issues I've been reading online.

On a different pair of speakers everything seemed fine!

So I started looking at my speaker filter and dug up some old forum thread. My woofer has a small capacitor over the main woofer inductor, which helps for higher frequency cone breakup. It had no resistor in series with this capacitor. I've read this could tax the amplifier in a way it might not like. Other crossovers of the same manufacturer DO have a resistor in series with the capacitor!

I had a few 6.8 Ohm 10 W resistors laying around so I soldered them in series with the little capacitor, and now everything seems fine.
There are no pops, no hisses, and I can't detect any noise when the speakers are muted.

Since my other two amplifiers, all simple class D or T type jobbies, worked fine with these speakers, maybe the MX5 is sensitive to inductive loading or whatever happens when this resistor was missing.

Of course each speaker is different, but it might point into the direction of some form of sensitivity that this amp has to certain speakers and filters.
Without the resistor in series with the capacitor that is in parallel with the inductor, the impedance of your speakers was too low for this amplifier at high frequencies. I don’t know what your capacitance values are, but at high enough frequencies the circuit will appear almost as a short circuit.
 

Usatencu

New Member
Joined
Aug 27, 2022
Messages
3
Likes
1
Hello! I just bought topping mx5 with kef q350 and chord c screen speaker cables. I was afraid about noises or something else, but for me it s running dead silent, I put volume 100 and nothing, completely silent in all modes. It s sound very nice, i don't have audiophile experience, previous setup was q acoustics m20, also nice but no tone controls and lacking little bit in bass. In conclusion it a good upgrade for me, i don't know why this amp has so many bad reviews, sound it s full and very clear
 

spiritofjerry

Active Member
Joined
May 8, 2018
Messages
146
Likes
105
From time to time I drop in on the community to see if any desktop all in one units that meet my needs have been developed, and here I was excited to see a new Topping offering that nearly does... only to be let down by design flaws with the switching noise and the lack of a subwoofer/pre out. The Loxjie unit from a few years back was almost there, but the headphone stage was just too anemic to be useful.

I'll check back in another 6-12 months.
 

Usatencu

New Member
Joined
Aug 27, 2022
Messages
3
Likes
1
I had some problems with dropping sound only by optical cable and only on tv mode, rest of them working, youtube sptotify. I contacted topping service by email and they send me private 1.5 update, it s not on the site. And now everything working perfect.
 

Attachments

  • MX5-2.zip
    211.5 KB · Views: 57

warpdrive

Member
Joined
Jan 21, 2021
Messages
81
Likes
62
do regular banana plugs fit into the terminals? They look smaller than usual in the picture
 

Technically

Member
Joined
Oct 10, 2021
Messages
12
Likes
2
Location
Portugal
I had some problems with dropping sound only by optical cable and only on tv mode, rest of them working, youtube sptotify. I contacted topping service by email and they send me private 1.5 update, it s not on the site. And now everything working perfect.
Hi, Why the heck Topping won't publish that new firmware ? I'm kind of afraid to flash my unit with that file you posted here...
 

Usatencu

New Member
Joined
Aug 27, 2022
Messages
3
Likes
1
Hi, Why the heck Topping won't publish that new firmware ? I'm kind of afraid to flash my unit with that file you posted here...

You can flash without problems or if you don t trust me, you can contact them by email and i think they will send you same file, but in a few days. Best regards!
 

warpdrive

Member
Joined
Jan 21, 2021
Messages
81
Likes
62
From time to time I drop in on the community to see if any desktop all in one units that meet my needs have been developed, and here I was excited to see a new Topping offering that nearly does... only to be let down by design flaws with the switching noise and the lack of a subwoofer/pre out. The Loxjie unit from a few years back was almost there, but the headphone stage was just too anemic to be useful.

I'll check back in another 6-12 months.
FWIW, I just got mine and there is zero switching noise between inputs

The lack of a subwoofer out is definitely an omission they should address.

The headphone stage seems quite good, lots of power for my Hifiman, HD600 and Focal
 

IntoTheRainBowVeins

New Member
Joined
Nov 3, 2022
Messages
1
Likes
0
Ordered a used one on Amazon for ($198 (amazon used price) - $35 (Reward Points) + $13.86 (Tax)) = $176. Not a bad deal, really looking forward to this amp for my desk. Agree with others about lack of outputs, hope the next interaction has even more features at the $300 price point.
 

djrodrigues

New Member
Joined
Nov 20, 2022
Messages
2
Likes
0
Hello,
For the people who ordered this amp very recently, do the noises when not using the speakers still exist?
Very interested in buying one...
Thanks!
 

D!sco

Active Member
Joined
Jun 16, 2021
Messages
265
Likes
198
Hello,
For the people who ordered this amp very recently, do the noises when not using the speakers still exist?
Very interested in buying one...
Thanks!
I just have to ask, why would you get an MX-device and not use the speaker output? There are way better dedicated HP/DAC/AMP devices for less.
 

djrodrigues

New Member
Joined
Nov 20, 2022
Messages
2
Likes
0
I just have to ask, why would you get an MX-device and not use the speaker output? There are way better dedicated HP/DAC/AMP devices for less.
I didnt say I was never going to use the speakers.

From what I read I believe the problem was noise when on standby mode.
 

warpdrive

Member
Joined
Jan 21, 2021
Messages
81
Likes
62
Mine is fine. A very slight tick/pop when turning off. No noise when switching inputs. Silent when the power is on and no signal

I'm happy with this device. The terminals are too close together to use my banana plugs so I tinned the wire instead.
 

Houna67

New Member
Joined
Nov 21, 2022
Messages
3
Likes
0
Hello,
For the people who ordered this amp very recently, do the noises when not using the speakers still exist?
Very interested in buying one...
Thanks!
Hello happy people, I just subscribed to this forum as I am seeking information on the MX5 and other little things.

I took the risk, having read this whole thread before, and ordered it like 10 days ago because I couldn't find a device that would do it all in one convenient box.

And I have that hissing noise !

Only when on the headphone output. The volume of the hissing is really low but I use open back headsets at my home desk so when the volume of the music goes low, I can hear it. It is quite inconsistent though. Sometimes it is hardly noticeable. Or totally gone, like right now.

Also I use it in a desktop setup with the speakers (Eltax monitor 3) at arm length. So kind of a worst case scenario.

I updated to 1.04, I don't think it changed anything. I didn't take notes to compare but maybe the hissing was present when on mute but no longer ? Now it is really silent whenever on mute or with the speaker out (even speaker + headphone, but I don't get the benefit of that option). I didn't take another risk with the version 1.05 of the firmware posted on this thread a while ago but I emailed to the topping customer service for information.

But right now, I hear absolutely no noise. Inconsistent, I said. So worst case I'll move it to the living room but I still don't know what could replace it with the limited space on my desk.
 

gr-e

Active Member
Joined
Jan 5, 2019
Messages
142
Likes
238
I updated to 1.04, I don't think it changed anything. I didn't take notes to compare but maybe the hissing was present when on mute but no longer ?
Yes, on 1.02 pressing the mute button in speaker mode muted the power amp (and that's what causes the high pitched noise to come through). On 1.03 and newer they partially fixed the issue by muting the preamp section instead. Unfortunately, this trick won't work for when the headphone out is used, because muting the preamp will disable both outputs.
 

luxxxman

Member
Joined
Mar 2, 2022
Messages
8
Likes
2
I had some problems with dropping sound only by optical cable and only on tv mode, rest of them working, youtube sptotify. I contacted topping service by email and they send me private 1.5 update, it s not on the site. And now everything working perfect.
Thanks so much for posting about this -- finally my MX5 is fixed and I'm not getting any dropouts via optical from my TV! This device is now pretty much perfect in terms of features and value for money. Like some of the other posters here I wasn't sure about installing firmware that I didn't receive directly from the source, but I decided to take a calculated risk -- I can confirm it's legit. Very weird that Topping didn't post it on the public website -- I've been checking on and off form months now for a firmware update. Thanks again!
 

Houna67

New Member
Joined
Nov 21, 2022
Messages
3
Likes
0
I installed it too but it did not change a thing about the hissing. At least it didn't break anything, so yay. I am trying to return it ie I am still trying to explain that an amplifier is not functional with a sound like that, the seller dared to say that the unit is still working so not a return under warranty. WTF ? I'll avoid these guys in the future.


I already ordered a DX3+ and a PA3s as a replacement. I hope I'll have more luck. I considered a SMSL stack but I think the DX3 is still a reference when it comes to budget DAC+AMP. And they easily fit on my desk. So crossing fingers that this time it will just work.
 
Top Bottom