• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). There are daily reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

Topping MX5, A new device?

terryforsythe

Member
Joined
May 4, 2022
Messages
47
Likes
14
I received my MX5 today and had some issues and managed to fix it, which might perhaps point somebody into hopefully the right direction.

There was no speaker output, just occasional 'pops', not loud, of some medium frequency. This occurred with analog and digital input. Headphone output was fine.
I upgraded the firmware, which was 1.02, to 1.04 and the problem remained, but the frequency of the pops grew to about 1 per second.
These pops seem to be in line with some issues I've been reading online.

On a different pair of speakers everything seemed fine!

So I started looking at my speaker filter and dug up some old forum thread. My woofer has a small capacitor over the main woofer inductor, which helps for higher frequency cone breakup. It had no resistor in series with this capacitor. I've read this could tax the amplifier in a way it might not like. Other crossovers of the same manufacturer DO have a resistor in series with the capacitor!

I had a few 6.8 Ohm 10 W resistors laying around so I soldered them in series with the little capacitor, and now everything seems fine.
There are no pops, no hisses, and I can't detect any noise when the speakers are muted.

Since my other two amplifiers, all simple class D or T type jobbies, worked fine with these speakers, maybe the MX5 is sensitive to inductive loading or whatever happens when this resistor was missing.

Of course each speaker is different, but it might point into the direction of some form of sensitivity that this amp has to certain speakers and filters.
Without the resistor in series with the capacitor that is in parallel with the inductor, the impedance of your speakers was too low for this amplifier at high frequencies. I don’t know what your capacitance values are, but at high enough frequencies the circuit will appear almost as a short circuit.
 

Usatencu

New Member
Joined
Aug 27, 2022
Messages
2
Likes
0
Hello! I just bought topping mx5 with kef q350 and chord c screen speaker cables. I was afraid about noises or something else, but for me it s running dead silent, I put volume 100 and nothing, completely silent in all modes. It s sound very nice, i don't have audiophile experience, previous setup was q acoustics m20, also nice but no tone controls and lacking little bit in bass. In conclusion it a good upgrade for me, i don't know why this amp has so many bad reviews, sound it s full and very clear
 

spiritofjerry

Active Member
Joined
May 8, 2018
Messages
146
Likes
102
From time to time I drop in on the community to see if any desktop all in one units that meet my needs have been developed, and here I was excited to see a new Topping offering that nearly does... only to be let down by design flaws with the switching noise and the lack of a subwoofer/pre out. The Loxjie unit from a few years back was almost there, but the headphone stage was just too anemic to be useful.

I'll check back in another 6-12 months.
 

Usatencu

New Member
Joined
Aug 27, 2022
Messages
2
Likes
0
I had some problems with dropping sound only by optical cable and only on tv mode, rest of them working, youtube sptotify. I contacted topping service by email and they send me private 1.5 update, it s not on the site. And now everything working perfect.
 

Attachments

  • MX5-2.zip
    211.5 KB · Views: 10
Top Bottom