• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Topping E30 DAC Review

Poyo

Member
Joined
Mar 3, 2021
Messages
9
Likes
0
Location
Reunion Island
Hi, can't edit my previous post I don't know why.
With native Windows 10 driver the issue is still here :( I don't know what to do
Only thing I can test is to put the DAC in an USB 2.0 port and reinstaller the drivers.

If the problem persist, i'm out of solution.
Am I the only one is this situation ?

Edit 1 : Problem is still here on USB 2.0 ports, now I'm trying another USB cable...
 
Last edited:

Ozu

Member
Joined
Feb 14, 2021
Messages
6
Likes
1
I made a quick research in the thread but I did not find about my issue, sorry if I am repeating which is already answered. On the screen of my brand new E30, via audirvana, nothing changing while I am playing pieces, only when I start to listen music, first piece shows the pcm value, but after all it is : - 0 0. 0. what should I do for seeing constantly the value of pcm that I am playing ?
 

solderdude

Major Contributor
Joined
Jul 21, 2018
Messages
8,358
Likes
17,365
Location
The Neverlands
I made a quick research in the thread but I did not find about my issue, sorry if I am repeating which is already answered. On the screen of my brand new E30, via audirvana, nothing changing while I am playing pieces, only when I start to listen music, first piece shows the pcm value, but after all it is : - 0 0. 0. what should I do for seeing constantly the value of pcm that I am playing ?
I suspect the E30 is in 'pre-amp' mode and shows the attenuation. You may want to set it to DAC mode. It will show the sample rate.
Default it comes in pre-amp mode.

If you don't plan on using the E30 as a pre-amp or use the volume control (remote), set the E30 in the DAC mode, just enter standby, press and hold the On/Off button on the touch panel for about 3 seconds until you see “DAC” written on screen, release the button and power it on.
 

Poyo

Member
Joined
Mar 3, 2021
Messages
9
Likes
0
Location
Reunion Island
Well, I've tested everything, I don't know how to fix that. It seems that I'm the only guy with this problem... last chance is to update my windows but I don't think it'll work...
 

Thalis

Active Member
Joined
Sep 2, 2020
Messages
293
Likes
172
Well, I've tested everything, I don't know how to fix that. It seems that I'm the only guy with this problem... last chance is to update my windows but I don't think it'll work...

why not find an OTG cable just to see if the problem persists with your phone?
 

Aldoszx

Active Member
Joined
Aug 19, 2019
Messages
212
Likes
127
What driver version do you have?
I strongly recommend to reinstall Windows !
I bet you'll be surprised by the results !
Just give it a try.
And try not to play much with drivers and settings anymore.
It is very easy to mess all the things up under Windows.
 

Ozu

Member
Joined
Feb 14, 2021
Messages
6
Likes
1
If you don't plan on using the E30 as a pre-amp or use the volume control (remote), set the E30 in the DAC mode, just enter standby, press and hold the On/Off button on the touch panel for about 3 seconds until you see “DAC” written on screen, release the button and power it on.
Thanks a lot, you were right, it works!
 

Poyo

Member
Joined
Mar 3, 2021
Messages
9
Likes
0
Location
Reunion Island
What driver version do you have?
I strongly recommend to reinstall Windows !
I bet you'll be surprised by the results !
Just give it a try.
And try not to play much with drivers and settings anymore.
It is very easy to mess all the things up under Windows.
I have 5.0 drivers, the latest. Maybe I have to reinstall but it's long :'( Yeah Windows over years crap itself a lot, it's so bad but playing video games, don't have choice.

Yes a good idea too. What would be your source?
My PC have a optical output, but only 24 bits 96 kHz, tomorrow my friend will loan me a optical cable.
 

Aldoszx

Active Member
Joined
Aug 19, 2019
Messages
212
Likes
127
I don't think is so long.
Usually, around 30-40 minutes, with all settings and software installed.
From my experience, the only solution to solve Windows issues is a clean install.
You will spend a lot more time trying to solve the problems than a clean reinstall !
Don't waste your time !
Take a 8GB USB, Media Creation Tool, Patch My PC for rapid install of a large list of usual software and tell us that everything is OK after that !
I own you a beer if not ;).

And as a tip, a best practice is to have at least 2 partitions: one only for Windows and another one (or more) for installed apps and games.
Also, always backup important things !
 
Last edited:

Poyo

Member
Joined
Mar 3, 2021
Messages
9
Likes
0
Location
Reunion Island
Guys, I tried something, I changed the positioning of my RCA pushing them a little bit far away from each other, switched the L and R and the problem didn't happened for few hours, maybe I'm just lucky for now...

Maybe stacking with RCA cable can do some "interference" ?
My cable plugs look like this and they were very closed to each other.

 
Joined
Jul 28, 2020
Messages
12
Likes
11
Are there any problems with E30 2008 ? As I'm about to contact my seller about replacing my L30 2006 which has 'exploding headphones' problem and I don't know if I should also ask about replacing E30 aswell. I don't have any problems with E30 or L30 but as many mentioned, problem with L30 hasn't happened for me 'YET', so if there is any future problem with E30 I would also like to change that. Thanks for response.
 
Joined
Jan 7, 2021
Messages
34
Likes
16
Are there any problems with E30 2008 ? As I'm about to contact my seller about replacing my L30 2006 which has 'exploding headphones' problem and I don't know if I should also ask about replacing E30 aswell. I don't have any problems with E30 or L30 but as many mentioned, problem with L30 hasn't happened for me 'YET', so if there is any future problem with E30 I would also like to change that. Thanks for response.
Hello, there is no problem with E30 post 2004+, anyway if you use USB only the polarity was fixed for earlier version with the new firmware.
Btw you have a 2008, so no problem at all :) Keep it
 
Joined
Jul 28, 2020
Messages
12
Likes
11
Hello, there is no problem with E30 post 2004+, anyway if you use USB only the polarity was fixed for earlier version with the new firmware.
Btw you have a 2008, so no problem at all :) Keep it
I probably read that wrong but someone said that 'new' 2009+ versions are totally fixed so i was worried that 2008 may still have some problems.
 
Joined
Mar 8, 2021
Messages
8
Likes
12
Location
Missouri
Question about DAC mode for topping E30

First of all, this forum has been incredible and very insightful! I'm grateful for all the reviews I've read and posts. I'm a long time peruser.

Re the Topping E30: My macbook on big sur Midiaudio settings for the E30 allows me to dial down the volume on the E30 - does this decimate the signal and reduce the Bits or is the e30 setup to keep the signal the same (it has a preamp mode)? I have an amp that gives me limited travel on the knob and if it doesn't decimate the sound - might be easier to just turn it down on my mac vs getting a passive preamp. Thanks!
 

voodooless

Major Contributor
Forum Donor
Joined
Jun 16, 2020
Messages
1,005
Likes
1,282
Location
Netherlands
Are there any problems with E30 2008 ? As I'm about to contact my seller about replacing my L30 2006 which has 'exploding headphones' problem and I don't know if I should also ask about replacing E30 aswell. I don't have any problems with E30 or L30 but as many mentioned, problem with L30 hasn't happened for me 'YET', so if there is any future problem with E30 I would also like to change that. Thanks for response.
That's like asking: Hey, my car has a broken wheel, should I also replace my steering wheel now..?
 

Poyo

Member
Joined
Mar 3, 2021
Messages
9
Likes
0
Location
Reunion Island
Hello guys,

just to keep you update for my issue with Topping E30.
For reminder :
- Loose left channel during listening/gaming
- Left channel very low volume and sound was like "compressed" and very awful

Test to find out a solution :
- Swapping L+R RCA cable to see if the problem was the cable : No results, problem remains
- Test another USB cable and RCA cable : No results, problem remains
- Test optical input : No results, problem remains
- Test to "unstack" them, putting L30 and E30 horizontally : No problem atm (48h = without any issue and sound is awesome)

I figured out that the L30 was pretty hot and where I live, it's summer, 32~35°C during 6 months a year, and the "winter" is 24~28°C :p
Do you think the problem was due to the temperature ? Does the E30 sensitive to hot condition ?

Now, the L30 still remains hot but the E30 is cold/warm.

Edit : Problem has arrived today :( I'm out of solution
 
Last edited:

shamus

New Member
Joined
Mar 10, 2021
Messages
4
Likes
1
Hi guys,

I received my L30 and E30 stack today and I ran into the following issues:

1) Whenever I change songs on Tidal, the window slider volume will change with the songs and it varies from songs to songs
2) I will get this error on Youtube "Audio renderer error. Please restart your computer" whenever I paused Tidal and play any video on Youtube.
  • If I manage to get the youtube video to play, there would be no audio. I would have to manually change the playback device to the from "REALTEK DIGITAL OUTPUT" to "TOPPING USB DAC" before I can get any audio.
When I try to change the volume manually from the volume slider, it will jump back to the "default" volume the song is being played at.
The E30 is connected via USB to my PC. (Windows 10)
The E30 is in DAC mode
I have enabled exclusive mode on Tidal
I have installed the latest E30 driver

Could it be the sample/bit rate difference of Youtube and Tidal?

Any inputs/solutions would be greatly appreciated. This is my first time using an AMP/DAC setup.

Thank you!
 
Last edited:
Top Bottom