• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Review and Measurements of Topping D50 DAC

Joined
Dec 31, 2018
Messages
11
Likes
1
Location
DFW
Toku wrote, "If there is a cause in the ESS chip according to the Topping 's answer, the same problem will exist not only in D50 but in DX7 (. . . ) which use(s) the same chip(s)"
The usual "passing of the buck". But let's wait and see . . . Topping may come through yet. I really like this little unit, but I think I'm not buying one until I at least see Topping address this issue responsibly. Do the principles at Topping follow this thread? (prolly not, but I do wonder what their biggest market is?)
- da Choge
 
Joined
Jan 2, 2019
Messages
30
Likes
7
If there is a cause in the ESS chip according to the Topping 's answer, the same problem will exist not only in D50 but in DX7s and SMSL SU-8 which use the same chip.
May or may not.

The easiest way to find out is to try on DX7s and SMSL if the issue is easily reproducible. No need to speculate.
 

yue

Active Member
Joined
Jul 21, 2018
Messages
275
Likes
254
If there is a cause in the ESS chip according to the Topping 's answer, the same problem will exist not only in D50 but in DX7s and SMSL SU-8 which use the same chip.
not necessary. During device initialization vendor can turn auto mute on or off via I2S.
It is possible that this issue only happens on certain kind of devices.
 

redfish

New Member
Joined
Jan 18, 2019
Messages
2
Likes
0
My D50 Coax in didn't work with my Micro iDSD Coax out, but worked like a charm when using the Sony CDP Coax out. Is there any fix can be done? Thanks!
P/S: I'm using a RCA cable for the Coax connection at the moment. You guys think this is the cause for the above prob?
I lent my D50 to another and he called up to say his coax would not work with the D50 Dac.
It was a better quality one he picked up recently 2nd hand and worked in his system.
Asked him to try another and he found a older cheaper one and that worked fine!
The one that did not work, I think he said it would not wake up the D50.
 
Joined
Jan 2, 2019
Messages
30
Likes
7
I tried to install D50 driver on my windows 10 desktop pc but it wasn’t successful. Windows says usb device is not recognized. I had a pci internal sound card which I disabled , but that didn’t help either. Any pointers?
 

BYRTT

Active Member
Patreon Donor
Joined
Nov 2, 2018
Messages
134
Likes
158
Location
Denmark (Jutland)
@Shangri-La
Technically device should work used on a USB 2.0 port and up, so note it won't work on old USB 1/1.1 ports should you happen have those old hardware protocols.

Suggest try another port and see what happens, if still no success try go to power plans in control panel and for current plan set USB suspension to deactivated.

Myself is on Win7 platform and driver is needed there to support UAC class 2 devices, but not shure Win10 if its latest build need driver installed in that some Win10 builds ago MS annouced native UAC class 2 device support.
 
Joined
Jan 2, 2019
Messages
30
Likes
7
@Shangri-La
Technically device should work used on a USB 2.0 port and up, so note it won't work on old USB 1/1.1 ports should you happen have those old hardware protocols.

Suggest try another port and see what happens, if still no success try go to power plans in control panel and for current plan set USB suspension to deactivated.

Myself is on Win7 platform and driver is needed there to support UAC class 2 devices, but not shure Win10 if its latest build need driver installed in that some Win10 builds ago MS annouced native UAC class 2 device support.
Thanks. My USB ports are 2.0, and Windows 10 is supposed to have USB Audio 2.0 native support, though the driver will be overwritten after 3rd party driver is installed. https://docs.microsoft.com/en-us/windows-hardware/drivers/audio/usb-2-0-audio-drivers

I tried a few different ports and the disabled USB suspension, still not working...
 
Joined
Dec 27, 2018
Messages
49
Likes
12
^ @Shangri-La i think i have similar problem

got mine today and can't make it to work:

WIN10 + Asus360 laptop

D50 serial# 1809+
device drivers 4.14

tried different cables + power supply and laptops USB ports
D50 turns on nicely, menus are ok
no cracks pops or hum if connected to amps+speakers

Topping device settings:

Topping USB audio device control panel
No device connected

sound settings:
no other devices than speakers found


WIN10 doesn't recognize D50 at all and can't find it as an audio/usb device

absolutely no communication between laptop and D50...

when i turn D50 manually on it gives "USB" then "unlock" and then menu shows in bottom line "usb input unlock" and turns itself off after a while

edit: unlike manual says, i didn't get notification from windows security to accept drivers, only notification i get is that manuals "to complete etc"-YES

editII: D50 doesn't show up to device manager USB devices, (USB3.0)

editIII: behaves same with pc, laptop and android phone (or with out USB connected) : USB doesn't connect


Any help appreciated, thanks


well, FUCK ME, after testing everything three times i checked bottom of the power supply....

voltage slide selector was just a touch out of 5V and it gave 3V instead...

but why it didn't work at all with another PSU :facepalm:
 
Last edited:
Joined
Jan 2, 2019
Messages
30
Likes
7
^ @Shangri-La i think i have similar problem

got mine today and can't make it to work:

WIN10 + Asus360 laptop

D50 serial# 1809+
device drivers 4.14

tried different cables + power supply and laptops USB ports
D50 turns on nicely, menus are ok
no cracks pops or hum if connected to amps+speakers

Topping device settings:

Topping USB audio device control panel
No device connected

sound settings:
no other devices than speakers found


WIN10 doesn't recognize D50 at all and can't find it as an audio/usb device

absolutely no communication between laptop and D50...

when i turn D50 manually on it gives "USB" then "unlock" and then menu shows in bottom line "usb input unlock" and turns itself off after a while

edit: unlike manual says, i didn't get notification from windows security to accept drivers, only notification i get is that manuals "to complete etc"-YES

editII: D50 doesn't show up to device manager USB devices, (USB3.0)

editIII: behaves same with pc, laptop and android phone (or with out USB connected) : USB doesn't connect


Any help appreciated, thanks


well, FUCK ME, after testing everything three times i checked bottom of the power supply....

voltage slide selector was just a touch out of 5V and it gave 3V instead...

but why it didn't work at all with another PSU :facepalm:
So you got it working with a proper power supply setting? I think I tried with PC usb power. Let me give it another go with an external power supply..
 

metal571

Member
Patreon Donor
Joined
Dec 1, 2017
Messages
6
Likes
21
I know this is not a big deal and was mentioned by one user in a past post in this thread, but are there any plans to fix the display of "00" for bit depth when using S/PDIF input on this DAC?
 
Joined
Dec 27, 2018
Messages
49
Likes
12
^Thanks! not sure if it measures very nicely ;) but it do sounds very nice.


I did some testing/listening today D50 vs Copland CDA822 player. CDA822 has (xlr) rca / spdif out and pre amp has relay inputs so signal cuts off completely when changing source, although it's fed to both ways at the same time (rca and spdif). This is not ment to be scientific comparison but more like listening if it sounds different, and indeed it does. But not by much.

I used The Eden House - Street spirit (fade out) as test track ( The looking glass cd ).

So, player is connected to pre amp with Nordost RedDawn rca's and D50 with basic spidf. Sound level is a tad higher with player. CDA822 has slightly better separation and bottom end, D50 very slightly more "klang" in top end. And that's about it. No real difference, if someone would play me whole track i couldn't tell 100% if it's D50 or CDA822 but, CDA822 has neat A-B option so i can "record" part of the song (it plays same part again, it doesn't save it to memory) and was able to pick some tiny differences. Biggest difference is singer is slightly more forward and articulation is clearer.

But there is but, CDA822 is HDCD-player and it converts regular 44kHz/16bit cd to 176.4khz / 24bit. :
https://hometheaterreview.com/copland-cda822-compact-disc-player-reviewed/
"The master clock is used for the CD transport, the sample rate converter and the D/A converter, the 44.1khz digital signal from the transport upsampled by to a 176.4khz, 24-bit signal while also removing jitter."

And when played through spdif it only gives 44.1kHz/16bit (not sure about bits, could be 24?) out ( D50 shows 44.1 / 00bits ).

But yes, both do their job very well and in regular listening there is no real world difference.

Copland CTA301 mkII ( Shuguang CV-181-Z )
Copland CDA822
Topping D50
Nelson Audio Image M9 ( TAD EF86, Shuguang 6N8PA "globe", 4 x Tungsol KT66 / unit )
Duntech Opal
 
Last edited:

Rems86

New Member
Joined
Jan 27, 2019
Messages
1
Likes
2
Hi there,
I am just new subscribed here but I read this thread since the beginning. I have also the D50 for last mid year : All work good and very happy with it. But I have met the same issue on the right channel when I was performing measurement with REW software. In fact during a sweep performing of 5,5s duration, I had like a mini "plop" after about 4s and nothing after 10-11KHz on my measurement. No issue on left channel or both working together.

I thought something was wrong with my amp, my cables... or my DAC. In fact I have noticed that 10-11Khz was a multiple of the sampling frequency tuned in Windows sound property of "headspeaker topping dac usb". I mean in default format in advanced statistics.

So, I change the value to 48KHz like the sample rate in the soundcard menu of REW. And everything was as it should be !
I don't know if my story can help on this subject... Whatever I think this is a firmware issue on mono right channel.

By the way, thanks to Amirm for his work here !
Rémi.
 
Last edited:
Joined
Dec 27, 2018
Messages
49
Likes
12
^ I have wall psu and power bank (13600mAh).
That wall psu (cheapest i found) gives some noise to my equipment even it's not connected to D50...
But through D50, nothing. Haven't noticed any sq difference psu vs pb and pb lasts easily whole day.

So, i think any 5V/1A wall psu will do.

I have been looking for solar powered power bank that could be in use ( = connected to D50 ) while charging, any ideas ? Thanks.
 
Top Bottom