• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). There are daily reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

NAD M33 Streaming Amplifier Review

ddingle

Member
Joined
Dec 8, 2021
Messages
8
Likes
4
Continuing to listen after the 3.16.2 update and it is such a nice improvement that I am wondering if all M33s were compromised by the tone controls being always in the circuit ( I assume that is the issue as noted by Audioexpress review and my own experience). I would suggest it had to be all M33s. If that is the case all the reviews were made on handicapped units. Mostly really good reviews, but since an old set of ears like mine observed a very noticeable improvement after the fix the reviews would have been better without the tone control handicap.
 
Last edited:

bvhme

Member
Joined
May 26, 2021
Messages
11
Likes
7
My unit doesn't seem to go into Standby by itself like the M10, I tried toggling on and off the 'auto standby' setting but it's not doing anything. Am I misunderstanding the unit?
 

pogo

Addicted to Fun and Learning
Joined
Sep 4, 2020
Messages
529
Likes
107
I am totally thrilled. My distortion problem described here is no longer audible after the last update:
Link

I have not changed anything on the DL correction or even remeasured!
 

Stefan

Member
Joined
May 29, 2021
Messages
67
Likes
13
Guys, not trying to spoil your party here, but nothing has changed with the latest update; especially not on the distortion issue…
 

ddingle

Member
Joined
Dec 8, 2021
Messages
8
Likes
4
Guys, not trying to spoil your party here, but nothing has changed with the latest update; especially not on the distortion issue…
I would say that I would/could be experiencing confirmation bias as I was hoping that the tone control update in 3.16.2 would eliminate the tone control circuits totally from the signal path when they were turned off in the menu. I can absolutely confirm that the tone controls were affecting the sound when turned off as after reading the review in AudioXpress I checked and sure enough the bass was turned up on my M33 even though I had never touched the controls since bringing the M33 home. I turned the bass to neutral which made a nice improvement in the sound even with the tone controls off. The Audioexpress reviewer actually viewed the increase in treble on a scope and confirmed the reduction in treble when he turned it down both with the tone controls on or off. So IMHO the tone control circuit was still affecting the sound in my M33 with the bass and treble in the middle or neutral setting as the circuit was still in signal path. I am assuming that NAD found why the tone control circuits were not turning off with the off control and applied a fix in 3.16.2. I am also assuming that the improvements I am hearing are due to those circuits being eliminated from the signal path and not confirmation bias as the improvement has been consistent with multiple sources and music I am very familiar with over a few days now. P.S. I haven't been following the other distortion being discussed. I am only familiar with the tone control issues.
 

pogo

Addicted to Fun and Learning
Joined
Sep 4, 2020
Messages
529
Likes
107
Guys, not trying to spoil your party here, but nothing has changed with the latest update; especially not on the distortion issue…
This is not quite right. My problem was solved, see also here:
Link

And by the way, the cloudy sound is also no longer present for me with DL enabled.
 

ddingle

Member
Joined
Dec 8, 2021
Messages
8
Likes
4
This is not quite right. My problem was solved, see also here:
Link

And by the way, the cloudy sound is also no longer present for me with DL enabled.
Hey Pogo, Try running Dirac again after the 3.16.2. I just updated the Dirac software version on my laptop as well and then ran Dirac pretty much the same way I have always with 12 measurements. Again confirmation bias is running rampant here, but regardless I am going to suggest it is noticeably better than before 3.16.2.
 

Hoeksel

Member
Joined
Nov 14, 2021
Messages
10
Likes
2
So, today after 5 weeks I got my M33 back from Denmark (I am in The Netherlands). My dealer could not tell what NAD did, they will check. Unfortunately, the noise floor issue..... is exactly as it was when I got the unit and after the first "repair". The dealer unpacked a brand new M33, it had exactly the same issue. We think it is the display. The moment the display turns on, the noise starts. So I do wonder if other NAD Masters units like the M12 have this issue as well. Or, I am extremely sensitive to this (spoiler alert, I am, but still this should not be acceptable).

So after 2 repairs, no change. Personally done with the brand NAD, never again. I am now considering next steps, I will contact my dealer later, but I can't imagine I can learn myself to ignore this so I will start looking for an alternative which does not have NAD written on it.
 

pogo

Addicted to Fun and Learning
Joined
Sep 4, 2020
Messages
529
Likes
107
From which production period does your M33 originate and in which range does your serial number refer?
 

Hoeksel

Member
Joined
Nov 14, 2021
Messages
10
Likes
2
From which production period does your M33 originate and in which range does your serial number refer?
The packaging shows date incoming 08-11-2021 (Dutch text, so probably label for when it arrived at NAD Netherlands?) and SN starts with H203.
 

pogo

Addicted to Fun and Learning
Joined
Sep 4, 2020
Messages
529
Likes
107
Mine is in this range: H209M33015xx
Production date could have been Sep'20 (209)!?
 

fcracer

Member
Forum Donor
Joined
Nov 10, 2020
Messages
99
Likes
144
So, today after 5 weeks I got my M33 back from Denmark (I am in The Netherlands). My dealer could not tell what NAD did, they will check. Unfortunately, the noise floor issue..... is exactly as it was when I got the unit and after the first "repair". The dealer unpacked a brand new M33, it had exactly the same issue. We think it is the display. The moment the display turns on, the noise starts. So I do wonder if other NAD Masters units like the M12 have this issue as well. Or, I am extremely sensitive to this (spoiler alert, I am, but still this should not be acceptable).

So after 2 repairs, no change. Personally done with the brand NAD, never again. I am now considering next steps, I will contact my dealer later, but I can't imagine I can learn myself to ignore this so I will start looking for an alternative which does not have NAD written on it.
Can you record the sound and share here? Mine is dead silent and I have some funky voltage in Beijing from 218V all the way out to 234V some days. No noises.
 

Hoeksel

Member
Joined
Nov 14, 2021
Messages
10
Likes
2
Can you record the sound and share here? Mine is dead silent and I have some funky voltage in Beijing from 218V all the way out to 234V some days. No noises.
Sound is already to be heard in post #942 by Stefan. The issue is unrelated to the way the power is supplied. I have good grounded 220 V/50 Hz, and the unit performs the same also on the treated setup at the dealer. Stefan also verified it is independent of how good your power supply line is.
Sound starts the moment the display shows light, but does not go away unfortunately if the display is turned OFF while the unit is ON.
 

Hoeksel

Member
Joined
Nov 14, 2021
Messages
10
Likes
2
Today I wanted to change a setting on my Logitech Harmony, basically a button to go to the HDMI ARC of the M33. To do this I had to take the HTRM 2 "brick/remote" that I did not use before. How does this even work? I can use the remote only for a few basic functions, mainly control the volume (up/down/mute), control BluOS (pause/play/next/..) and toggle speakers. But how do I change inputs? Could use some help here.
 

Hoeksel

Member
Joined
Nov 14, 2021
Messages
10
Likes
2
Thanks! So I learned not only my M33 has the coil whine from the unit, but also my remote does not work. I am unable to switch inputs, and surprisingly the HDMI is not even supported by the remote. I am done with the M33, time to move on.
 

pogo

Addicted to Fun and Learning
Joined
Sep 4, 2020
Messages
529
Likes
107
Guys, not trying to spoil your party here, but nothing has changed with the latest update; especially not on the distortion issue…

I started DL again yesterday after a long time (> one month) and got the following message in german:
dl-anderung_1135882.png


I have never received such a message before and it probably indicates a M33 DL implementation change.
As I wrote before, after the last BluOS update, my cloudy sound and distortion issue is no longer present for me with DL enabled.
 
  • Like
Reactions: gjm

Lieven

New Member
Joined
Jan 3, 2022
Messages
2
Likes
0
How can you access presets created in the BluOs app with the HTRM 2 remote?
 

pogo

Addicted to Fun and Learning
Joined
Sep 4, 2020
Messages
529
Likes
107
There is no possibility at the moment. As an alternative, there is the Bluesound RC1, which is highly recommended and can also call 10 presets directly.
 
Top Bottom