• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). There are daily reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

Motu M4: Using Sub + Mic (Feedback Loop)

BoredErica

Addicted to Fun and Learning
Joined
Jan 15, 2019
Messages
539
Likes
726
Location
USA
Hi,
I have Motu M4 and I'm hooking up my mic, speakers, subwoofer into it. My understanding is in order to get subwoofer to play with the main speakers, I need to enable "Loopback Mix" in Recording tab of my Windows audio devices settings.

1648156260617.png


1648156926665.png

This has worked just fine so far, but once I hooked up my new XLR mic the subwoofer is playing a ton of feedback loop, causing super loud bass. How do I play music with my subwoofer in addition to my main speakers, while being able to use my microphone for Skype/etc? I do not want to hear my own voice when I talk into the microphone. I have Loopback Mix enabled (here disabled in the picture) only because that's the only way I know of to get the sub to work with the mains. I feel like this can't be the way to do it and I must be doing something wrong. :'(




Extra info: The idea is to use Nvidia Broadcast to remove background noise with the mic. I dunno if that changes anything.

The monitor button in front of my Motu M4 is not activated.
Thanks

EDIT:
Think I fixed it?
Here are my settings:
1648158103764.png
I see now that Loopback didn't work to make my sub work with mains because in the settings for Loopback it wasn't set to 'listen to this device' and playback through this device wasn't set to Out 3-4 (which sub is connected to). I made "Loopback" enabled and playing the sub, and "Loopback Mix" Out 1-2, but unchecked "listen to this device". That way the mic works, but I'm not listening to myself which should remove the feedback.

All correct?
 

Attachments

  • 1648158095438.png
    1648158095438.png
    96.6 KB · Views: 24
Last edited:

RickSanchez

Major Contributor
Cartographer
Joined
Sep 4, 2019
Messages
1,162
Likes
2,410
Location
Austin, TX
A couple questions I have:
  1. What subwoofer are you using?
  2. How are you connecting your Motu M4 to the mains and the sub?
I have a (somewhat) similar 2.1 setup to you, except that I have a USB mic and a Focusrite Scarlett 2i2. I didn't have to change any Windows 10 settings for it to work: clean, normal sound with no feedback when using the USB mic. I use it all the time for Zoom calls -- using the speakers, not headphones -- and haven't had any issues. I also play music through it, but I never bother to turn the mic off. And when I plug in an XLR mic (Behringer ECM8000 measurement mic) for use with REW I haven't had any issues with feedback either.

Maybe this setting would work for you? In Windows 10 make sure for the mic device that the "Listen to this device" box is unchecked. (See option #1 in the article.)
 
OP
BoredErica

BoredErica

Addicted to Fun and Learning
Joined
Jan 15, 2019
Messages
539
Likes
726
Location
USA
A couple questions I have:
  1. What subwoofer are you using?
  2. How are you connecting your Motu M4 to the mains and the sub?
I have a (somewhat) similar 2.1 setup to you, except that I have a USB mic and a Focusrite Scarlett 2i2. I didn't have to change any Windows 10 settings for it to work: clean, normal sound with no feedback when using the USB mic. I use it all the time for Zoom calls -- using the speakers, not headphones -- and haven't had any issues. I also play music through it, but I never bother to turn the mic off. And when I plug in an XLR mic (Behringer ECM8000 measurement mic) for use with REW I haven't had any issues with feedback either.

Maybe this setting would work for you? In Windows 10 make sure for the mic device that the "Listen to this device" box is unchecked. (See option #1 in the article.)
Subwoofer is Rythimk F12.
Connection was as follows: Motu M4 TRS out in the back, 1-2 to PA5, PA5 to mains. 3 for subwoofer.
Settings: I think it was just Loopback Mix enabled, set to listen, and Motu 3-4.

I think I fixed it. What I didn't understand was there seems to be two loopbacks in recording tab, and they can be configured to include listening or not, and I can pick which device. So I set up one loopback for Motu 3-4 (sub) and check listen. Then other loopback for Motu 1-2 (which includes mic for some reason) and uncheck listen to device.
 
Last edited:

RickSanchez

Major Contributor
Cartographer
Joined
Sep 4, 2019
Messages
1,162
Likes
2,410
Location
Austin, TX
Then other loopback for Motu 1-2 (which includes mic for some reason) and uncheck listen to device.
Yeah, that's the part that seems off about how Win10 is handling this. Hence why I suggested trying to handle it at the device (mic) level instead of the Loopback level. But if you've got it working in the Loopback settings then stick with that!
 
OP
BoredErica

BoredErica

Addicted to Fun and Learning
Joined
Jan 15, 2019
Messages
539
Likes
726
Location
USA
Yeah, that's the part that seems off about how Win10 is handling this. Hence why I suggested trying to handle it at the device (mic) level instead of the Loopback level. But if you've got it working in the Loopback settings then stick with that!
Sorry, I'm not sure what you mean. How do I handle it at the mic level? In recording tab I don't see a device called "Earthworks M23". Back when I used my Blue Yeti USB mic, it'd show up as just the mic and whatever I change will just be for the mic. I just see "Motu 1-2", "Motu 3-4", "Loopback", "Loopback Mix".

Does your mic hooked up to Motu M4 via XLR show up as its own mic?
 

RickSanchez

Major Contributor
Cartographer
Joined
Sep 4, 2019
Messages
1,162
Likes
2,410
Location
Austin, TX
I tested again this morning, and I'm seeing the same as you on Win10:
  • USB mic (Yeti): when this is plugged into my audio interface Win10 recognizes it. (See screen shots below.)
  • XLR mic (Behringer ECM8000): when this is plugged into my audio interface Win10 does not see it.
So you're right, loopback may be the only way to control the "Listen to this device" function in Win10 when using an XLR mic through the Motu M4.


1648307358961.png
 

Attachments

  • 1648307306450.png
    1648307306450.png
    147.9 KB · Views: 15
Top Bottom