• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Matrix Audio Element X does not read the entire hard-drive

Joined
Oct 14, 2020
Messages
51
Likes
20
#1
Hello,
Took the delivery of the Element X on Monday, very impressed with how it sounds. Got a small, or maybe not so small problem however - it does not read the entire 4G portable hard-drive, only a part of it. The card-slot is empty, and there are no other drives attached to it, yet it stops at almost a quarter of a way. Have the same (mirrored) hard-drive with the same songs on it, and it behaves exactly the same.

Comments, suggestions are much appreciated.

thank you
 
OP
A
Joined
Oct 14, 2020
Messages
51
Likes
20
Thread Starter #2
Just got an email from Matrix Support

For the moment, we just support MBR format partition table of HHD, yours might be GPT format partition table.
Such is a known issue and our engineer will fix it soon.
I am surely surprised, as I have not seen the mention of the supported partition types in any of the reviews I have seen or red.
 
OP
A
Joined
Oct 14, 2020
Messages
51
Likes
20
Thread Starter #6
suggest you contact support. I also experience many software issues with M and hope they can fix them
I did contact them, the response was;

For the moment, we just support MBR format partition table of HHD, yours might be GPT format partition table.
Such is a known issue and our engineer will fix it soon


Which kind of made no sense at all. First because portable external hard-drives are always GPT, and I assume in the presentation below too;
, and secondly, I do not believe 4T external hard-drive can even be MBR. Which means there is not only the format limitation but also the size. Again, not what one would assume from this Q&A https://www.matrix-digi.com/en/Q&A/ , which states there is no limitation.

I made two partitions on one drive, now it works.
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
#7
I did contact them, the response was;

For the moment, we just support MBR format partition table of HHD, yours might be GPT format partition table.
Such is a known issue and our engineer will fix it soon


Which kind of made no sense at all. First because portable external hard-drives are always GPT, and I assume in the presentation below too;
, and secondly, I do not believe 4T external hard-drive can even be MBR. Which means there is not only the format limitation but also the size. Again, not what one would assume from this Q&A https://www.matrix-digi.com/en/Q&A/ , which states there is no limitation.

I made two partitions on one drive, now it works.
Good that you find a solution. Yes I do agree there are some restriction don’t make sense. An another example I use SMB and it only support version 1 and 2.
 

muslhead

Active Member
Forum Donor
Joined
May 28, 2020
Messages
190
Likes
58
#8
2tb is the limit for mbr. Above that is has to be gpt.
I have a matrix m and i and both work fine with my gpt drives.
 
OP
A
Joined
Oct 14, 2020
Messages
51
Likes
20
Thread Starter #9
2tb is the limit for mbr. Above that is has to be gpt.
I have a matrix m and i and both work fine with my gpt drives.
How big are your drives?

I made two equal partitions on WD 4T portable drive, and they work fine. It did not scan the entire 4T in one partition though.
 

muslhead

Active Member
Forum Donor
Joined
May 28, 2020
Messages
190
Likes
58
#10
i have multiple drives ranging from 4-10tb but mine are set in a raid array so maybe that is the difference?
 
OP
A
Joined
Oct 14, 2020
Messages
51
Likes
20
Thread Starter #11
i have multiple drives ranging from 4-10tb but mine are set in a raid array so maybe that is the difference?
Really? Would that suggest that my element x is defective? - It does not seem to read the full 4T hdd. Only when partitioned into 2.
 

muslhead

Active Member
Forum Donor
Joined
May 28, 2020
Messages
190
Likes
58
#12
Maybe or maybe my setup is different which accounts for my success and yours not working.
Are you just connecting a single drive or is this a NAS?
Mine is a NAS so i assumed in my reading of your question yours was too.
After rereading maybe you are speaking of just a single drive
Why that would matter, I have no idea
 
OP
A
Joined
Oct 14, 2020
Messages
51
Likes
20
Thread Starter #13
Maybe or maybe my setup is different which accounts for my success and yours not working.
Are you just connecting a single drive or is this a NAS?
Mine is a NAS so i assumed in my reading of your question yours was too.
After rereading maybe you are speaking of just a single drive
Why that would matter, I have no idea
I connect single drive, have not started with NAS yet.
Maybe it even works, it seems like it is reconnecting at some point during the scan and then starts again. Like as if it is under-powered in some way, but then it works when the partitions are smaller.
 

Bombadil

Active Member
Forum Donor
Joined
Jan 28, 2017
Messages
249
Likes
220
Location
Davis CA
#14
2tb is the limit for mbr. Above that is has to be gpt.
I have a matrix m and i and both work fine with my gpt drives.
Curious if you have tried using AirPlay with your units. I had multiple Element components and when streaming Spotify through AirPlay the phone would connect with one player but would then refuse to reconnect with another player. Ended up returning all of the units for various problems (other than AirPlay).
 
OP
A
Joined
Oct 14, 2020
Messages
51
Likes
20
Thread Starter #15
Curious if you have tried using AirPlay with your units. I had multiple Element components and when streaming Spotify through AirPlay the phone would connect with one player but would then refuse to reconnect with another player. Ended up returning all of the units for various problems (other than AirPlay).
No, I did not try AirPlay. What other problems did you have with it?
 

Bombadil

Active Member
Forum Donor
Joined
Jan 28, 2017
Messages
249
Likes
220
Location
Davis CA
#16
No, I did not try AirPlay. What other problems did you have with it?
I started with the M; it worked fine with an ethernet connection but would drop off the network periodically if connected wirelessly. I did not have access to a hard line for this unit and so returned it. BTW my wireless network is very robust, no problem with many other devices. Next was an Element i; it worked better with regard to connecting but after about a month it stopped connecting altogether (wireless) even if sitting next to the router. And when the unit was turned off the speakers would emit a very strange sound, like air leaking from a balloon. I actually have an audio file (arghh arghh) of the sound but unfortunately it cannot be attached to this message. I have a feeling that the brainiacs on this site would probably recognize the problem but oh well. That unit was returned. Then I purchased and X and P. I know, dumb to keep buying them but they offer such superb performance (when working). The P had a fault in the volume control, I had to listen at PLUS 10-15 for sufficient volume, then it went out altogether within 2-3 weeks. The X performed fine, but it was the unit in which I noticed that AirPlay would only work on one unit, you couldn't go from one to the other. That could well be an issue with AirPlay, I think the version in the Element series is the older iteration, maybe it would be fixed with AirPlay2. My dealer was very understanding and I was able to return all units but clearly I was not impressed with the QC at Matrix. Matrix support tries to be helpful, they are quite sincere, but they are off on weekends and all Chinese holidays, and when you do finally hear from them the language difference is a real problem. I've ended up with a Bluesound Node2i for streaming to my major system via Anthem STR preamp, and a Bluesound Powernode2i as an integrated and streamer for my casual listening setup. They both work flawlessly and the app is excellent, could not say the same for the MA app.
 

somy

Senior Member
Joined
Aug 20, 2020
Messages
312
Likes
62
#17
I started with the M; it worked fine with an ethernet connection but would drop off the network periodically if connected wirelessly. I did not have access to a hard line for this unit and so returned it. BTW my wireless network is very robust, no problem with many other devices. Next was an Element i; it worked better with regard to connecting but after about a month it stopped connecting altogether (wireless) even if sitting next to the router. And when the unit was turned off the speakers would emit a very strange sound, like air leaking from a balloon. I actually have an audio file (arghh arghh) of the sound but unfortunately it cannot be attached to this message. I have a feeling that the brainiacs on this site would probably recognize the problem but oh well. That unit was returned. Then I purchased and X and P. I know, dumb to keep buying them but they offer such superb performance (when working). The P had a fault in the volume control, I had to listen at PLUS 10-15 for sufficient volume, then it went out altogether within 2-3 weeks. The X performed fine, but it was the unit in which I noticed that AirPlay would only work on one unit, you couldn't go from one to the other. That could well be an issue with AirPlay, I think the version in the Element series is the older iteration, maybe it would be fixed with AirPlay2. My dealer was very understanding and I was able to return all units but clearly I was not impressed with the QC at Matrix. Matrix support tries to be helpful, they are quite sincere, but they are off on weekends and all Chinese holidays, and when you do finally hear from them the language difference is a real problem. I've ended up with a Bluesound Node2i for streaming to my major system via Anthem STR preamp, and a Bluesound Powernode2i as an integrated and streamer for my casual listening setup. They both work flawlessly and the app is excellent, could not say the same for the MA app.
Sorry to hear your experience. Apparently besides good measurement/sound there are also other things to consider when choosing a HiFi product. Also learned the hard way with M.
 

SJ777

Senior Member
Forum Donor
Joined
Jul 29, 2020
Messages
475
Likes
606
Location
UK
#18
Sorry to hear your experience. Apparently besides good measurement/sound there are also other things to consider when choosing a HiFi product. Also learned the hard way with M.
The more I read the posts on this thread, alongside the Element M thread, the more convinced I am that there's a gaping chasm between hardware and software when it comes to network streamers. Why don't manufacturers like Matrix simply build their excellent hardware around an RPi? Is it because the RPi appears to be too DIY and they're after something more bespoke?
 
OP
A
Joined
Oct 14, 2020
Messages
51
Likes
20
Thread Starter #19
I started with the M; it worked fine with an ethernet connection but would drop off the network periodically if connected wirelessly. I did not have access to a hard line for this unit and so returned it. BTW my wireless network is very robust, no problem with many other devices. Next was an Element i; it worked better with regard to connecting but after about a month it stopped connecting altogether (wireless) even if sitting next to the router. And when the unit was turned off the speakers would emit a very strange sound, like air leaking from a balloon. I actually have an audio file (arghh arghh) of the sound but unfortunately it cannot be attached to this message. I have a feeling that the brainiacs on this site would probably recognize the problem but oh well. That unit was returned. Then I purchased and X and P. I know, dumb to keep buying them but they offer such superb performance (when working). The P had a fault in the volume control, I had to listen at PLUS 10-15 for sufficient volume, then it went out altogether within 2-3 weeks. The X performed fine, but it was the unit in which I noticed that AirPlay would only work on one unit, you couldn't go from one to the other. That could well be an issue with AirPlay, I think the version in the Element series is the older iteration, maybe it would be fixed with AirPlay2. My dealer was very understanding and I was able to return all units but clearly I was not impressed with the QC at Matrix. Matrix support tries to be helpful, they are quite sincere, but they are off on weekends and all Chinese holidays, and when you do finally hear from them the language difference is a real problem. I've ended up with a Bluesound Node2i for streaming to my major system via Anthem STR preamp, and a Bluesound Powernode2i as an integrated and streamer for my casual listening setup. They both work flawlessly and the app is excellent, could not say the same for the MA app.
I am sorry to hear that.
 
Top Bottom