• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). There are daily reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

Level variation with RPi streamer into different DACs

scrubb

Member
Forum Donor
Joined
Aug 7, 2020
Messages
60
Likes
122
Location
Chicago, IL
I'm having a strange levels issue with my Raspberry Pi 4 streamer running Moode. Maybe someone can tell me what I'm doing wrong.

I stream via Airplay to RPi, USB out to MiniDSP 2x4HD, analog out to Vanatoo Transparent Zero powered speakers. It sounds good, but the volume is very low. I have to crank the volume knob on the Vanatoos. Computer volumes are all at max, 2x4HD level is at 0 dB.

If I connect the computer directly to the 2x4HD via USB the volume is fine, plenty of headroom, I have to turn the Vanatoos back down.

Sounds like an issue with the RPi so far, right? But: If I stream to the RPi, USB out to Vanatoo's internal DAC - skipping the 2x4HD - volume is also fine.

So what's going on?
 
OP
scrubb

scrubb

Member
Forum Donor
Joined
Aug 7, 2020
Messages
60
Likes
122
Location
Chicago, IL
If it's not available through the Moode interface, I'm not sure I have the skills to access it. I'll have to learn more about source code in the Pi.
Is this something that could change with different USB destinations out from the Pi?
 
OP
scrubb

scrubb

Member
Forum Donor
Joined
Aug 7, 2020
Messages
60
Likes
122
Location
Chicago, IL
In Moode there is an ASLA volume. It is at 100 in all cases.
 

MarcosCh

Addicted to Fun and Learning
Joined
Apr 10, 2021
Messages
804
Likes
511
Ok I am VERY newbie but will try to help as others did with me. This is just to access alsamixer. What you need to do there or if there is a better way to do it, i have zero idea:

In Moode go to "system", scroll down to "local services" and in "SSH term server" switch to "on" and press "set"
Then, just below, press "open web ssh terminal"
A command window will open asking for a user, that is "pi" and then a password, that is "moodeaudio"
Once in, type "alsamixer" and there you are. You will see you have options to select each output and set the volume for each.
hope it helps
 
OP
scrubb

scrubb

Member
Forum Donor
Joined
Aug 7, 2020
Messages
60
Likes
122
Location
Chicago, IL
Your Airplay device likely has a volume control as well, what is that set at? Do you have any processing applied in the 2X4HD?

Michael
Yes, the laptop running airplay has all volume controls at full in every scenerio. The 2x4HD does have processing applied, but the volume is fine when running USB direct from the laptop vs USB from the Pi.
 

abdo123

Master Contributor
Forum Donor
Joined
Nov 15, 2020
Messages
5,659
Likes
5,499
Location
Brussels, Belgium
  • Open a terminal.
  • Enter "alsamixer" and press the Enter key.
  • You will now see a user interface. In this user interface, you can do the following:
    • Select your correct sound card using F6 and select F5 to see recording controls as well
    • Move around with left and right arrow keys.
    • Increase and decrease volume with up and down arrow keys.
    • Increase and decrease volume for left/right channel individually with "Q", "E", "Z", and "C" keys.
    • Mute/Unmute with the "M" key. An "MM" means muted, and "OO" means unmuted. Note that a bar can be 100% full but still be muted, so do check for this.
    • Exit from alsamixer with the Esc key.
 
Top Bottom