• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Khadas tone board external power

Joined
Apr 6, 2019
Messages
7
Likes
1
#1
Hello. I use the same power supply, that have two +5volt exit, for supply raspberry and khadas.

I use this cable, that divide signal from power, then the power of to khadas from power supply and not from raspberry.

https://www.audiophonics.fr/fr/cabl...our-alimentation-et-donnees-20cm-p-14052.html

The problem is that the sound have high distortion.

To resolving, I must disconnect khadas manually from power and reconnect it, then sounds is good.

Why ?
Thanks
 

gvl

Major Contributor
Joined
Mar 16, 2018
Messages
2,327
Likes
2,261
Location
SoCal
#2
I don't know why this happens but I have a similar issue when powering KTB from Schiit Wyrd and using SPDIF. When I flip the switch on the Wyrd KTB distorts, I need to unplug it and plug it back in then all is good. There may be some initial supply voltage instability that confuses the KTB and it fails to initialize properly. Try a different PSU maybe.
 

Gradius

Active Member
Joined
Aug 17, 2019
Messages
295
Likes
184
Location
Iquique, Chile
#3
Did you tried a ferrite on that cable? Sounds like an initial EMI problem / ground problem.

raspberry3 has high noise on USB ports, it was corrected on v4.
 
Top Bottom