• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required. There are many reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

E1DA Cosmos ADC

BluegrassDan

New Member
Joined
Apr 16, 2024
Messages
3
Likes
1
Thank you so much! Yes, it was showing blue lights. I'll go in, adjust the settings, and report back.

I appreciate the help.
 

BluegrassDan

New Member
Joined
Apr 16, 2024
Messages
3
Likes
1
All is well. Muted the "primary" fader and it's doing what it should.

How about the low latency headphone situation? Thoughts?
 

USER

Major Contributor
Forum Donor
Joined
Mar 30, 2019
Messages
1,022
Likes
1,691
Does anyone know if it is possible to use the E1DA Cosmos in an IEM measurement set-up with a Gras IEC711 coupler (a third party one if that matters)?

I can't seem to get a high-enough signal on REW to use them, even with the Scaler at max output. Is the output of the "IEC711" coupler/measurement mic just too low for the Cosmos/Scaler or am I doing something wrong? It works fine with my Apple USB-C dongle.

 

staticV3

Master Contributor
Joined
Aug 29, 2019
Messages
8,654
Likes
13,987
Does anyone know if it is possible to use the E1DA Cosmos in an IEM measurement set-up with a Gras IEC711 coupler (a third party one if that matters)?
Yes. I did that with a IEC60318-4 Clone coupler->B&K 1704 signal conditioner -> Cosmos APU -> Cosmos ADC.

I can't seem to get a high-enough signal on REW to use them, even with the Scaler at max output. Is the output of the "IEC711" coupler/measurement mic just too low for the Cosmos/Scaler or am I doing something wrong?
Your clone coupler probably needs Plug-in power. Are you currently supplying Plug-in power to your coupler?
 

USER

Major Contributor
Forum Donor
Joined
Mar 30, 2019
Messages
1,022
Likes
1,691
Yes. I did that with a IEC60318-4 Clone coupler->B&K 1704 signal conditioner -> Cosmos APU -> Cosmos ADC.


Your clone coupler probably needs Plug-in power. Are you currently supplying Plug-in power to your coupler?
Ah, thank you for the info. I did not think about supplying power to it as I didn't think the Apple dongle was doing that for whatever reason. I was hesitant to get the conditioner as I thought that it likely adds noise that would make the specific use of the Cosmos redundant. Is there an alternative source of power that simply does that so that I can use the Scaler for gain? Perhaps that's not even a thing.

Now I am curious if the E1DA USB headphone amp is the best solution to this if it provides the best of both worlds, power and specs. I just want to figure out if the apple dongle is giving me a low frequency droop because of impedance issues.
 

staticV3

Master Contributor
Joined
Aug 29, 2019
Messages
8,654
Likes
13,987
Is there an alternative source of power that simply does that so that I can use the Scaler for gain?
Sure. Just do Coupler->Rode VXLR+->Cosmos APU->Cosmos ADC and enable phantom power on the APU.

Edit:
There's also a VXLR Pro model with transformer balanced output, which however seems to introduce some distortion:
 

Music1969

Major Contributor
Joined
Feb 19, 2018
Messages
4,700
Likes
2,879
IEC60318-4 Clone coupler->B&K 1704 signal conditioner -> Cosmos APU -> Cosmos ADC.
Can you show how you connect ?

What cables from coupler to B&K?

And what cables from B&K to Cosmos ADC?

1713963396240.png
 

KSTR

Major Contributor
Joined
Sep 6, 2018
Messages
2,881
Likes
6,451
Location
Berlin, Germany
I'm trying to flash latest FW into the CosmosADC (non-iso) but the flash tool reports "no device available". The Cosmos is correctly enumerated and visible to other apps like the TweakCosmos app and REW (WASAPI Exclusive)
What am I missing?
1714037202454.png
 

staticV3

Master Contributor
Joined
Aug 29, 2019
Messages
8,654
Likes
13,987
Sorry guys, why do I need to watch a completely undecipherable/blurry video when two or three sentences of written word would do?
The video is in crisp Full HD.
Not sure which part is undecipherable. Please tell me, so that I can assist.
 

pkane

Master Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
5,786
Likes
10,562
Location
North-East
View attachment 365800

And your response doesn't answer my question. If you've done a FW update, why not share how you did it?

The Auto button initiates the update, after you find the device and select the firmware file. The video seems to recommend to uninstall and then reinstall the Comtrue driver, first. Last time I did it, it worked without reinstalling and I didn't have to look for the right PID.
 
Top Bottom