• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). Come here to have fun, be ready to be teased and not take online life too seriously. We now measure and review equipment for free! Click here for details.

Beta Test: Multitone Loopback Analyzer software

Grooved

Active Member
Joined
Feb 26, 2021
Messages
296
Likes
191
Hey @pkane,

Since few days, Multitone stopped working, whatever the version I use (10.0.11 or 10.0.10).
View attachment 174201
This message occurs with either ASIO, WASAPI, DirectSound, whatever for input or output (E1DA Cosmos).

Just tested 1.0.12. Still the same. I've either this with ASIO (Matrix or Topping):

View attachment 174202

Or this with WASAPI:

View attachment 174203

Any thoughts?
Got the same thing yesterday, but I don't remember if it was coming from the "shared mode" or if it was another software opened and having exclusive mode on the same device.
I also got the ASIO devices only, no WASAPI devices appearing, which was fixed after rebooting the computer, so maybe it was from installing the last version without uninstalling first the previous one (which I did every time before this last one)
Sorry to not remember the problem but it was working after that and I didn't get it anymore
 
Last edited:
OP
pkane

pkane

Major Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
2,797
Likes
4,747
Location
North-East
Got the same thing yesterday, but I don't remember if it was coming from the "shared mode" or if was another software opened and having exclusive mode on the same device.
Sorry to not remember the problem but it was working after that and I didn't get it anymore

That error is indicating that there are no audio channels available through this driver (channel range is from 0 to 0 :)), while Multitone is asking for a 2 channel input device. The reason, most likely, is that an output device was selected for input, or vice versa (@VintageFlanker -- please check)

index.php
 
Last edited:

VintageFlanker

Major Contributor
Forum Donor
Joined
Sep 20, 2018
Messages
2,634
Likes
6,917
Location
Paris
For ASIO, did you set the output sample rate in settings? It needs to be selected for the rate that's supported by the driver.

For WASAPI, try switching between shared and not shared modes to see if it makes a difference.


-Paul
It was WASAPI shared mode that caused trouble. Fixed ! Many thanks, @pkane !:)
 
OP
pkane

pkane

Major Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
2,797
Likes
4,747
Location
North-East
Quick update to v1.0.13 based on the feedback from @IVX.

Please note that with this version, you'll need to set the system volume control to the desired level (usually 100%) for measurements. Multitone will no longer do this automatically to accommodate devices such as Cosmos ADC that use the volume setting for a different purpose.

Changes in 1.0.13

  • Change: Multitone will no longer automatically set the system volume control to 100%. The user will need to make that change manually, if desired.
 
Last edited:
Top Bottom