• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). There are daily reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

Beta Test: Multitone Loopback Analyzer software

OP
pkane

pkane

Major Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
4,186
Likes
7,196
Location
North-East
Thanks! It actually worked to my benefit for that post. The bug that became a feature :)

You probably know this, but if you want to show only the available data in the measurement range, just click on the 'Freq' label above the plot. It'll zoom in to set the minimum and maximum frequency for the plot to match your selected bandwidth.
 

Rantapossu

Active Member
Joined
Jul 21, 2022
Messages
268
Likes
193
@pkane could it be possible to implement the newest recording features of MT (For example the ASIO channel selector and the several fixes for the rare but possible problems with certain sound card combinations) to DeltaWave, so that both programs woud use the similar recording engine? There has been a lot of recording tweaks for Multitone lately (since the last public release of Deltawave) and it would certainly be beneficial for DeltaWave to have them too.

And do you have time to do some bug fixes for DeltaWave too? I tried it again after a while and found several bugs. I can report them for you, if you still want to continue bug fixing...
 
OP
pkane

pkane

Major Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
4,186
Likes
7,196
Location
North-East
@pkane could it be possible to implement the newest recording features of MT (For example the ASIO channel selector and the several fixes for the rare but possible problems with certain sound card combinations) to DeltaWave, so that both programs woud use the similar recording engine? There has been a lot of recording tweaks for Multitone lately (since the last public release of Deltawave) and it would certainly be beneficial for DeltaWave to have them too.

And do you have time to do some bug fixes for DeltaWave too? I tried it again after a while and found several bugs. I can report them for you, if you still want to continue bug fixing...

I do have a version of DeltaWave where I added most of the audio driver changes/fixes for MT. It's not fully tested yet, but it is working. Of course, if you have bug reports, please share them. Please post in the DeltaWave thread with those.

https://www.audiosciencereview.com/...-test-deltawave-null-comparison-software.6633
 

Rantapossu

Active Member
Joined
Jul 21, 2022
Messages
268
Likes
193
I do have a version of DeltaWave where I added most of the audio driver changes/fixes for MT. It's not fully tested yet, but it is working.

Is it possible to upload it for beta testing?

Of course, if you have bug reports, please share them. Please post in the DeltaWave thread with those.

It was my plan to report there. You don't know what Pandora's box you opened when you let me to break DeltaWave too... ;)
 

Sokel

Major Contributor
Joined
Sep 8, 2021
Messages
1,577
Likes
1,123
@Rantapossu
Can you please check my broken R channel now? :p

rch.PNG


Can I please have my EE degree tomorrow morning? :facepalm:

(contact spray can make miracles if you heat it a little too ;) )
 
OP
pkane

pkane

Major Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
4,186
Likes
7,196
Location
North-East
Much simpler,I opened it all,removed all knobs,etc,bathed it with contact spray and heat it up with the hair dryer.
The original plan was to set it on fire but fixed the right channel instead :),

So, the recommendation is to wash your audio equipment regularly for best results? ;)
 

Moto

Active Member
Joined
Jan 19, 2021
Messages
140
Likes
30
Paul, I was doing a level sweep and got the first plot. Then to check if there was really something going on I plotted a smaller range.
why would the first plot rise like that from 1.2 to 1.1? Just a glitch like the first hump?
 

Attachments

  • Level Sweep 1.jpg
    Level Sweep 1.jpg
    400.6 KB · Views: 10
  • Level Sweep 2.jpg
    Level Sweep 2.jpg
    401.8 KB · Views: 10
Last edited:

Moto

Active Member
Joined
Jan 19, 2021
Messages
140
Likes
30
Another question. At the beginning of this sweep it said it was going to make 11 measurements but only 10 are plotted.
 

Attachments

  • Last Measurement.jpg
    Last Measurement.jpg
    408.5 KB · Views: 11
OP
pkane

pkane

Major Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
4,186
Likes
7,196
Location
North-East
Paul, I was doing a level sweep and got the first plot. Then to check if there was really something going on I plotted a smaller range.
why would the first plot rise like that from 1.2 to 1.1? Just a glitch like the first hump?
Looks like a glitch. Simplest way to figure it out is to watch the waveform as it's being captured for each point. You can stop the capture once you get a large jump like that and then look at what happened. It can be noise spikes, or possibly some gaps in the capture if something took CPU time away from Multitone as it was analyzing and capturing the sweep points. Increase ASIO buffer size if you can, as that can also result in occasional gaps if the CPU isn't fast enough to keep up with processing continuous FFTs.

Another question. At the beginning of this sweep it said it was going to make 11 measurements but only 10 are plotted.
I'll take a look and see if I can reproduce this. Is it happening every time, or just occasionally?
 

Moto

Active Member
Joined
Jan 19, 2021
Messages
140
Likes
30
Looks like a glitch. Simplest way to figure it out is to watch the waveform as it's being captured for each point. You can stop the capture once you get a large jump like that and then look at what happened. It can be noise spikes, or possibly some gaps in the capture if something took CPU time away from Multitone as it was analyzing and capturing the sweep points. Increase ASIO buffer size if you can, as that can also result in occasional gaps if the CPU isn't fast enough to keep up with processing continuous FFTs.


I'll take a look and see if I can reproduce this. Is it happening every time, or just occasionally?
All the time. I also tried with .05 step and its the same. Says 21 measurements but plots 20.
 
OP
pkane

pkane

Major Contributor
Forum Donor
Joined
Aug 18, 2017
Messages
4,186
Likes
7,196
Location
North-East
So far, so good. It seems be working OK. In the process, I added support for higher sampling rates, up to 768k and up to DSD256 (over DOP). Only output works with DSD for now, recording is still over PCM.

ADI-2 Pro FS at 12Mhz (DSD256/48k) recorded 384k with E1DA ADC:

Capture.PNG
 
Top Bottom