• WANTED: Happy members who like to discuss audio and other topics related to our interest. Desire to learn and share knowledge of science required as is 20 years of participation in forums (not all true). There are daily reviews of audio hardware and expert members to help answer your questions. Click here to have your audio equipment measured for free!

Apple Music Spatial Audio review and question

MarcR

Member
Forum Donor
Joined
Apr 12, 2021
Messages
13
Likes
13
I have become a huge fan of Apple Music Spatial Audio, and I regularly review the Now in Spatial Audio listing to discover new Dolby Atmos music. The experience of well-crafted Atmos mixes in my home theater room has revitalized my interest in music - at its best, the sonic experience is revelatory.

Over time I have become more interested in new music, which at its best takes greater advantage of the larger canvas afforded by Atmos to the artists and engineers. Prioritizing Atmos mixes has broken me out of a rut to discover artists and genres that I had previously discounted.

And while not all of the after-the-fact mixes sound like improvements to me, many do. Check out The Allman Brothers' Melissa from Eat a Peach for a good example.

All that said, I have tried toggling Atmos on and off on the Android app with earbuds in, and I can't tell the difference - at best, the binaural downmix of Atmos is a pale shadow of the 9.2.6 experience.

This brings me to my question. Playing Atmos cuts from a 2021 Apple TV 4K through a Trinnov Altitude 16 works well generally, but I cannot play one particular album. It's Noah Cyrus' The Hardest Part. It will play a couple of the tracks, but the ATV4K skips or quickly goes silent for most of them. (My ATV4K software is up to date as of today.) I suspect that the Apple Music-hosted bitstream files needed to deliver Atmos to a processor are corrupt. I wonder if anyone else can reproduce this, either with the A16 or another HT processor.

More generally, has anyone experienced this with other Apple Music Atmos content delivered by the ATV4K?
 

bevok

Member
Joined
Dec 28, 2020
Messages
49
Likes
25
Hi Marc
Just noticed this. Yes spacial audio/Atmos is amazing and personally I think its great that Apple’s adoption of it seems to have really accelerated multichannel music at long last to a wide audience (I know its not exclusive to them but I think they’ve really driven adoption).
I’d missed this album so thanks for the heads up. On my Apple TV both the standard and deluxe version seem to play in Atmos fine on a selection of tracks (except the bonus tracks on the deluxe which are lossless only). Perhaps its been sorted in the interim.
Bevan
 
OP
MarcR

MarcR

Member
Forum Donor
Joined
Apr 12, 2021
Messages
13
Likes
13
Thanks for the reply, Bevan. I received similar information in response to an inquiry in another forum. I closed that discussion with this summary, which I think may be helpful to other ATV4K+ owners:

Seeing that this album plays correctly on another identical ATV4K+ inspired me to poke around a bit more in the ATV4K+ settings. It turns out that Atmos can be configured in two places, the Video and Audio area and also in Apps / Music. Previously I had tried all of the settings under Video and Audio - those settings had affected the playback protocol as expected, but the tracks on the album continued to go silent and skip.

When I disabled Atmos in Apps / Music this morning, the songs on the album played correctly, and when I reenabled Atmos they continued to play correctly. Initially after fixing one of the songs in this way, I tried to fix the rest of the album quickly by playing only a small portion of each of the corrupted songs with Atmos off, but that didn't work. I had to play each song through completely with Atmos off in Apps / Music to fix it.

Clearly this is a caching issue - my ATV4K+ had stored corrupt versions of the songs on that album locally. Playing the Lossless versions of those songs triggered replacement of the corrupt cached Atmos versions so that future Atmos plays would download fresh valid bitstreams from the Apple Music servers.

I do recall attempting to play tracks on this album when it was listed in a pre-release state with just one or two of the tracks available but all of the tracks listed. There were errors at the time - I bet that's when the ATV4K+ cache was corrupted.
 

bevok

Member
Joined
Dec 28, 2020
Messages
49
Likes
25
Gosh that's excellent troubleshooting (and an exhausting process to resolve!). I'll have a listen to the album now . . . :)
 
Top Bottom